QLE 2.1 fails to start in Ubuntu 14.04

Bug #1283167 reported by Alin Andrei on 2014-02-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
QLE Unity Quicklist editor
Critical
Jacob Vlijm

Bug Description

I just upgraded to QLE 2.1 from the PPA in Ubuntu 14.04 Trusty Tahr and it fails to start with the following error:

h: 1: cannot create /home/andrei/.config/qle/current_theme.txt: Directory nonexistent
Traceback (most recent call last):
  File "/usr/bin/qle_quicklisteditor", line 4017, in <module>
    MainWindow()
  File "/usr/bin/qle_quicklisteditor", line 47, in __init__
    self.prepare_environment()
  File "/usr/share/qlequicklisteditor/qle_fileactions.py", line 534, in prepare_environment
    self.gettheme()
  File "/usr/share/qlequicklisteditor/qle_fileactions.py", line 459, in gettheme
    self.colorvalue = self.get_colorvaluesfromfile()
  File "/usr/share/qlequicklisteditor/qle_fileactions.py", line 513, in get_colorvaluesfromfile
    self.colordata = self.readtext_offile()
  File "/usr/share/qlequicklisteditor/qle_extract.py", line 79, in readtext_offile
    self.check_textfile = open(self.textfile, "r")
FileNotFoundError: [Errno 2] No such file or directory: '/home/andrei/.config/qle/current_theme.txt'

I got the application to start after creating these two directories:

~/.config/qle
~/.config/qle/initial_backups

Jacob Vlijm (vlijm) on 2014-02-21
Changed in jonb.homelauncher:
importance: Undecided → Critical
assignee: nobody → Jacob Vlijm (vlijm)
Jacob Vlijm (vlijm) wrote :

Dear Alin,
Thank you for your report!
The bug was caused by a order in the prepare_environment function. it did not occur during testing because all testing machines already had the necessary directories.
A fix will be uploaded in a minute, and should be available within an hour.

Thank you once again!

Jacob Vlijm (vlijm) on 2014-02-21
Changed in jonb.homelauncher:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers