Application crashes at startup

Bug #1280137 reported by Tryfon Farmakakis on 2014-02-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
QLE Unity Quicklist editor
Critical
Jacob Vlijm

Bug Description

Hi, I am using the latest version of QLE on Ubuntu 13.10 64bit. The application does not even start. Starting it from the command line prints the following:

tryfon@tryfon-ESPRIMO-P920:~$ qle_quicklisteditor
Traceback (most recent call last):
  File "/usr/bin/qle_quicklisteditor", line 3897, in <module>
    MainWindow()
  File "/usr/bin/qle_quicklisteditor", line 47, in __init__
    self.prepare_environment()
  File "/usr/share/qlequicklisteditor/qle_fileactions.py", line 460, in prepare_environment
    os.makedirs(self.localdir)
  File "/usr/lib/python3.3/os.py", line 258, in makedirs
    makedirs(head, mode, exist_ok)
  File "/usr/lib/python3.3/os.py", line 258, in makedirs
    makedirs(head, mode, exist_ok)
  File "/usr/lib/python3.3/os.py", line 258, in makedirs
    makedirs(head, mode, exist_ok)
  File "/usr/lib/python3.3/os.py", line 269, in makedirs
    mkdir(name, mode)
PermissionError: [Errno 13] Permission denied: '/home/tryfon'

Jacob Vlijm (vlijm) on 2014-02-14
Changed in jonb.homelauncher:
assignee: nobody → Jacob Vlijm (vlijm)
Jacob Vlijm (vlijm) wrote :

Hi Tryfon,
first of all, thank you for your bug report, I really appreciate the fact that you take the effort.
About the case: when the editor starts up, it looks if all the necessary directories exist. If the directory ~/.local/share/applications does not exist, it creates the directory, or it tries to in your case. It looks like you have no permission in your own home directory to create the directory, which is very strange, and you should have a lot of other applications that experience problems with that. Could you check if the directory ~/.local/share/applications exists, and who is the owner of it? If it is root, could you change it to your name?
Thsi will probably solve the problem, could you let me know?

Jacob Vlijm (vlijm) wrote :

....what you should probably check is just the ~/.local directory...

Strange, everything looks fine I think:

tryfon@tryfon-ESPRIMO-P920:~$ ls -l ~/.local/
total 4
drwxr-xr-x 21 tryfon tryfon 4096 Φεβ 14 16:39 share

tryfon@tryfon-ESPRIMO-P920:~$ ls -l ~/.local/share/
total 164
drwx------ 2 tryfon tryfon 4096 Φεβ 14 18:01 applications
drwx------ 7 tryfon tryfon 4096 Σεπ 24 19:02 evolution
drwx------ 3 tryfon tryfon 4096 Οκτ 8 12:53 gegl-0.2
drwxr-xr-x 2 tryfon tryfon 4096 Νοέ 7 20:59 gnome-settings-daemon
-rw-r--r-- 1 tryfon tryfon 1029 Νοέ 7 20:59 gsettings-data-convert
drwx------ 2 tryfon tryfon 4096 Φεβ 14 18:02 gvfs-metadata
drwxrwxr-x 2 tryfon tryfon 4096 Φεβ 7 15:54 icc
drwx------ 3 tryfon tryfon 4096 Σεπ 25 10:11 icons
drwx------ 2 tryfon tryfon 4096 Φεβ 13 15:39 keyrings
drwx------ 4 tryfon tryfon 4096 Νοέ 13 15:29 mime
drwx------ 3 tryfon tryfon 4096 Σεπ 24 19:02 nautilus
drwx------ 2 tryfon tryfon 4096 Δεκ 9 18:01 previews
-rw------- 1 tryfon tryfon 79892 Φεβ 14 16:39 recently-used.xbel
drwx------ 2 tryfon tryfon 4096 Οκτ 13 13:27 rhythmbox
-rw-r--r-- 1 tryfon tryfon 352 Νοέ 7 20:59 session_migration-ubuntu
drwx------ 2 tryfon tryfon 4096 Νοέ 7 20:59 sounds
drwx------ 5 tryfon tryfon 4096 Δεκ 9 10:31 Trash
drwxrwxr-x 4 tryfon tryfon 4096 Σεπ 24 19:15 ubuntuone
drwx------ 3 tryfon tryfon 4096 Φεβ 14 18:01 unity-webapps
drwx------ 2 tryfon tryfon 4096 Οκτ 21 10:42 vlc
drwx------ 3 tryfon tryfon 4096 Σεπ 24 19:22 webkit
drwx------ 3 tryfon tryfon 4096 Νοέ 7 21:00 zeitgeist

tryfon@tryfon-ESPRIMO-P920:~$ ls -l ~/.local/share/applications/
total 80
-rwxrwxr-x 1 tryfon tryfon 433 Νοέ 11 13:28 alacarte-made-1.desktop
-rwxrwxr-x 1 tryfon tryfon 259 Σεπ 25 12:41 alacarte-made-1.desktop~
-rw-r--r-- 1 tryfon tryfon 197 Ιαν 31 14:42 alacarte-made-2.desktop
-rwxrwxr-x 1 tryfon tryfon 429 Νοέ 11 13:26 alacarte-made.desktop
-rwxrwxr-x 1 tryfon tryfon 261 Νοέ 11 13:12 alacarte-made.desktop~
-rw-r--r-- 1 tryfon tryfon 222 Φεβ 14 18:01 Gmailmailgooglecom.desktop
-rw-rw-r-- 1 tryfon tryfon 221 Νοέ 7 20:59 GMailmailgooglecom.desktop
-rw-r--r-- 1 tryfon tryfon 253 Φεβ 12 14:55
GoogleCalendargooglecom.desktop
-rw-rw-r-- 1 tryfon tryfon 23370 Σεπ 24 20:09
libreoffice4.1-startcenter.desktop
-rw-rw-r-- 1 tryfon tryfon 18690 Σεπ 24 20:09
libreoffice-startcenter.desktop
-rw-r--r-- 1 tryfon tryfon 2740 Νοέ 13 15:29 mimeapps.list

On Fri, Feb 14, 2014 at 5:24 PM, Jacob Vlijm <email address hidden>wrote:

> ....what you should probably check is just the ~/.local directory...
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1280137
>
> Title:
> Application crashes at startup
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/jonb.homelauncher/+bug/1280137/+subscriptions
>

Jacob Vlijm (vlijm) wrote :

....!? I cannot figure it out immediately.
I have a strange question, but could you create a "dummy" new user, and log in as the new user and see what happens?
I am trying to figure out why the editor has no permission to create (or enter) the directory. The (first) output you sent me is exactly what I get when I change the owner of my ~/.local directory to root (for example)...

Ok, I installed it at my home computer, Ubuntu 13.10 64bit again. I made
sure the ~/.local permissions are ok. Now I get a different error output:

tryfon@tryfon-ThinkPad-T430u:~$ qle_quicklisteditor
Traceback (most recent call last):
  File "/usr/bin/qle_quicklisteditor", line 3897, in <module>
    MainWindow()
  File "/usr/bin/qle_quicklisteditor", line 47, in __init__
    self.prepare_environment()
  File "/usr/share/qlequicklisteditor/qle_fileactions.py", line 470, in
prepare_environment
    self.create_complete_database()
  File "/usr/share/qlequicklisteditor/qle_applicationlists.py", line 197,
in create_complete_database
    self.create_database_standalones()
  File "/usr/share/qlequicklisteditor/qle_applicationlists.py", line 188,
in create_database_standalones
    self.standalones.append(self.getdata_fromdtfile())
  File "/usr/share/qlequicklisteditor/qle_applicationlists.py", line 91, in
getdata_fromdtfile
    return({"interfacename": self.lookup_interfacename(),
  File "/usr/share/qlequicklisteditor/qle_applicationlists.py", line 107,
in lookup_interfacename
    return(self.founddata()["line"].replace("Name=", ""))
TypeError: list indices must be integers, not str

On Fri, Feb 14, 2014 at 9:25 PM, Jacob Vlijm <email address hidden>wrote:

> ....!? I cannot figure it out immediately.
> I have a strange question, but could you create a "dummy" new user, and
> log in as the new user and see what happens?
> I am trying to figure out why the editor has no permission to create (or
> enter) the directory. The (first) output you sent me is exactly what I get
> when I change the owner of my ~/.local directory to root (for example)...
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1280137
>
> Title:
> Application crashes at startup
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/jonb.homelauncher/+bug/1280137/+subscriptions
>

Jacob Vlijm (vlijm) wrote :

Can I ask which version you use? did you install it from a .deb file or from ppa? This is a bug that should have been fixed since 2.0.4, it was caused by the fact that some .desktopfiles do not have an (interface-) nameline. please let me know!

I installed it from this ppa: ppa:vlijm/qle It is version 2.0.6-1

On Sat, Feb 15, 2014 at 3:48 PM, Jacob Vlijm <email address hidden>wrote:

> Can I ask which version you use? did you install it from a .deb file or
> from ppa? This is a bug that should have been fixed since 2.0.4, it was
> caused by the fact that some .desktopfiles do not have an (interface-)
> nameline. please let me know!
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1280137
>
> Title:
> Application crashes at startup
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/jonb.homelauncher/+bug/1280137/+subscriptions
>

Jacob Vlijm (vlijm) wrote :

...I got it, I fixed the editor for occasions in which a desktopfile in /usr/share/applications had no Name= line, but forgot to do the same trick for standalone desktop files in ~/.local/share/applications. I will upload a fix today and let you know.
I owe you!

Jacob Vlijm (vlijm) wrote :

...Just pushed version 2.0.7. everything should work now.
please let me know!

Seems to be working fine now. With regards to the thank you, don't even
mention it, I always wanted a tool like this and it is people like you who
pioneer in building a new free future for everyone. People like me just try
to help as much as they can. See you around!

On Sat, Feb 15, 2014 at 5:28 PM, Jacob Vlijm <email address hidden>wrote:

> ...Just pushed version 2.0.7. everything should work now.
> please let me know!
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1280137
>
> Title:
> Application crashes at startup
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/jonb.homelauncher/+bug/1280137/+subscriptions
>

Jacob Vlijm (vlijm) wrote :

perfect!

Changed in jonb.homelauncher:
importance: Undecided → Critical
status: New → Fix Released
Javier Marino (marino-javier) wrote :

hi how i can fix in ubuntu 12.04

i have installed from the official ppa and i have the last version.

this is the error i have

Traceback (most recent call last):
  File "/usr/bin/qle_quicklisteditor", line 4044, in <module>
    MainWindow()
  File "/usr/bin/qle_quicklisteditor", line 47, in __init__
    self.prepare_environment()
  File "/usr/share/qlequicklisteditor/qle_fileactions.py", line 540, in prepare_environment
    os.mkdir(self.qle_locals)
OSError: [Errno 2] No such file or directory: '/home/root/.config/qle'

Jacob Vlijm (vlijm) wrote :

@Javier Marino
It seems you are logged in as root, while the editor assumes your local directory to be /home/username. Since root doesn't have a local folder, it will not work I am afraid.

Javier Marino (marino-javier) wrote :

ohhh i see, whatever thank you for you responose .... if anyway or a fix release for that situation?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers