"add an instrument" window doesn't remember window size after I resize it

Reported by eppy 1 on 2007-06-10
6
Affects Status Importance Assigned to Milestone
Jokosher
Low
alasdair.macleod

Bug Description

The "add an instrument" window doesn't remember window size after I resize it.

Steps:
1. Open "add an instrument" window
2. Resize it to make it bigger
3. Close it
4. Open it again

Results:
Resets to the original size, not the size I set it at

Expected Results:
Save my customized window size

Info:
Just a cosmetic issue but a little annoying.
There might be other windows that do this, I'll have to test Jokosher more.

Maybe related to Bug #99785

Related branches

Jono Bacon (jonobacon) on 2007-09-13
Changed in jokosher:
importance: Undecided → Low
status: New → Confirmed
Laszlo Pandy (laszlok) on 2009-03-02
Changed in jokosher:
assignee: nobody → laszlok
milestone: 1.0 → 0.11.1
Laszlo Pandy (laszlok) on 2009-03-18
Changed in jokosher:
milestone: 0.11.1 → 0.11.2

This annoys me to no end. All dialogs should remember this size, including this one and the "filters" (effects) dialog. I would presume that code could be simply copy-pasted over from the main windows, since it seems the issue was fixed for the main window.

Laszlo Pandy (laszlok) wrote :

You are exactly right. This is blindingly simple to do. There is very little chance of causing problems elsewhere so it is even good for someone who is new to the code. Can I convince you to attempt a patch?

Well I could add that to my todo list, but I would probably not manage
to find the time to attempt it until summer, and even then, no
guarantees... so if that's something that takes 2 minutes for an
experimented coder or someone familiar with the code, anyone is welcome
to attempt it!

I have nothing to do today :) i'll give it a shot :)

Changed in jokosher:
assignee: laszlok → alasdair-macleod
status: Confirmed → Fix Committed
Changed in jokosher:
status: Fix Committed → Fix Released

Still not fixed with jokosher trunk

Changed in jokosher:
status: Fix Released → In Progress

Nevermind, I was running ./bin/jokosher instead of ./Jokosher/Jokosher

Changed in jokosher:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers