Install progress window has no title

Reported by Michael Jones on 2009-02-01
116
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Jockey
Undecided
Bilal Akhtar
One Hundred Papercuts
Undecided
Unassigned
Declined for Karmic by Vish
jockey (Ubuntu)
Low
Bilal Akhtar

Bug Description

A window with name "Untitled Window" is created when installing the NVidea hardware drivers in Ubuntu Ibex.
The window has a clear purpose. It just looks bad to have "Untitled Window" appear on my task-bar

A screenshot is attached.

Michael Jones (jonesmz) wrote :
Richard Laager (rlaager) wrote :

I can confirm this. I'm also on Intrepid.

Changed in jockey (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) on 2009-04-23
Changed in jockey (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Martin Pitt (pitti) on 2009-04-23
summary: - Untitled Window when installing NVidea hardware drivers.
+ Install progress window has no title
ShawnJGoff (shawn-goff) wrote :

not sure it's a paper cut because it's not something you encounter every day

Well... Its gotta be fixed eventually...

On Wed, Jun 17, 2009 at 10:06 PM, ShawnJGoff <email address hidden> wrote:

> not sure it's a paper cut because it's not something you encounter every
> day
>
> --
> Install progress window has no title
> https://bugs.launchpad.net/bugs/323815
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in One Hundred Paper Cuts: New
> Status in “jockey” source package in Ubuntu: Triaged
>
> Bug description:
> A window with name "Untitled Window" is created when installing the NVidea
> hardware drivers in Ubuntu Ibex.
> The window has a clear purpose. It just looks bad to have "Untitled Window"
> appear on my task-bar
>
> A screenshot is attached.
>

Lightbreeze (nedhoy-gmail) wrote :

A 'paper cut' is something that might be encountered many times during the day, which this clearly would not be, as ShawnJGoff points out.

Don't worry though, you're right, this _is_ a design issue. The window should either skip the taskbar or have a title. Thanks for helping to polish Ubuntu :D

Changed in hundredpapercuts:
status: New → Invalid

I dont care if its not paper cut!

Its a stupid little bug which looks unprofessional.

Its been like it since jockey was put in Ubuntu. Its now Ubuntu 9.10, it still has not been fixed!

Changed in jockey (Ubuntu):
status: Triaged → Confirmed
Vish (vish) on 2009-10-13
affects: hundredpapercuts → null

Found it too. Agreed with chewit.

Hugh Saunders (hughsaunders) wrote :

Linked branch with naive fix, found the dialogue in glade and gave it a title, not sure if that is the correct way to do it, or how that works with i18n.

Tiago Neiva (tneiva) wrote :

Just updated my ATI drivers and still get a MessageBox with no title, as some have said it before it looks unprofessional.
I also looked at it like a papercut, bu I agree, I will see it only once a month, when I install a new machine.

Vish (vish) wrote :

Bug had already been marked invalid in Papercuts [comment #5]
For further information about papercuts criteria, please read https://wiki.ubuntu.com/PaperCut.

Don't worry though, this bug has been marked as "Invalid" only in the papercuts project.

@chewit , "Triaged" means the bug has enough information for a developer to start working on it, you have *lowered* the status to "Confirmed".
For more information on bug statuses , kindly read. : https://wiki.ubuntu.com/Bugs/Status

Changed in hundredpapercuts:
status: New → Invalid
Changed in jockey (Ubuntu):
status: Confirmed → Triaged
Michael Jones (jonesmz) wrote :

Just installed the 10.10 release candidate. This is a problem.

Additionally, the documentation for the hardware drivers program is wrong now.

Michael Jones (jonesmz) wrote :
Michael Jones (jonesmz) wrote :
Michael Jones (jonesmz) wrote :

The help menu says to go to system->administration->hardware drivers
My menu only has system->administration->additional drivers

Bilal Akhtar (bilalakhtar) wrote :

I shall get this fixed soon. (Expect a patch by Wednesday)

Changed in jockey (Ubuntu):
assignee: nobody → Bilal Akhtar (bilalakhtar)
status: Triaged → In Progress
Bilal Akhtar (bilalakhtar) wrote :

Was expected to be fixed in bug #616569, but it wasn't fixed completely.

Changed in jockey:
assignee: nobody → Bilal Akhtar (bilalakhtar)
status: New → In Progress
Martin Pitt (pitti) on 2010-11-10
Changed in jockey (Ubuntu):
status: In Progress → Fix Committed
Changed in jockey:
status: In Progress → Fix Committed
Bilal Akhtar (bilalakhtar) wrote :

I think this should be a papercut, since bug #616569 was also one.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jockey - 0.6-0ubuntu1

---------------
jockey (0.6-0ubuntu1) natty; urgency=low

  [ Alberto Milone ]
  * data/handlers/nvidia.py:
    - Re-enable nvidia-96 now that it's compatible with xserver 1.9.
      (LP: #626974).

  [ Martin Pitt ]
  * New upstream release 0.6:
    - Add support and test case for reading modaliases from package headers.
    - Put back "Additional Drivers" progress window title. Thanks Bilal
      Akhtar! (LP: #323815)
    - jockey/detection.py, get_hardware(): Disable printer detection.
      cupshelpers.getDevices() is excruciatingly slow (about 15 seconds), and
      jockey is not normally used directly to install printer drivers.
      Instead, system-config-printer picks up new printers, and calls jockey
      with the device ID, so jockey does not need to detect printers by
      itself.
    - jockey-kde: Use runtime .ui loading instead of pykdeuic4; the latter
      just keeps breaking.
    - gtk/jockey-gtk.ui: Drop obsolete has_separator property; Explicitly set
      topmost GtkVBox fill property to True, as the default changed in GTK 3.0
      (GNOME #634592)
    - Various test suite fixes.
  * debian/control: Drop now obsolete python-{qt4,kde}* build dependencies.
  * debian/jockey-kde.install: Install the KDE *.ui files.
  * jockey/oslib.py, has_repositories(): Greatly speed up (5 seconds →
    negligible) by calling "apt-cache policy" instead of creating an
    apt.Cache() object.
  * Drop data/handlers/b43.py, our linux-firmware package ships the b43
    firmware now. Also, the wl driver is generally a lot better.
  * Add support for putting modalias definitions in driver package's
    debian/control, so that we can replace the /usr/share/jockey/modaliases/*
    lists with lookups in the package database (see blueprint
    hardware-desktop-n-package-field-modaliases). With this we can drop the
    foo-modaliases packages, and shipping third-party driver packages will
    just work in Jockey without any further integration.
    - Add debian/debhelper/dh_jockey: Debhelper program to produce a
      ${modaliases} substvar from scanning .ko files or
      debian/packagename.modaliases.
    - Add debian/debhelper/test_dh_jockey: Automatic test script for
      dh_jockey.
    - Add debian/debhelper/modaliases.pm: dh_auto sequencer for dh_modaliases.
    - debian/control: Add dh-modaliases package.
    - debian/dh-modaliases.install: Install dh_modaliases and modaliases.pm.
    - debian/rules: Create manpage from dh_modaliases POD.
    - jockey/oslib.py: Add apt implementation for package_header_modaliases().
    - tests/oslib.py: Add test case for our package_header_modaliases()
      implementation. This only really tests anything if there is at least one
      package with a "Modaliases:" field in the local apt repository.
  * jockey/oslib.py: Change deprecated apt.apt_pkg.Config.Set() to .set().
  * debian/rules: Drop simple-patchsys.mk, we don't need it (patches are
    inline, maintained in bzr).
 -- Martin Pitt <email address hidden> Thu, 25 Nov 2010 19:49:00 +0100

Changed in jockey (Ubuntu):
status: Fix Committed → Fix Released
Mel C (melc) wrote :

try to change the "Untitled window" in natty

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers