Cannot deactivate a printer driver from Jockey 0.5alpha1

Bug #269435 reported by Till Kamppeter on 2008-09-12
2
Affects Status Importance Assigned to Milestone
Jockey
Undecided
Martin Pitt

Bug Description

I am on Intrepid with Jockey 0.5alpha1 (source downloaded from Launchpad and rebuilt). It seems to early that Apport can report bugs on this Jockey version (tells that it is not a genuine Ubuntu package).

I have done the following test sequence:

I have run the command

dbus-send --print-reply --dest=com.ubuntu.DeviceDriver /GUI com.ubuntu.DeviceDriver.search_driver string:"printer_deviceid:MFG:Samsung;MDL:ML-1610;CMD:GDI"

to pretend that a printer setup tool detected a Samsung ML-1610 and asks Jockey for getting a driver for it. Jockey gets the information that splix is suitable from OpenPrinting and asks the user in a little window to confirm. I have rejected.

Now I run

jockey-gtk

and it remembered that it offered splix to me earlier as it showed the splix driver. I selected the splix driver and installed it by clicking the button at the lower right. This worked fine. I closed Jockey.

Then I started jockey again from the same console using

jockey-gtk.

splix was listed and I selected and uninstalled it with button on the lower right. This dis not work. I got the following traceback (and the window stayed open):

Traceback (most recent call last):
  File "/usr/bin/jockey-gtk", line 323, in on_button_toggle_clicked
    'toggle', False):
  File "/usr/lib/python2.5/site-packages/jockey/ui.py", line 574, in set_handler_enable
    handler_id, enable)
  File "/usr/lib/python2.5/site-packages/jockey/backend.py", line 116, in polkit_auth_wrapper
    return fn(*args, **kwargs)
  File "/usr/lib/python2.5/site-packages/jockey/backend.py", line 87, in dbus_sync_call_signal_wrapper
    raise _h_exception_exc
dbus.exceptions.DBusException: org.freedesktop.DBus.Python.NameError: Traceback (most recent call last):
  File "/var/lib/python-support/python2.5/dbus/service.py", line 696, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/lib/python2.5/site-packages/jockey/backend.py", line 256, in set_enabled
    return h.disable()
  File "/usr/lib/python2.5/site-packages/jockey/handlers.py", line 239, in disable
    OSLib.inst.remove_repository(self.repository)
  File "/usr/lib/python2.5/site-packages/jockey/oslib.py", line 311, in remove_repository
    w.write('\n'.join(result))
NameError: global name 'w' is not defined

Changed in jockey:
assignee: nobody → pitti

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 status fixcommitted
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAkjOirMACgkQDecnbV4Fd/KZ2gCeMmWhuJKrOAJQLQPl/jTUVQHv
MdYAoMq6uVgGe59XSE988jDsG4hjL9ck
=H0kO
-----END PGP SIGNATURE-----

Martin Pitt (pitti) on 2008-09-15
Changed in jockey:
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Fixed in upstream release 0.5beta1.

Changed in jockey:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers