Nvidia driver Enabled but not In Use

Bug #216650 reported by kripken on 2008-04-13
42
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Jockey
Undecided
Martin Pitt
jockey (Ubuntu)
Undecided
Martin Pitt
Hardy
Undecided
Martin Pitt
Intrepid
Undecided
Martin Pitt

Bug Description

I am using the binary Nvidia driver, and it works ok. However, the display in Hardware Drivers is odd to me: it says the driver is "Enabled" (with a checkmark) but in the other column says it is "Not in Use" (with a red dot).

Since the driver works fine, I think it should say both Enabled and In Use.

(Also, I'm not even sure what the difference between the columns is. Perhaps it could be explained somewhere? Currently pressing 'help' gives an error message in the help viewer.)

TEST CASE:
 - On a system with an nvidia graphics card, check which driver jockey recommends (old, newest, or standard driver, corresponding to nvidia-glx-legacy, nvidia-glx-new, and nvidia-glx).
 - Install the one which is *not* recommended (usually n-glx-new or n-glx)
 - Jockey in hardy final: driver appears as enabled
 - Fixed Jockey: driver appears as disabled

Martin Pitt (pitti) wrote :

Can you please do

  jockey-gtk --list --debug | tee /tmp/jockey.txt

in a Terminal and attach /tmp/jockey.txt here? Replace jockey-gtk with jockey-kde if you are using Kubuntu.

Also, please give me the output of "dpkg -l nvidia-glx*". Thank you!

Changed in jockey:
status: New → Incomplete
kripken (kripkenstein) wrote :

Ok, after running the first command, jockey.txt contains a single line,

kmod:nvidia_new - NVIDIA accelerated graphics driver (latest cards) (restricted, Enabled, Not in use)

The second command gives me

Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-============================-=======================
ii nvidia-glx 1:96.43.05+2.6.24.12-16.34 NVIDIA binary XFree86 4.x/X.Org driver
un nvidia-glx-legacy <none> (no description available)
un nvidia-glx-new <none> (no description available)
un nvidia-glx-src <none> (no description available)

Martin Pitt (pitti) wrote :

Whoops, sorry. Wrong routing of the debugging output. Can you please try again:

  jockey-gtk --list --debug 2>&1 | tee /tmp/jockey.txt

Thanks!

kripken (kripkenstein) wrote :

Ok, here it is, attached.

Dean Loros (autocrosser) wrote :

Very weird--I am having the same problem. Jockey reports that the driver is enabled but not in use(Nvidia-glx-new)--glxgears reports a bit over !0.000fps so I know the driver is working. jockey.txt & dpkg -l nvidia-glx* included....

dean@linux:~$ dpkg -l nvidia-glx*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
pn nvidia-glx <none> (no description available)
un nvidia-glx-dev <none> (no description available)
un nvidia-glx-leg <none> (no description available)
un nvidia-glx-leg <none> (no description available)
ii nvidia-glx-new 169.12+2.6.24. NVIDIA binary XFree86 4.x/X.Org 'new' driver
ii nvidia-glx-new 169.12+2.6.24. NVIDIA binary XFree86 4.x/X.Org 'new' driver
un nvidia-glx-src <none> (no description available)

Dean Loros (autocrosser) wrote :

Opps--that was 10,000fps 8600GT card.

Martin Pitt (pitti) wrote :

Ah, so the problem is that the recommended driver for your system is nvidia-glx-new, but you have nvidia-glx. So the correct way to show this would actually be "disabled" and "not in use". I'll fix this.

Changed in jockey:
assignee: nobody → pitti
status: Incomplete → In Progress
Martin Pitt (pitti) wrote :
Changed in jockey:
status: In Progress → Fix Released
assignee: nobody → pitti
status: New → In Progress
Martin Pitt (pitti) wrote :

Explanation of the patch: Currently, NvidiaHandler's enabled() method only tests if xorg.conf has "nvidia" selected as driver. However, this is not enough, since there are three different handlers for the drivers (legacy/new/standard). It additionally needs to check if the corresponding package is installed and if the module is not blacklisted, which is what the ancestor method ModulePackageHandler.enabled() does.

description: updated
Martin Pitt (pitti) on 2008-04-28
Changed in jockey:
assignee: nobody → pitti
milestone: none → ubuntu-8.04.1
status: New → In Progress
Steve Langasek (vorlon) wrote :

accepted in hardy-proposed, please test.

Changed in jockey:
status: In Progress → Fix Committed
Pedro Fragoso (ember) wrote :

Here's a little test i did with Martin.

I'm running updated Hardy with nvidia-glx-new and jockey 0.3.3-0ubuntu8
http://pfragoso.org/ubuntu/jockey1.png

Then i switched to nvidia-glx and using jockey 0.3.3-0ubuntu8
http://pfragoso.org/ubuntu/jockey2.png

In the end using nvidia-glx and jockey 0.3.3-0ubuntu7
http://pfragoso.org/ubuntu/jockey3.png

Hope this helps.

Martin Pitt (pitti) wrote :

Thanks, Pedro! This demonstrates the fix nicely.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jockey - 0.3.3-0ubuntu9

---------------
jockey (0.3.3-0ubuntu9) intrepid; urgency=low

  * Upload fixes from hardy-proposed to intrepid.

jockey (0.3.3-0ubuntu8) hardy-proposed; urgency=low

  * fglrx.py: Do not override already installed third-party fglrx driver with
    --check-composite. (LP: #221968)
  * debian/control: Updated Vcs-Bzr: to point to the hardy branch.
  * XorgDriverHandler, nvidia, fglrx: Set identifiers for newly created
    sections, they are invalid without one. Thanks to Laszlo Pandy!
    (LP: #218478)
  * nvidia.py: Fix "enabled" handling: check if the package is installed and
    module not blacklisted. (LP: #216650)
  * OSLib.open_app(): Wait until the subprocess returned, so that we can check
    the system state afterwards. (prerequisite for change below)
  * jockey/ui.py, --check-composite: Re-check the system after attempting to
    enable the driver, and only signal success (exit with 0) if the driver was
    actually enabled. Otherwise, cancelling installation would invalidly
    signal success to the caller. (LP: #208026)

 -- Martin Pitt <email address hidden> Mon, 05 May 2008 20:49:10 +0200

Changed in jockey:
status: In Progress → Fix Released
Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in jockey:
status: Fix Committed → Fix Released
Bryn Hughes (linux-nashira) wrote :

This bug has come back in Lucid...

jockey-gtk/lucid uptodate 0.5.7-0ubuntu1
nvidia-current/lucid uptodate 190.53-0ubuntu14

Same message - driver is shown as installed but listed as not in use, despite the fact that it IS in use.

OpenGL renderer string: Quadro FX 880M/PCI/SSE2

Tommy_CZ (t-kijas) wrote :

I can confirm it, Kubuntu Lucid Lynx 10.04

Alberto Milone (albertomilone) wrote :

@Tommy_CZ
You're experiencing bug #552653 , not the one described in this bug report

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers