Hang on starting opengl

Bug #596030 reported by Helge Dietert
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
JHelioviewer
Fix Released
Undecided
Unassigned

Bug Description

When using my pwf account to start JHelioviewer application over "ssh -X" hangs with no possibility to close it on the splash screen with "Starting OpenGL". It can be reproduced just by starting any time and happens in trunk and the Andre's release branch.

The Log on the console is:

smaug:~$ java -jar JHelioviewer.jar
2010-06-18 19:02:38,024 [main] INFO root - JHelioviewer started with command-line options:
2010-06-18 19:02:38,025 [main] INFO root - Create directories...
2010-06-18 19:02:38,100 [main] INFO root - Initializing JHelioviewer
2010-06-18 19:02:54,847 [main] INFO root - Try to load Kakadu libraries
2010-06-18 19:02:57,017 [main] INFO root - Load OpenGL libraries
2010-06-18 19:02:58,892 [main] INFO root - Load Cgc
2010-06-18 19:02:59,239 [main] INFO root - Load FFmpeg
2010-06-18 19:02:59,595 [main] INFO root - Read settings
2010-06-18 19:02:59,618 [main] INFO root - Use default look and feel
2010-06-18 19:02:59,619 [main] INFO root - Load settings
2010-06-18 19:02:59,654 [main] INFO root - Use cache directory: /home/hgwd2/JHelioviewer/Cache/
2010-06-18 19:02:59,683 [main] INFO root - Load plugin settings
2010-06-18 19:02:59,875 [main] INFO root - Add internal plugin: FilterPlugin
2010-06-18 19:03:00,284 [main] INFO root - Add internal plugin: OverlayPlugin
2010-06-18 19:03:00,289 [main] INFO root - Search for plugins in /home/hgwd2/JHelioviewer/Plugins/
2010-06-18 19:03:00,295 [main] INFO root - Initialize GUI
2010-06-18 19:03:23,958 [main] INFO root - Start main window
Exception in thread "main" javax.media.opengl.GLException: Unable to select one of the provided GLCapabilities
 at javax.media.opengl.DefaultGLCapabilitiesChooser.chooseCapabilities(DefaultGLCapabilitiesChooser.java:218)
 at com.sun.opengl.impl.x11.X11GLDrawableFactory.chooseGraphicsConfiguration(X11GLDrawableFactory.java:190)
 at javax.media.opengl.GLCanvas.chooseGraphicsConfiguration(GLCanvas.java:520)
 at javax.media.opengl.GLCanvas.<init>(GLCanvas.java:131)
 at org.helioviewer.jhv.opengl.GLInitPanel.<init>(Unknown Source)
 at org.helioviewer.jhv.JHVSplashScreen.startUpOpenGL(Unknown Source)
 at org.helioviewer.jhv.JavaHelioViewer.main(Unknown Source)

Looks like an uncatched exception, when no OpenGL is available. Should be easily fixable by catching the exception.

Revision history for this message
Malte Nuhn (malte.nuhn) wrote :

One thing we might try, before actually catching the exception, is to activate the debug options provided by the OpenGL java library "JOGL".

java -Dnewt.debug=all -Dnativewindow.debug=all -Djogl.debug=true -jar JHelioviewer.jar

Perhaps this output would be nice to see for Markus, too.

Revision history for this message
Andre Dau (andre-dau) wrote :

Fix in the experimental-release branch: Fallback to software mode when exception is thrown during the initialization of OpenGL

Changed in jhelioviewer:
status: New → In Progress
Revision history for this message
Helge Dietert (helge-dietert) wrote :

Okay, maybe interesting is that connecting to one server its working fine (okay, not super fast over the wifi down here), while connecting to the other server does not work, while in both cases my local X Server to which its connecting is the same.

I attach a detailed log.

Revision history for this message
Malte Nuhn (malte.nuhn) wrote :

Thanks for the log. This looks really strange - they seem to do some hacks in the JOGL libraries, that do not work in all (including this) cases.

I posted a thread over here to see what to do in the long run. I think for now, catching the exception is the best option.

http://jogamp.762907.n3.nabble.com/Error-Unable-to-select-one-of-the-provided-GLCapabilities-tp906522p906522.html;cid=1276894269579-969

Andre Dau (andre-dau)
Changed in jhelioviewer:
status: In Progress → Fix Committed
Changed in jhelioviewer:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Bug attachments