can not leave drawing mode in firefox with typeaheadfind

Bug #611300 reported by Helge Hielscher on 2010-07-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
JessyInk
Medium
Hannes Hochreiner

Bug Description

Steps to reproduce:
1. open about:conig in firefox
2. set accessibility.typeaheadfind to true
3. open JessyInk_1_5_1_showcase.svg
4. hit d to enable drawing mode

Result: I found no way to exit drawing mode.

Thanks for bringing this problem to my attention. I am not quite sure why it would allow you to change into drawing mode, but not out of it again. One thing I will try is not to let the keypress event propagate.

Tested on the following setup:
Mozilla/5.0 (X11; Linux i686; rv:2.0b3pre) Gecko/20100728 Ubuntu/10.04 (lucid) MozillaDeveloperPreview/4.0b3pre

Changed in jessyink:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Hannes Hochreiner (hannes-hochreiner)
Changed in jessyink:
milestone: none → 1.5.2
Helge Hielscher (hhielscher) wrote :

What about adding "Escape" as an alternative to leave drawing mode?

Changed in jessyink:
milestone: 1.5.2 → 2.0.0alpha

Hmm, I tried that. Actually, in version 1.5.2 "escape" will be available as a special key and it will (by default) be assigned to switching from drawing mode into slide mode. However, I still get strange results when type ahead is active. Index mode seems to work a little better. Although, even in index mode I cannot use "i" to switch back to slide mode. "Enter" seems to work. I also tried to assign "enter" for switching from drawing mode to slide mode, but that did not yield the expected result either.

Interestingly enough, if I had the browser display an alert window at the beginning of the switching function, things seemed to be back to normal. I am not quite sure what to make of that, but I don't want to block the release of version 1.5.2 because of this issue. Hence, I reassigned the issue to 2.0.0 alpha.

Changed in jessyink:
milestone: 2.0.0alpha1 → 2.0.0alpha2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers