Support for LaunchPad git repos

Bug #1606394 reported by Joshua Powers on 2016-07-25
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
cloud-init
High
Unassigned
jenkins-launchpad-plugin
Undecided
Unassigned

Bug Description

LaunchPad supports the use of git as a version control system. The plugin (as far as I can tell) does not allow specifying a git based repo as it was built around the use of bzr.

In addition to using git over bzr, some of the changes between the two systems' URLs are outlined below:

Merge Request:
bzr: https://code.launchpad.net/~harlowja/cloud-init/cloud-init-tag-distros/+merge/300840
git: https://code.launchpad.net/~harlowja/cloud-init/+git/cloud-init/+merge/301108

Proposed Branch:
bzr: https://code.launchpad.net/~harlowja/cloud-init/cloud-init-tag-distros
git: https://code.launchpad.net/~harlowja/cloud-init/+git/cloud-init/+ref/distro-tags

Merge Branch:
bzr: https://code.launchpad.net/~cloud-init-dev/cloud-init/trunk
git: https://code.launchpad.net/~cloud-init-dev/cloud-init/+git/cloud-init/+ref/master

I am currently trying to determine what the best route would be to add git support.

Scott Moser (smoser) on 2016-08-30
Changed in jenkins-launchpad-plugin:
status: New → Confirmed
Changed in cloud-init:
status: New → Confirmed
importance: Undecided → High
Joshua Powers (powersj) on 2016-09-28
tags: added: jenkins-launchpad-plugin
removed: jenkins-lauchpad-plugin
Curtis Hovey (sinzui) wrote :

Scripts can now use Lp webhooks to register a url to call when a change is made to a git or bzr repo
    https://help.launchpad.net/API/Webhooks

git repos/branches/merge proposals are supported in the API
    https://launchpad.net/+apidoc/devel.html#git_repositories
but I don't think API is needed because the webhook provides a good information.

Joshua Powers (powersj) wrote :

New merge request proposed [1] to add support for querying for merge proposals. This is based on albaguirre's proposal [2], but incorporates fginther's comment about not always needing the repo_type option. It is now optional, defaulting to auto, and if set to auto will go and determine the repo type.

After that is accepted albaguirre's second [3] and third [4] proposals can be added. The second will have to conflicts, accepting what is already in the tree will safely resolve this as the differences are what are is set as the default argument (auto vs bazaar).

[1] https://code.launchpad.net/~powersj/jenkins-launchpad-plugin/support-query-auto-mps/+merge/317556
[2] https://code.launchpad.net/~albaguirre/jenkins-launchpad-plugin/support-query-git-mps/+merge/302329
[3] https://code.launchpad.net/~albaguirre/jenkins-launchpad-plugin/support-voting-on-git-mps/+merge/302451
[4] https://code.launchpad.net/~albaguirre/jenkins-launchpad-plugin/support-lp-trigger-for-git-mps/+merge/302868

Joshua Powers (powersj) wrote :

CI in place and running \o/

Changed in cloud-init:
status: Confirmed → Fix Released
Changed in jenkins-launchpad-plugin:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers