Rename php53 -> php53u

Bug #691755 reported by BJ Dierkes on 2010-12-17
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
IUS Community Project
Medium
BJ Dierkes

Bug Description

Because Redhat is including php53 in RHEL 5.6, we need to rename our php53 packages so that we do not break our packaging guidelines. So, php53u must Obsolete php53 from now... until sometime before RHEL 5.6 is GA in an effort to get all IUS php53 users onto php53u.

php53 must also be removed completely from the IUS repos.

BJ Dierkes (derks) wrote :

This affects all php53 packages:

BJ Dierkes (derks) wrote :

Pushed to ius-testing.

Changed in ius:
assignee: nobody → BJ Dierkes (derks)
importance: Undecided → Medium
status: New → Fix Committed
BJ Dierkes (derks) wrote :

This has been pushed to ius-el5 stable.

Changed in ius:
status: Fix Committed → Fix Released
David Bell (evad) wrote :
Download full text (4.2 KiB)

Hi, thanks for pushing to stable, however there is a small consequence:

Package php53u-common-5.3.4-2.ius.el5.x86_64.rpm is not signed

I've tried running a "yum clean metadata" but the issue persists.

Full log:

[root@uos-web00172-vs ~]# yum -y install php53u python26
Loaded plugins: rhnplugin, security
vmware-tools | 951 B 00:00
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php53u.x86_64 0:5.3.4-2.ius.el5 set to be updated
--> Processing Dependency: php53u-cli = 5.3.4-2.ius.el5 for package: php53u
--> Processing Dependency: php53u-common = 5.3.4-2.ius.el5 for package: php53u
--> Processing Dependency: libtool-ltdl for package: php53u
--> Processing Dependency: t1lib for package: php53u
--> Processing Dependency: libedit for package: php53u
---> Package python26.x86_64 0:2.6.5-5.el5 set to be updated
--> Processing Dependency: libffi.so.5()(64bit) for package: python26
--> Processing Dependency: libpython2.6.so.1.0()(64bit) for package: python26
--> Running transaction check
---> Package libedit.x86_64 0:2.11-2.20080712cvs.el5 set to be updated
---> Package libffi.x86_64 0:3.0.5-1.el5 set to be updated
---> Package libtool-ltdl.x86_64 0:1.5.22-7.el5_4 set to be updated
---> Package php53u-cli.x86_64 0:5.3.4-2.ius.el5 set to be updated
---> Package php53u-common.x86_64 0:5.3.4-2.ius.el5 set to be updated
---> Package python26-libs.x86_64 0:2.6.5-5.el5 set to be updated
---> Package t1lib.x86_64 0:5.1.1-7.el5 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

====================================================================================================================================================================================
 Package Arch Version Repository Size
====================================================================================================================================================================================
Installing:
 php53u x86_64 5.3.4-2.ius.el5 ius 1.3 M
 python26 x86_64 2.6.5-5.el5 epel 6.5 M
Installing for dependencies:
 libedit x86_64 2.11-2.20080712cvs.el5 epel 80 k
 libffi x86_64 3.0.5-1.el5 epel 24 k
 libtool-ltdl x86_64 1.5.22-7.el5_4 rhel-x86_64-server-5 38 k
 ph...

Read more...

BJ Dierkes (derks) wrote :

Sincerely apologize, this should be resolved now. Please let us know if you have any further issues.

David Bell (evad) wrote :

Sorry for taking so long to reply, but yes thanks that fixed it :-) IUS is excellent :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers