php53u xcache install messes up ioncube

Reported by Shawn on 2012-12-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
IUS Community Project
Undecided
Jeffrey Ness

Bug Description

I have installed php53u on centos 5.8 from the repo. I can install ioncube just fine and php -v gives me the correct output. When I install xcache then ioncube complains it is not first in /etc/php.ini. The problem is they are not loading loading from /etc/php.ini they are loading from /etc/php.d/. So if the system is working correctly ioncube would load first as it comes before xcache.

I know it is a problem with xcache as I have the zend guard loader installed and it works fine also.

 I have tried editing /etc/php.ini and telling ioncube to load before xcache and it did not work. (Yes I deleted the corresponding /etc/php.d/ entries first so they did not double load.)

OS = Centos 5.8

PHP = 5.3u

Packages = php53u-5.3.18-1.ius.el5.i386, php53u-ioncube-loader-4.2.2-1.ius.el5.i386, php53u-xcache.i386 0:3.0.0-1.ius.el5

Steps to reproduce problem = Just install the packages is all I have done.

Jeffrey Ness (jeffrey-ness) wrote :

Thank you for the bug report Shawn,
we will look in to this issue.

Jeffrey-

Jeffrey Ness (jeffrey-ness) wrote :

I have confirmed this bug also effects me internally:

# rpm -q php53u
php53u-5.3.18-1.ius.el5
[root@CentOS5-5-IUS-testing ~]# rpm -q php53u-ioncube-loader
php53u-ioncube-loader-4.2.2-1.ius.el5
[root@CentOS5-5-IUS-testing ~]# rpm -q php53u-xcache
package php53u-xcache is not installed

# php -v
PHP 5.3.18 (cli) (built: Oct 18 2012 17:14:24)
Copyright (c) 1997-2012 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2012 Zend Technologies
    with the ionCube PHP Loader v4.2.2, Copyright (c) 2002-2012, by ionCube Ltd., and
    with Xdebug v2.2.1, Copyright (c) 2002-2012, by Derick Rethans
    with Suhosin v0.9.33, Copyright (c) 2007-2012, by SektionEins GmbH

# yum install php53u-xcache

# rpm -q php53u-xcache
php53u-xcache-3.0.0-1.ius.el5

# php -v
PHP Fatal error: [ionCube Loader] The Loader must appear as the first entry in the php.ini file in Unknown on line 0

Jeffrey Ness (jeffrey-ness) wrote :

So the issue here is our Xcache package is build as a stand alone module
not a Zend extension.

I believe this article explains:

   http://havokmon.blogspot.com/2011/07/freebsd-64bit-php-53-ioncube-zend.html

Jeffrey Ness (jeffrey-ness) wrote :

So Version 3.0 of Xcache is no longer a Zend extension:

   http://xcache.lighttpd.net/wiki/Release-3.0.0

Jeffrey Ness (jeffrey-ness) wrote :

Since 3.0 no longer is a Zend extension it appears the two have issues with each other,
if you require both Xcache and Ioncube-loader I would use a 2.0 Xcache found in our Archive repo:

  http://dl.iuscommunity.org/pub/ius/archive/

# rpm -ivh http://dl.iuscommunity.org/pub/ius/archive/Redhat/5/x86_64/php53u-xcache-2.0.1-1.ius.el5.x86_64.rpm
Retrieving http://dl.iuscommunity.org/pub/ius/archive/Redhat/5/x86_64/php53u-xcache-2.0.1-1.ius.el5.x86_64.rpm
Preparing... ########################################### [100%]
   1:php53u-xcache ########################################### [100%]

# php -v
PHP 5.3.18 (cli) (built: Oct 18 2012 17:14:24)
Copyright (c) 1997-2012 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2012 Zend Technologies
    with the ionCube PHP Loader v4.2.2, Copyright (c) 2002-2012, by ionCube Ltd., and
    with XCache v2.0.1, Copyright (c) 2005-2012, by mOo
    with Xdebug v2.2.1, Copyright (c) 2002-2012, by Derick Rethans
    with Suhosin v0.9.33, Copyright (c) 2007-2012, by SektionEins GmbH

Shawn (slackersu) wrote :

Okay that makes sense. I will use the repo's version 2.0 until I upgrade php.

Thank you Jeff.

Jeffrey Ness (jeffrey-ness) wrote :

A new bug report has been created with upstream Xcache:

   http://xcache.lighttpd.net/ticket/294

Shawn (slackersu) wrote :

Thank you again Jeff, seems they don't think sometimes when they do things.

Jeffrey Ness (jeffrey-ness) wrote :

According to http://xcache.lighttpd.net/ticket/294 this has been fixed in the latest svn trunk.

Jeffrey Ness (jeffrey-ness) wrote :

The latest svn 3.0.1 trunk has not yet been marked stable,
3.0.0 is still the latest stable:

    http://xcache.lighttpd.net/#Downloads

Once 3.0.1 is moved over to stable we will package it for the IUS Community.

Jeffrey-

Shawn (slackersu) wrote :

That is good news. Thank you for keeping me updated Jeff.

Changed in ius:
assignee: nobody → Jeffrey Ness (jeffrey-ness)
status: New → Confirmed
bharper (bharper) wrote :

Hey Shawn,

A new version of xcache just got released and release notes state improve compatibility with "the ionCube PHP Loader", Zend Optimizer:

http://xcache.lighttpd.net/wiki/Release-3.0.1

I have build it and it has been tagged as test-candidate. It will be in placed in the testing repos tonight and can take around 24 hours to hit all the mirrors.

See the following for information on how to use the testing repo:

http://iuscommunity.org/pages/FAQs.html?highlight=testing#how-do-i-install-packages-from-testing

-Ben

Sounds good thank you for the update Ben.

Shawn

On 1/11/13, bharper <email address hidden> wrote:
> Hey Shawn,
>
> A new version of xcache just got released and release notes state
> improve compatibility with "the ionCube PHP Loader", Zend Optimizer:
>
> http://xcache.lighttpd.net/wiki/Release-3.0.1
>
> I have build it and it has been tagged as test-candidate. It will be in
> placed in the testing repos tonight and can take around 24 hours to hit
> all the mirrors.
>
> See the following for information on how to use the testing repo:
>
> http://iuscommunity.org/pages/FAQs.html?highlight=testing#how-do-i
> -install-packages-from-testing
>
>
> -Ben
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1088667
>
> Title:
> php53u xcache install messes up ioncube
>
> Status in IUS Community Project:
> Confirmed
>
> Bug description:
> I have installed php53u on centos 5.8 from the repo. I can install
> ioncube just fine and php -v gives me the correct output. When I
> install xcache then ioncube complains it is not first in
> /etc/php.ini. The problem is they are not loading loading from
> /etc/php.ini they are loading from /etc/php.d/. So if the system is
> working correctly ioncube would load first as it comes before xcache.
>
> I know it is a problem with xcache as I have the zend guard loader
> installed and it works fine also.
>
> I have tried editing /etc/php.ini and telling ioncube to load before
> xcache and it did not work. (Yes I deleted the corresponding
> /etc/php.d/ entries first so they did not double load.)
>
> OS = Centos 5.8
>
> PHP = 5.3u
>
> Packages = php53u-5.3.18-1.ius.el5.i386, php53u-ioncube-
> loader-4.2.2-1.ius.el5.i386, php53u-xcache.i386 0:3.0.0-1.ius.el5
>
> Steps to reproduce problem = Just install the packages is all I have
> done.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ius/+bug/1088667/+subscriptions
>

bharper (bharper) wrote :

The updated version of xcache is currently available in the stable repos.

-Ben

Changed in ius:
status: Confirmed → Fix Released
Shawn (slackersu) wrote :

Thank you for keeping me updated Ben.

Shawn

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.