Istanbul freezes when recording ends with Record Sound

Bug #63996 reported by michelem on 2006-10-04
162
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Istanbul
Won't Fix
High
istanbul (Debian)
Fix Released
Unknown
istanbul (Ubuntu)
Medium
Unassigned
Nominated for Hardy by Brad Langhorst
Nominated for Intrepid by Mark Stosberg
Nominated for Karmic by scified
Nominated for Lucid by Mark Stosberg

Bug Description

When I try to record a screencast with istanbul the applet loads correctly and I can click the start record icon, but when I try to stop recording I cannot do it.

The Istanbul icon changes to a disk indicating it is saving, but nothing ever happens. It has frozen, and needs to be killed.

This occurs only when the Record Sound option is enabled.

WORKAROUND:
Disable the Record Sound option.

Related branches

Onkar Shinde (onkarshinde) wrote :

This is not reproducible on my side.

What is the version of istanbul you are using? It is quite possible that it didn't get updated. The problem you have specified was in Dapper version of istanbul.

michelem (michele-marcucci) wrote :

mik@604:~$ istanbul --version
0.2.1

mik@604:~$ dpkg -l istanbul
ii istanbul 0.2.1-0ubuntu3 Desktop session recorder

Dave Morley (davmor2) wrote :

I can confirm on my amd 64 bit it doesn't shut down after it has saved the file.

I'm using Edgy Eft with Istanbul 0.2.1, and I get the same problem.

If it helps at all, this is the terminal output:

istanbul
(1169, 953) - (80, 5)
DEBUG: final pipeline: oggmux name=mux ! filesink location=/tmp/tmp4ut8Yc istximagesrc startx=1169 starty=953 endx=79 endy=4 name=videosource ! video/x-raw-rgb,framerate=10/1 ! videorate ! ffmpegcolorspace ! videoscale method=1 ! video/x-raw-yuv,width=-544,height=-474,framerate=10/1 ! theoraenc ! queue ! mux. gconfaudiosrc name=audiosource ! audioconvert ! vorbisenc ! queue ! mux.
Traceback (most recent call last):
  File "/var/lib/python-support/python2.4/istanbul/main/tray_icon.py", line 56, in _trayicon_clicked
    self.current_screencast.start_recording()
  File "/var/lib/python-support/python2.4/istanbul/main/screencast.py", line 109, in start_recording
    self._pipeline = gst.parse_launch(final_pipeline)
gobject.GError: could not link videoscale0 to theoraenc0
Traceback (most recent call last):
  File "/var/lib/python-support/python2.4/istanbul/main/tray_icon.py", line 62, in _trayicon_clicked
    self.current_screencast.stop_recording()
  File "/var/lib/python-support/python2.4/istanbul/main/screencast.py", line 136, in stop_recording
    self._vsource.set_state(gst.STATE_NULL)
AttributeError: Screencast instance has no attribute '_vsource'

It appears to do this only when I have the Record Sound option checked. Otherwise, it works just fine.

Lex Berger (lexberger) wrote :

confirming on feisty, istanbul 0.2.1-3build1

John Carr (johncarr) wrote :

confirming on feisty, istanbul 0.2.1

Lex Berger (lexberger) wrote :

I can confirm what aysiu has reported: When I uncheck "Record Sound", the bug does not appear.

Onkar Shinde (onkarshinde) wrote :

Marking confirmed as per comments.

Changed in istanbul:
status: Unconfirmed → Confirmed
michelem (michele-marcucci) wrote :

I upgraded to feisty some months ago and the problem is still there, this is my output:

mik@goa:~$ istanbul
/usr/lib/python2.4/site-packages/cairo/__init__.py:1: RuntimeWarning: Python C API version mismatch for module cairo._cairo: This Python has API version 1013, module cairo._cairo has version 1012.
  from _cairo import *
/usr/lib/python2.4/site-packages/gst-0.10/gst/__init__.py:108: RuntimeWarning: Python C API version mismatch for module _gst: This Python has API version 1013, module _gst has version 1012.
  from _gst import *
/usr/lib/python2.4/site-packages/gst-0.10/gst/__init__.py:109: RuntimeWarning: Python C API version mismatch for module interfaces: This Python has API version 1013, module interfaces has version 1012.
  import interfaces
/usr/lib/python2.4/site-packages/istanbul/main/tray_icon.py:26: DeprecationWarning: the module egg.trayicon is deprecated; equivalent functionality can now be found in pygtk 2.10
  import egg.trayicon

DEBUG: final pipeline: oggmux name=mux ! filesink location=/tmp/tmpqzuOFq istximagesrc name=videosource show-pointer=false ! video/x-raw-rgb,framerate=10/1 ! videorate ! ffmpegcolorspace ! videoscale method=1 ! video/x-raw-yuv,width=1400,height=1050,framerate=10/1 ! theoraenc ! queue ! mux. gconfaudiosrc name=audiosource ! audioconvert ! vorbisenc ! queue ! mux.
Traceback (most recent call last):
  File "/usr/bin/istanbul", line 40, in <module>
    sys.exit(main.main(sys.argv))
  File "/usr/lib/python2.4/site-packages/istanbul/main/main.py", line 86, in main
    gtk.main()
KeyboardInterrupt

Lex Berger (lexberger) wrote :

Adding the output of
$ istanbul --gst-debug-level=3

KillerKiwi (killerkiwi2005) wrote :

Im getting this in gutsy, checking sound creates a crash

DanFoxDavies (danfox) wrote :

Bug confirmed in Ubuntu Gutsy 64bit
Can not save file.
The icon freezes on 'In process of saving to disk'
The Istanbul process under the System Monitor goes to sleep.
No Ogg file gets saved.
But only if you want to record sound.
:-(

Xan (dxpublica) wrote :

hi,

it looks like but since my bug report i have disabled pulseaudio and i
have the same problem.

I tried to debug istanbul. The sole thing i have seen is that when
python says to GST to stop the pipes, istanbul wait for dbus messages
from GST that never come.

Regards,

Edouard

Le jeudi 03 janvier 2008 à 11:04 +0000, Xan a écrit :
> Is https://bugs.launchpad.net/ubuntu/+source/istanbul/+bug/86281 a duplicate of this bug?
> Not of all,
>

same bug in xubuntu 8.04 alpha5 , crash when i try to save my record .

oskar (oskar669) wrote :

Same thing here.
Since it's the same with xvidcap and gtkrecordmydesktop, it would be nice if someone could fix just one of those programs, so we can do screen recordings.

The Ubuntu Screencast team also suggest you record audio and video separately. I can't imagine what the problem is having both functions in one program... but then I'm not a programmer.
Ubuntu Screencasting tutorial:
https://wiki.ubuntu.com/ScreencastTeam/RecordingScreencasts

michelem (michele-marcucci) wrote :

The bug is still present in Hardy Heron Alpha 6 with i915 video driver

Martin Schaaf (mascha) wrote :

This are the commands that instanbul calls. They work if you call them them on a terminal.

gst command line complete screen without 3d
gst-launch-0.10 oggmux name=mux ! filesink location=/tmp/tmppUzJ_f istximagesrc name=videosource display-name=:0.0 screen-num=0 ! video/x-raw-rgb,framerate=10/1 ! videorate ! ffmpegcolorspace ! videoscale method=1 ! video/x-raw-yuv,width=1280,height=800,framerate=10/1 ! theoraenc ! queue ! mux. gconfaudiosrc name=audiosource ! audioconvert ! vorbisenc ! queue ! mux.

gst command line screen part with 3d
oggmux name=mux ! filesink location=/tmp/tmpNvkdPj istximagesrc name=videosource display-name=:0.0 screen-num=0 startx=263 starty=98 endx=829 endy=511 use-damage=false ! video/x-raw-rgb,framerate=10/1 ! videorate ! ffmpegcolorspace ! videoscale method=1 ! video/x-raw-yuv,width=567,height=414,framerate=10/1 ! theoraenc ! queue ! mux. gconfaudiosrc name=audiosource ! audioconvert ! vorbisenc ! queue ! mux.

I've nominated this problem for hardy since its not just a missing feature, but a total application hang and is 100% reproducible on my system (and others aparently)

Lex Berger (lexberger) wrote :

The bug is still present in Hardy Heron final, nvidia video driver.

Changed in istanbul:
status: Unknown → Confirmed
alfonx (skpublic) wrote :

Confirming the bug for Hardy. ( istanbul version 0.2.2-2 ).
I try to record with sound, with mouse, without 3d.
I have a Thinkpad Z61m with fglrx driver... in case it matters.

The trayicon hangs and shows the tooltip "in process of saving to disk".

Ron Shank (rshank) wrote :

Another Confirmation -- only with sound enabled.

Hardy 8.04
Istanbul 0.2.2

~$ lspci | grep VGA
00:05.0 VGA compatible controller: nVidia Corporation C51 [Geforce 6150 Go] (rev a2)

Let's blame nVidia! :)

Happens in my Hardy box, too. With sound DISABLED.

Jim J (morlockhq) wrote :

Confirmed on Hardy Heron (8.04) on my computer as well. Sound is disabled and using a generic Intel onboard graphics chipset.

Istanbul allows me to click record, but then hangs and won't let my stop the recording.

The only way to stop it is to kill the process manually.

Jim J (morlockhq) wrote :

As a lark, I turned off Visual Effects and Istanbul started working properly. I don't have a way to input sound, but it looks like it at least works with Visual Effects (System -> Preferences -> Appearance -> Visual Effects -> None) turned off for my system.

Greg (ggbaker) wrote :

Confirmed here. I was having the same problem (hanging after starting recording). After turning visual effects off, it works correctly.

This started after I did the Hardy upgrade from Gutsy (or very near then, at least).

devvv (devvv) wrote :

Confirming hanging "in process of saving to disk" only when sound recording is enabled. Hardy Heron AMD 64

Is importance "unknown" ok? I think this is a CRITICAL bug of this application (at least its Ubuntu port).

Leon Smith (lsmith-leonsmith) wrote :

Confirmed on Hardy Heron final. Changing visual effects has no effect for me, neither does turning off sound. However, if I run istanbul from a terminal window as root (sudo istanbul) it does finish writing the file, but the result is choppy and horrible quality.

I noticed the first bug report was in 2006 ! Is there ANY work underway on this ? I am having the same problem as oskar; since upgrade to Heron I can't use istanbul, xvidcap or recordmydesktop. Please don't make me use Windows for my project.

Uwe L. Korn (uwelk) wrote :

Confirmed it on Hardy Heron Final with Istanbul 0.2.2 except(!) for turning on 3D Record when running as root, as an unprivileged user nothing works.

I confirm this bug in my Hardy Heron too.

ScorpFromHell (a.premkumar) wrote :

Confirmed on my Hardy Heron.

Tried running Istanbul as root, without 3D, without sound. All failed.

Tried disabling Visual Effects, works like a charm. Thanks to Jim's comment above: https://bugs.launchpad.net/ubuntu/+source/istanbul/+bug/63996/comments/27

Martin G Miller (mgmiller) wrote :

I also can't run istanbull in Hardy 8.04.1. I have uninstalled it and installed gtk-recordmydesktop. It seems to work perfectly.

k65 (petersanders65) wrote :

I can confirm this as well. On 8.04 including all updates it hangs and I have to kill the process. I cannot save any screencast and therefore istanbul is useless to me. Istanbul version 0.2.2

rhi (rhi-deactivatedaccount) wrote :

Could you please update the bug importance to critical?

Hew McLachlan (hew) wrote :

This bug still exists with istanbul 0.2.2-4 on Intrepid. Upstream have committed a hacky patch, but since the last Istanbul release was Feb 2007, this hasn't made it to Ubuntu yet.

Remember that unchecking "Record Sound" is a workaround for this issue.

This bug is of medium importance, so I have marked it as such. Please read https://wiki.ubuntu.com/Bugs/Importance for an explanation of bug importance.

Changed in istanbul:
importance: Undecided → Medium
status: Confirmed → Triaged
Hew McLachlan (hew) on 2008-09-30
description: updated
sole (solesole) wrote :

I confirm it doesn't work in hardy (ubuntu studio flavour). I tried with or without sound and using sudo or with normal user... it always hangs at the "saving to disk" stage.

zpon (zpon-dk) wrote :

I have the same problem in 8.10, it does not help to uncheck "Record sound" for, i'm using amd64, could this have something to do with the problem? I see others having the problem is also using 64bit

Myk Melez (myk-melez) wrote :

zpon: I experience the problem in a 32bit system, and my experience is exactly as described here (i.e. unchecking "Record sound" makes everything work), so it sounds like you might be encountering a different bug.

Daniele (rizzo-dani) wrote :

same problem here on Ubuntu 8.10 Intrepid with latest updates
unchecking "Record Sound" makes it work

Unchecking Sound does not help for me either, I can't find a workaround.
istanbul 0.2.2-4, interpid, Intel(R) Core(TM)2 CPU.
Attached is the output of istanbul --gst-debug-level=5 --gst-debug-no-color (gzipped).
Recording starts around line 16155 and stops right at the end.

I can stop istanbul using ctrl-C while it is recording. Once I try to stop it ctrl-C no longer works and I have to kill the process (send SIGTERM using killall)

Wydd (monaco-icmc) wrote :

It happens also here: unchecking "Record sound" does not help. Disabling desktop effect does.

Intrepid, istanbul 0.2.2-4, 32bit, nvidia graphics.

Only way to terminate istanbul is with SIGTERM.

Hew McLachlan (hew) wrote :

I see a few people here claim to have the same freeze bug, but disabling "Record sound" does not fix the problem. I suggest you open a new bug report, as it sounds like a different issue.

Hew is correct, from what I can tell there are two errors here.

First - there is a problem with deskcasting with istanbul with the "Record Sound" option enabled. This bug, as far as I can tell, is 100% reproducible in the current version of Ubuntu (8.10). All errors regarding this bug, (and this bug only) should go in this bug report.

Second - there is a bug that arises from using istanbul with desktop effects enabled. I *can* reproduce this bug if I *do not* have the "Record 3D" option enabled. If I enable "Record 3D", istanbul works fine. This probably has something to do with istanbul not recognizing ANY GPU output when this option is not enabled, and having problems with the 2D acceleration used for compiz effects. Comments on this bug should into newly created bug bug 307827 .

Keeping these two problems separated helps cut down on the confusion and provides developers with more information to help fix the problem. Thanks for taking the time to help make Ubuntu better!

RicardoHdez (ricardo-geocon) wrote :

I don't have problem with compiz on, i make a video good (see the attachment), the problem is went record sound.
Other insure is wend i tried to record without 3d record, the video recorded no have good shape.
I think there are two bugs, the first one is record sound y the other is 3d record.
Other one is went i record one specific window, only record one area of the screen.

So... I've noticed this at the end of 2007, and this still happens with Ubuntu Intrepid 8.10.
Tried killing pulseaudio, removed alsa.... nothing.... installed OSS4 and the samething still happens when Sound Rec is on.
If we only had config options for Istanbul.... like audio settings. It's probably looking for some alsa config that doesn't even exist... or some other sound lib....

Hew McLachlan (hew) wrote :

Istanbul appears to be unmaintained, so these bugs have just never been fixed. For those that are not aware, gtk-recordmydesktop is an application which provides similar functionality to istanbul, and may be useful for users that just want a stable screencasting app.

That's what I switched to and works for the most part.

I found that I had problems editing or viewing the resulting Ogg file
on some platforms so I use this ffmpeg based script to transcode the
file:

#!/bin/bash

INPUT_FILE=$1
OUTPUT_FILE=$2

ffmpeg -i ${INPUT_FILE} -s 960x720 -vcodec mpeg4 ${OUTPUT_FILE}

On Fri, Feb 20, 2009 at 4:16 AM, Hew McLachlan <email address hidden> wrote:
> Istanbul appears to be unmaintained, so these bugs have just never been
> fixed. For those that are not aware, gtk-recordmydesktop is an
> application which provides similar functionality to istanbul, and may be
> useful for users that just want a stable screencasting app.
>
> --
> Istanbul freezes when recording ends with Record Sound
> https://bugs.launchpad.net/bugs/63996
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Heavyworks (heavyworks) wrote :

My experience reflected a misunderstanding rather than a bug.

I was getting these hangs when saving the video but when I read people saying about disabling Compiz (Visual Effects -> None) I thought that maybe we were thinking the wrong way.

You must configure istanbul whether you're using Compiz or not. Compiz is a 3D and "normal" Gnome isn't so I think that the video engine should switch accordingly.

Checking "Record 3D" while in my Compiz environment made the software work like a charm (and that's why it worked with this option unchecked + no compiz). So if compiz, "Record 3D" checked, not, unchecked.

The "Record Sound" issue has as responsible the great "pulse audio" because istanbul (and other apps) tries to access the sound device directly (/dev/..) in order of pulse audio. I think that this may be corrected by configuring environment variables or somenthing, havent tested.

Hope this helps somebody!

Regards from Brazil

Pablo Rodríguez (ousia) wrote :

I discovered this just accidentally, trying to set a higher video recording quality.

The issue mentioned above has been discussed at http://bugzilla.gnome.org/show_bug.cgi?id=430151 and there is a workaround at http://bugzilla.gnome.org/attachment.cgi?id=86405.

I hope it helps,

Pablo

David D Lowe (flimm) wrote :

I can confirm that this bug is still an issue on Ubuntu 9.10, and that the workaround suggested by Pablo Rodríguez works.

David D Lowe (flimm) wrote :

As upstream hasn't released a version of Instanbul with this fixed, I'm attaching a patch to the deb.
The source of this patch is https://bugzilla.gnome.org/show_bug.cgi?id=430151#c1

Evan Broder (broder) on 2009-12-17
Changed in istanbul (Ubuntu):
assignee: nobody → Evan Broder (broder)
status: Triaged → In Progress
Evan Broder (broder) wrote :

Hi David -
  This patch looks very good, but since istanbul is already using quilt to track source patches, could you re-write your debdiff to add a new quilt patch? There's some docs on using quilt at <https://wiki.ubuntu.com/PackagingGuide/Howtos/Quilt>

Since you're working on the diff, please don't use Debian's Closes: syntax for bug closers. The syntax here is just "(LP: #nnnnnn)". Also, please re-target the changelog entry for the current development release, Lucid.

I've unsubscribed ubuntu-universe-sponsors, but feel free to re-subscribe when you've had a chance to update the patch - I'd be happy to sponsor it then.

Changed in istanbul (Ubuntu):
assignee: Evan Broder (broder) → David D Lowe (flimm)
status: In Progress → Incomplete
saidimu apale (saidimu) wrote :

I applied the patch mentioned here http://bugzilla-attachments.gnome.org/attachment.cgi?id=86405 but it hasn't once worked for me.

The first run after patch application briefly showed the save-file dialog but it crashed before I could give focus to the window. Subsequent istanbul runs still exhibit the old pre-patch problem.

I'm on Karmic (2.6.31-17-generic) running the default repo version of istanbul.

Here's how I applied the patch:

- save the patch to, e.g. /tmp/istanbul-patch.txt
- cd /usr/share/pyshared/istanbul/main/
- sudo patch -b -p2 </tmp/istanbul-patch.txt

A backup is created in-case you need to revert to the original file.

I tried gtk-RecordMyDesktop but it has audio-video sync problems, so it isn't much of an option.

saidimu apale (saidimu) wrote :

Without the patch, there is another workaround:

Since istanbul saves the recorded file to /tmp (with a random filename) after the recording session (even with sound and 3D turned-on), just go to /tmp and rename your file (it is already encoded as .ogv)

It appears that only the file-save dialog is improperly displayed (or not at all), but everything else works fine. I've tested it multiple times on Karmic (2.6.31-17-generic) running the default repository version (patched and unpatched). The quality is better than gtk-recordMyDesktop, especially a/v sync.

David D Lowe (flimm) wrote :

Thanks Evan. I've done what you asked.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package istanbul - 0.2.2-5ubuntu1

---------------
istanbul (0.2.2-5ubuntu1) lucid; urgency=low

  * Applied patch to screencast.py to allow recording sound. (LP: #63996)
 -- David D Lowe <email address hidden> Fri, 18 Dec 2009 18:05:10 +0000

Changed in istanbul (Ubuntu):
status: Incomplete → Fix Released
Evan Broder (broder) wrote :

That's much better, thanks. I've uploaded the fix to Lucid, and the Launchpad Janitor should close the ticket when the upload is accepted.

Changed in istanbul (Ubuntu):
assignee: David D Lowe (flimm) → nobody
EAB (adair-boder) wrote :

Can someone help me implement this fix in Karmic?

EAB (adair-boder) wrote :

Nevermind ... i got it sorted. the patch works by the way! Cheers

babygenius55 (babygenius55a) wrote :

Just out of curiosity, when I have a high res set to record I can't get istanbul to work right...This is a real bother. Thank for the tip Saidimu

use XVidCap or wait another year to see if this is fixed. :-)

-----Original Message-----
From: "babygenius55" <email address hidden>
Sent: Thursday, March 4, 2010 8:59am
To: <email address hidden>
Subject: [Bug 63996] Re: Istanbul freezes when recording ends with Record Sound

Just out of curiosity, when I have a high res set to record I can't get
istanbul to work right...This is a real bother. Thank for the tip
Saidimu

--
Istanbul freezes when recording ends with Record Sound
https://bugs.launchpad.net/bugs/63996
You received this bug notification because you are a direct subscriber
of the bug.

Status in Desktop session recorder: Confirmed
Status in “istanbul” package in Ubuntu: Fix Released

Bug description:
When I try to record a screencast with istanbul the applet loads correctly and I can click the start record icon, but when I try to stop recording I cannot do it.

The Istanbul icon changes to a disk indicating it is saving, but nothing ever happens. It has frozen, and needs to be killed.

This occurs only when the Record Sound option is enabled.

WORKAROUND:
Disable the Record Sound option.

To unsubscribe from this bug, go to:
https://bugs.launchpad.net/istanbul/+bug/63996/+subscribe

Pablo Rodríguez (ousia) wrote :

The bug was reported almost four years ago and it affects to 15 people at least.

Would it be possible to apply the provided patch and release the updated version?

It might not work for all, but since Istanbul doesn't seem to be developed further, this is better than nothing.

Thanks for your help,

Pablo

Alroger Filho (alroger-filho) wrote :

15 people? that makes me laugh.
If I only knew how to do it...

I've moved on to XVid or VLC (yes it CAN Do screen capture video and audio).

On Sat, May 1, 2010 at 4:38 PM, Alroger Filho <email address hidden>wrote:

> 15 people? that makes me laugh.
> If I only knew how to do it...
>
> --
> Istanbul freezes when recording ends with Record Sound
> https://bugs.launchpad.net/bugs/63996
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Desktop session recorder: Confirmed
> Status in “istanbul” package in Ubuntu: Fix Released
>
> Bug description:
> When I try to record a screencast with istanbul the applet loads correctly
> and I can click the start record icon, but when I try to stop recording I
> cannot do it.
>
> The Istanbul icon changes to a disk indicating it is saving, but nothing
> ever happens. It has frozen, and needs to be killed.
>
> This occurs only when the Record Sound option is enabled.
>
> WORKAROUND:
> Disable the Record Sound option.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/istanbul/+bug/63996/+subscribe
>

Hew McLachlan (hew) wrote :

This bug is marked as fixed for Lucid.

Alroger Filho (alroger-filho) wrote :

I had the same problem in Lucid. Then I tried closing all apps, including empathy and then it worked. I mean it didn't freeze. But it records only a bit of sound then starts cuting it up... basically still doesn't work with sound capture.

Leon Smith (lsmith-leonsmith) wrote :

I had just assumed that all work had stopped on Istanbul. There are good
alternatives out there.

On Sat, May 8, 2010 at 9:40 AM, Alroger Filho <email address hidden>wrote:

> I had the same problem in Lucid. Then I tried closing all apps,
> including empathy and then it worked. I mean it didn't freeze. But it
> records only a bit of sound then starts cuting it up... basically still
> doesn't work with sound capture.
>
> --
> Istanbul freezes when recording ends with Record Sound
> https://bugs.launchpad.net/bugs/63996
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Desktop session recorder: Confirmed
> Status in “istanbul” package in Ubuntu: Fix Released
>
> Bug description:
> When I try to record a screencast with istanbul the applet loads correctly
> and I can click the start record icon, but when I try to stop recording I
> cannot do it.
>
> The Istanbul icon changes to a disk indicating it is saving, but nothing
> ever happens. It has frozen, and needs to be killed.
>
> This occurs only when the Record Sound option is enabled.
>
> WORKAROUND:
> Disable the Record Sound option.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/istanbul/+bug/63996/+subscribe
>

Kẏra (thekyriarchy) wrote :

Not that use Gstreamer

On Sat, May 8, 2010 at 13:09, Leon Smith <email address hidden> wrote:
> I had just assumed that all work had stopped on Istanbul. There are good
> alternatives out there.
>
> On Sat, May 8, 2010 at 9:40 AM, Alroger Filho
> <email address hidden>wrote:
>
>> I had the same problem in Lucid. Then I tried closing all apps,
>> including empathy and then it worked. I mean it didn't freeze. But it
>> records only a bit of sound then starts cuting it up... basically still
>> doesn't work with sound capture.
>>
>> --
>> Istanbul freezes when recording ends with Record Sound
>> https://bugs.launchpad.net/bugs/63996
>> You received this bug notification because you are a direct subscriber
>> of the bug.
>>
>> Status in Desktop session recorder: Confirmed
>> Status in “istanbul” package in Ubuntu: Fix Released
>>
>> Bug description:
>> When I try to record a screencast with istanbul the applet loads correctly
>> and I can click the start record icon, but when I try to stop recording I
>> cannot do it.
>>
>> The Istanbul icon changes to a disk indicating it is saving, but nothing
>> ever happens. It has frozen, and needs to be killed.
>>
>> This occurs only when the Record Sound option is enabled.
>>
>> WORKAROUND:
>> Disable the Record Sound option.
>>
>> To unsubscribe from this bug, go to:
>> https://bugs.launchpad.net/istanbul/+bug/63996/+subscribe
>>
>
> --
> Istanbul freezes when recording ends with Record Sound
> https://bugs.launchpad.net/bugs/63996
> You received this bug notification because you are the registrant for
> Istanbul.
>

--
.danny

☮♥Ⓐ - http://www.google.com/profiles/danny.piccirillo
Every (in)decision matters.

Pablo Rodríguez (ousia) wrote :

Sorry for my previous comment, since I thought the patch wasn't applied.

There seems to be a new patch against CVS head, that might fix the problem (http://bugzilla-attachments.gnome.org/attachment.cgi?id=163377). It doesn't seem to work with version from Ubuntu 10.04.

I hope it helps,

Pablo

beccon (beccon) wrote :

Well, at least 16 people have this problem with Istanbul - the 15 aforementioned and me.

I found a quite crude workaround: disable sound recording in Istanbul, use the gnome sound recorder, save both files as ogg, join images and sound in pitivi (also able to edit it a bit)

It works for me but it is still nuts. It should be possible to patch the packets shouldn't it. Istanbul is a nice application: simple, straight forward, integrates well into the desktop. It's a pity it has that glitch.

Conrad

beccon (beccon) wrote :

Just installed the version 0.2.2-6 from ppa - and it works like a charm :-)

Thank you
Conrad

Kẏra (thekyriarchy) wrote :

which ppa?

Changed in istanbul (Debian):
status: Unknown → Fix Released
Changed in istanbul:
importance: Unknown → High

Bug,

I'd like to add you to my professional network on LinkedIn.

- Leon

Leon Smith
Founder at California Software Studio
Chico, California Area

Confirm that you know Leon Smith:
https://www.linkedin.com/e/-lezkt5-gvv39bc2-5t/isd/5148386745/_SEWKinh/?hs=false&tok=1rs4nCydnVw501

--
You are receiving Invitation to Connect emails. Click to unsubscribe:
http://www.linkedin.com/e/-lezkt5-gvv39bc2-5t/vQ6iJeSb2gKKXePLtKpthReQFX02015iIkap--/goo/63996%40bugs%2Elaunchpad%2Enet/20061/I1795072177_1/?hs=false&tok=2QiwwxP_jVw501

(c) 2011 LinkedIn Corporation. 2029 Stierlin Ct, Mountain View, CA 94043, USA.

Changed in istanbul:
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.