Apple Built-in iSight Firmware Tools for Linux

Snow Leopard 10.6 AppleUSBVideoSupport firmware does not work

Reported by Fabiano Francesconi on 2009-09-03
42
This bug affects 7 people
Affects Status Importance Assigned to Milestone
iSight Firmware Tools
Undecided
Deborah Conte

Bug Description

As your tool requests, I upload here the iSight firmware supplied with Snow Leopard.

Full path: /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBVideoSupport.kext/Contents/MacOS/AppleUSBVideoSupport

Macbook 4,1
Snow Leopard - OSX 10.6 (fresh install)

Used version: 1.4.2
Please remove the firmware when you downloaded it ;)

description: updated

MD5sum of my AppleUSBVideoSupport file: 602f49036c0ccc775f98b0374bad29a7

Confirmed. That's my MD5sum too.

Hi,

I lost the file, can you resend it ? :/

Étienne

Don't care about 'new' in the filename :P

Étienne BERSAC (bersace) wrote :

Le jeudi 24 septembre 2009 à 04:00 +0000, Pete Ashdown a écrit :
> MD5sum of my AppleUSBVideoSupport file: 602f49036c0ccc775f98b0374bad29a7
>

I don't have this file. Please file a new bug for this driver signature.
(With file and both OS version and machine description).

Étienne.

Changed in isight-firmware-tools:
status: New → Fix Released
Étienne BERSAC (bersace) wrote :

Hi,

Ok, i've been confused by Pete comment, your file is already supported by 1.5.90. Please tests :)

Regards,
Étienne.

You are right. Tried with git sources and it did work.

Btw I had to comment out "doc/Makefile.am" otherwise autogen would fail:
 doc/Makefile.am:1: `%'-style pattern rules are a GNU make extension
 automake-1.10: cannot open < doc/ift-extract.texi: No such file or directory

Thank you :)

Kẏra (kxra) wrote :

can somebody attach the isight.fw file from Snow Leopard 10.6 so that i may use it (wiped OSX for Ubuntu)

Pablo Martí (pmarti) wrote :

I've got the same hardware (4.1) than the original poster and isight-firmware-tools (1.5.90-0ubuntu1) core dumped with the same AppleVideoSupport (same md5). Attaching log, do let me know if you need anything else

Kẏra (kxra) wrote :

Sorry i'm confused. I thought i should be able to just drop isight.fw into /lib/firmware/ (ref: https://help.ubuntu.com/community/MactelSupportTeam/AppleiSight) so I was looking for the actual isight.fw file because i wiped OSX for Ubuntu. MacBook version 5,2

Sorry to use this bug looking for help...

Attached.

Danny Piccirillo wrote:
> Sorry i'm confused. I thought i should be able to just drop isight.fw
> into /lib/firmware/ (ref:
> https://help.ubuntu.com/community/MactelSupportTeam/AppleiSight) so I
> was looking for the actual isight.fw file because i wiped OSX for
> Ubuntu. MacBook version 5,2
>
> Sorry to use this bug looking for help...
>
>

cyrussi (cyrussi) on 2009-10-15
Changed in isight-firmware-tools:
status: Fix Released → Confirmed
status: Confirmed → Fix Released
-lorenzo87- (lorenzo87-) wrote :

hi, just installed ubuntu lucid and compiled ift 1.5.90 but can't find the firmware in my file, i am using a white macbook penryn 13".. is there a solution?

Deborah Conte (dconte) on 2011-04-13
Changed in isight-firmware-tools:
assignee: nobody → Deborah Conte (dconte)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers