Rescue ramdisk doesn't boot on UEFI

Bug #1749860 reported by Hironori Shiina on 2018-02-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ironic
Fix Released
High
Hironori Shiina

Bug Description

Rescue ramdisk failed to boot in an envitonment built by DevStack with IRONIC_BOOT_MODE=uefi. After the node was rebooted for rescuing, the following error occurs in the node.
  /pxelinux.cfg/52-54-00-5a-aa-7c... ok
  http://192.168.1.10:3928/b92828f5-135b-47b7-85c8-a1126161a5c8/rescue_kernel... ok
  http://192.168.1.10:3928/b92828f5-135b-47b7-85c8-a1126161a5c8/rescue_ramdisk... ok
  Failed to open file: deploy_ramdisk
  Trying to load files to higher address
  Failed to open file: deploy_ramdisk

This is caused by kernel parameter 'initrd' is hardcoded in iPXE config template like 'initrd=deploy_ramdisk'[1]. This should be 'initrd=rescue_ramdisk' at rescuing.

[1] https://github.com/openstack/ironic/blob/6883674b3c4b016ba36b73bb385ec8813d88f93f/ironic/drivers/modules/ipxe_config.template#L7

Changed in ironic:
assignee: nobody → Hironori Shiina (shiina-hironori)

Fix proposed to branch: master
Review: https://review.openstack.org/545186

Changed in ironic:
status: New → In Progress
Dmitry Tantsur (divius) on 2018-02-19
Changed in ironic:
importance: Undecided → High
tags: added: rescue
tags: added: uefi

Reviewed: https://review.openstack.org/545186
Committed: https://git.openstack.org/cgit/openstack/ironic/commit/?id=8f2e487b2bd9168822268fcca1ab43ff93084afe
Submitter: Zuul
Branch: master

commit 8f2e487b2bd9168822268fcca1ab43ff93084afe
Author: Hironori Shiina <email address hidden>
Date: Fri Feb 16 10:03:19 2018 +0900

    Set 'initrd' to 'rescue_ramdisk' for rescue with iPXE

    The kernel paramter 'initrd' is hard-coded as 'deploy_ramdisk' in iPXE
    config template. A rescue ramdisk may fail to boot due to this wrong
    paramter. This patch sets this 'initrd' paramter properly to
    'deploy_ramdisk' or 'rescue_ramdisk' by adding a new pxe option.

    Change-Id: I8ad1223dc289bbe915ee4ca8db66c8f80bf08f15
    Closes-Bug: 1749860

Changed in ironic:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/546955
Committed: https://git.openstack.org/cgit/openstack/ironic/commit/?id=6f3e8927e69d6ef781786bbfbeb511f8611991d0
Submitter: Zuul
Branch: stable/queens

commit 6f3e8927e69d6ef781786bbfbeb511f8611991d0
Author: Hironori Shiina <email address hidden>
Date: Fri Feb 16 10:03:19 2018 +0900

    Set 'initrd' to 'rescue_ramdisk' for rescue with iPXE

    The kernel paramter 'initrd' is hard-coded as 'deploy_ramdisk' in iPXE
    config template. A rescue ramdisk may fail to boot due to this wrong
    paramter. This patch sets this 'initrd' paramter properly to
    'deploy_ramdisk' or 'rescue_ramdisk' by adding a new pxe option.

    Change-Id: I8ad1223dc289bbe915ee4ca8db66c8f80bf08f15
    Closes-Bug: 1749860
    (cherry picked from commit 8f2e487b2bd9168822268fcca1ab43ff93084afe)

tags: added: in-stable-queens

This issue was fixed in the openstack/ironic 10.1.1 release.

This issue was fixed in the openstack/ironic 11.0.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers