[RFE] Add guru meditation report for ironic

Bug #1526423 reported by Vladyslav Drok
4
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ironic
Fix Released
Wishlist
Madhuri Kumari

Bug Description

Oslo_reports enables OpenStack projects to dump Guru Meditation Reports with useful debugging information to files or stderr. So we introduce it into ironic.

Vladyslav Drok (vdrok)
Changed in ironic:
status: New → Confirmed
importance: Undecided → Wishlist
tags: added: rfe
Revision history for this message
Jim Rollenhagen (jim-rollenhagen) wrote :

I don't think this will need a spec, but I'd like more details on what changes are required before approving this RFE.

Revision history for this message
Ruby Loo (rloo) wrote :

ditto with Jim's comment #1. How does the user indicate that they want a report generated? (What is a Guru meditation report anyway, makes me think that ironic will go to a retreat.)

Revision history for this message
Madhuri Kumari (madhuri-rai07) wrote :

Below link gives an idea of what is GMR and how is it generated
#link docs.openstack.org/developer/nova/gmr.html

(copied)A GMR can be generated by sending the USR2 signal to any Nova process with support (see below). The GMR will then be outputted standard error for that particular process.

For example, suppose that nova-api has process id 8675, and was run with 2>/var/log/nova/nova-api-err.log. Then, kill -USR2 8675 will trigger the Guru Meditation report to be printed to /var/log/nova/nova-api-err.log.

Changed in ironic:
assignee: nobody → Madhuri Kumari (madhuri-rai07)
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to ironic (master)

Fix proposed to branch: master
Review: https://review.openstack.org/413436

Changed in ironic:
status: Confirmed → In Progress
Revision history for this message
Ruby Loo (rloo) wrote :

Madhuri, are you planning on implementing a similar thing in ironic, as what is in nova? For both the api & conductor services? What about the structure of the GMR, were you going to extend it beyond package, threads, green threads, and configuration?

We're going to need documentation for this, probably in our non-existing admin guide: http://docs.openstack.org/developer/ironic/#administrator-s-guide

Revision history for this message
Madhuri Kumari (madhuri-rai07) wrote :

@Jim, we just need to enable GMR report before running server and reports can be generated anytime as per operators' need.

@Ruby, it will be same as nova and for all the services in Ironic(api and conductor). This features will currently support the minimal features that GMR provides itself.

If excepted, I will write update the docs also.

Revision history for this message
Ruby Loo (rloo) wrote :

I'm good with this (and it not requiring a spec).

Revision history for this message
Jim Rollenhagen (jim-rollenhagen) wrote :

+2

Revision history for this message
Ruby Loo (rloo) wrote :

I changed the tag to rfe-approved since Jim and I are good with it.

tags: added: rfe-approved
removed: rfe
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to ironic (master)

Reviewed: https://review.openstack.org/413436
Committed: https://git.openstack.org/cgit/openstack/ironic/commit/?id=7366479a94c6ed311bf71fdeedd18e2d53a0cb5a
Submitter: Jenkins
Branch: master

commit 7366479a94c6ed311bf71fdeedd18e2d53a0cb5a
Author: Madhuri Kumari <email address hidden>
Date: Wed Dec 21 12:03:38 2016 +0530

    Add guru meditation report support

    Oslo_reports enables OpenStack projects to dump
    Guru Meditation Reports with useful debugging
    information to files or stderr. For example,
    what threads are running, what config parameters
    are in effect, and more.

    Change-Id: Ib435f9e933009d52841dd8876d425a093731fe7e
    Closes-bug: #1526423

Changed in ironic:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/ironic 9.0.0

This issue was fixed in the openstack/ironic 9.0.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers