[RFE] Generic RAID interface for Ironic

Bug #1526400 reported by Vladyslav Drok on 2015-12-15
4
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ironic
Fix Released
Wishlist
Nisha Agarwal

Bug Description

The proposal presents the work required to create a new driver interface for
RAID configuration. It also proposes a method to make RAID configuration
available as part of zapping.

Tags: rfe Edit Tag help
Vladyslav Drok (vdrok) wrote :

Depends on bug 1526398.

Changed in ironic:
status: New → Confirmed
importance: Undecided → Wishlist
tags: added: rfe
Ruby Loo (rloo) wrote :

Specification has been approved and is available at http://specs.openstack.org/openstack/ironic-specs/specs/approved/ironic-generic-raid-interface.html.

Copying this from the old BP (https://blueprints.launchpad.net/ironic/+spec/ironic-generic-raid-interface):

Spec: http://specs.openstack.org/openstack/ironic-specs/specs/liberty/ironic-generic-raid-interface.html

Spec Review: https://review.openstack.org/#/c/135899/

Gerrit topic: https://review.openstack.org/#q,topic:bp/ironic-generic-raid-interface,n,z

Addressed by: https://review.openstack.org/155230
    Add driver interface for RAID configuration

Bumping to Liberty since this depends on the Zapping state (which has already been bumped)
- Devananda, 13 Mar 2015

Addressed by: https://review.openstack.org/162451
    Refactor method to add or update capability string

Gerrit topic: https://review.openstack.org/#q,topic:(detached,n,z

Addressed by: https://review.openstack.org/196003
    Add RAIDInterface for RAID configuration

Addressed by: https://review.openstack.org/196006
    Add RPCAPIs for RAID configuration

Addressed by: https://review.openstack.org/196007
    Add APIs for RAID configuration

Addressed by: https://review.openstack.org/198238
    Add support for inband raid configuration agent ramdisk

Addressed by: https://review.openstack.org/216946
    Add new method validate_raid_config to RAIDInterface

Addressed by: https://review.openstack.org/221939
    Cache the description of RAID properties

Addressed by: https://review.openstack.org/224356
    Document GET ...raid/logical_disk_properties

Gerrit topic: https://review.openstack.org/#q,topic:raid-schema,n,z

Addressed by: https://review.openstack.org/224299
    Update descriptions in RAID config schema

I believe we just need zapping and docs to call this implemented, right? // jroll 20151015

Changed in ironic:
assignee: nobody → Nisha Agarwal (agarwalnisha1980)
status: Confirmed → In Progress
Dan Yocum (yocum) wrote :

[RFE] - add 'nvme' as an interface_type in addition to 'sata', 'scsi', and 'sas'.

Changed in ironic:
assignee: Nisha Agarwal (agarwalnisha1980) → Vaishnavi (itsvaishnavi)
Changed in ironic:
assignee: Vaishnavi (itsvaishnavi) → Nisha Agarwal (agarwalnisha1980)

Reviewed: https://review.openstack.org/226330
Committed: https://git.openstack.org/cgit/openstack/ironic/commit/?id=139358b396cdaa810c577e7e4f5ef75900fc64a4
Submitter: Jenkins
Branch: master

commit 139358b396cdaa810c577e7e4f5ef75900fc64a4
Author: Nisha Agarwal <email address hidden>
Date: Tue Sep 22 13:54:41 2015 +0000

    Add documentation for RAID

    This commit adds documentation for RAID.

    Closes-bug: 1526400

    Change-Id: I7691c067afa300464c3160f1aa3d3eda64a9aa37

Changed in ironic:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers