[RFE] In-band RAID configuration using IPA

Bug #1526398 reported by Vladyslav Drok on 2015-12-15
4
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ironic
Fix Released
Wishlist
Nisha Agarwal

Bug Description

This change proposes to implement the RAID interface which uses IPA.

Vladyslav Drok (vdrok) on 2015-12-15
Changed in ironic:
status: New → Confirmed
importance: Undecided → Wishlist
tags: added: rfe
Ruby Loo (rloo) wrote :

Spec has been approved and is available at http://specs.openstack.org/openstack/ironic-specs/specs/approved/inband-raid-configuration.html.

Copying this from the old BP (https://blueprints.launchpad.net/ironic/+spec/inband-raid-configuration):

Gerrit topic: https://review.openstack.org/#q,topic:bp/implement-cleaning-states,n,z

Addressed by: https://review.openstack.org/161066
    Add cleaning/zapping support to IPA

----------
Bumping to Liberty since this depends on the Zapping state (which has already been bumped)
- Devananda, 13 Mar 2015

Addressed by: https://review.openstack.org/196960
    Add raid configuration commands in clean extension

Gerrit topic: https://review.openstack.org/#q,topic:bp/ironic-generic-raid-interface,n,z

Addressed by: https://review.openstack.org/198238
    Add support for inband raid configuration agent ramdisk

Addressed by: https://review.openstack.org/222287
    Agent supports post-clean-step operations

Addressed by: https://review.openstack.org/222264
    Refactor deploy_utils methods

Addressed by: https://review.openstack.org/224938
    Agent Inband RAID configuration available in cleaning

Addressed by: https://review.openstack.org/220898
    Add support for in-band cleaning in ISCSIDeploy

Gerrit topic: https://review.openstack.org/#q,topic:(detached,n,z

Addressed by: https://review.openstack.org/235730
    Add self.raid for iSCSI based drivers

Changed in ironic:
status: Confirmed → In Progress
assignee: nobody → Nisha Agarwal (agarwalnisha1980)
tags: added: rfe-approved
removed: rfe
Changed in ironic:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers