IPython - Enhanced Interactive Python

Twisted import warnings

Reported by drewm1980 on 2010-02-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
IPython
Fix Committed
Medium
Brian Granger

Bug Description

Foolscap added a level to it's module hierarchy and is throwing warnings.

Debian Testing as of Feb. 19:
Python 2.5.2 (r252:60911, Jan 24 2010, 17:44:40)
IPython 0.10
twisted.version Version('twisted', 9, 0, 0)

On importing I get the warnings:
____________
from IPython.kernel import client
  ...:

/usr/lib/pymodules/python2.5/IPython/kernel/clientconnector.py:43:
DeprecationWarning: Importing class Tub directly from 'foolscap' is
deprecated since Foolscap 0.4.3. Please import foolscap.api.Tub
instead
 self.tub = Tub()
__________

On instantiation of a task client I get:

____________
In [7]: tc = client.TaskClient()
/usr/lib/pymodules/python2.5/IPython/kernel/taskfc.py:79:
DeprecationWarning: Importing class Referenceable1 directly from
'foolscap' is deprecated since Foolscap 0.4.3. Please import
foolscap.api.Referenceable instead
 class FCTaskControllerFromTaskController(Referenceable):
____________

Something similar for a multiengine client:

______________
In [8]: mec = client.MultiEngineClient()
/usr/lib/pymodules/python2.5/IPython/kernel/multienginefc.py:86:
DeprecationWarning: Importing class Referenceable1 directly from
'foolscap' is deprecated since Foolscap 0.4.3. Please import
foolscap.api.Referenceable instead
 class FCSynchronousMultiEngineFromMultiEngine(Referenceable):
_____________

Download full text (3.4 KiB)

Thanks, I will fix this in trunk.

Brian

On Mon, Feb 22, 2010 at 7:21 AM, drewm1980 <email address hidden> wrote:
> Public bug reported:
>
> Foolscap added a level to it's module hierarchy and is throwing
> warnings.
>
> Debian Testing as of Feb. 19:
> Python 2.5.2 (r252:60911, Jan 24 2010, 17:44:40)
> IPython 0.10
> twisted.version Version('twisted', 9, 0, 0)
>
> On importing I get the warnings:
> ____________
> from IPython.kernel import client
>   ...:
>
> /usr/lib/pymodules/python2.5/IPython/kernel/clientconnector.py:43:
> DeprecationWarning: Importing class Tub directly from 'foolscap' is
> deprecated since Foolscap 0.4.3. Please import foolscap.api.Tub
> instead
>  self.tub = Tub()
> __________
>
> On instantiation of a task client I get:
>
> ____________
> In [7]: tc = client.TaskClient()
> /usr/lib/pymodules/python2.5/IPython/kernel/taskfc.py:79:
> DeprecationWarning: Importing class Referenceable1 directly from
> 'foolscap' is deprecated since Foolscap 0.4.3. Please import
> foolscap.api.Referenceable instead
>  class FCTaskControllerFromTaskController(Referenceable):
> ____________
>
> Something similar for a multiengine client:
>
> ______________
> In [8]: mec = client.MultiEngineClient()
> /usr/lib/pymodules/python2.5/IPython/kernel/multienginefc.py:86:
> DeprecationWarning: Importing class Referenceable1 directly from
> 'foolscap' is deprecated since Foolscap 0.4.3. Please import
> foolscap.api.Referenceable instead
>  class FCSynchronousMultiEngineFromMultiEngine(Referenceable):
> _____________
>
> ** Affects: ipython
>     Importance: Undecided
>         Status: New
>
>
> ** Tags: import twisted warnings
>
> --
> Twisted import warnings
> https://bugs.launchpad.net/bugs/525805
> You received this bug notification because you are a member of IPython
> Developers, which is subscribed to IPython.
>
> Status in IPython - Enhanced Interactive Python: New
>
> Bug description:
> Foolscap added a level to it's module hierarchy and is throwing warnings.
>
> Debian Testing as of Feb. 19:
> Python 2.5.2 (r252:60911, Jan 24 2010, 17:44:40)
> IPython 0.10
> twisted.version Version('twisted', 9, 0, 0)
>
> On importing I get the warnings:
> ____________
> from IPython.kernel import client
>   ...:
>
> /usr/lib/pymodules/python2.5/IPython/kernel/clientconnector.py:43:
> DeprecationWarning: Importing class Tub directly from 'foolscap' is
> deprecated since Foolscap 0.4.3. Please import foolscap.api.Tub
> instead
>  self.tub = Tub()
> __________
>
> On instantiation of a task client I get:
>
> ____________
> In [7]: tc = client.TaskClient()
> /usr/lib/pymodules/python2.5/IPython/kernel/taskfc.py:79:
> DeprecationWarning: Importing class Referenceable1 directly from
> 'foolscap' is deprecated since Foolscap 0.4.3. Please import
> foolscap.api.Referenceable instead
>  class FCTaskControllerFromTaskController(Referenceable):
> ____________
>
> Something similar for a multiengine client:
>
> ______________
> In [8]: mec = client.MultiEngineClient()
> /usr/lib/pymodules/python2.5/IPython/kernel/multienginefc.py:86:
> DeprecationWarning: Importing class Referenceable1 directly from
> 'foolscap' is deprecated since Foolscap 0.4.3. Please import
> fools...

Read more...

Changed in ipython:
assignee: nobody → Brian Granger (ellisonbg)
milestone: none → 0.11
importance: Undecided → Medium
status: New → Fix Committed
drewm1980 (drewm1980) wrote :

Great! How do I pull the change into my working copy? I tried:

awagner@hesse:/home/src/python/ipython/ipython_bzr$ bzr update
Tree is up to date at revision 1228.

awagner@hesse:/home/src/python/ipython/ipython_bzr$ bzr pull
Using saved location: http://bazaar.launchpad.net/~ipython-dev/ipython/trunk/
No revisions to pull.

Thanks,
Drew

I haven't merged this commit into trunk yet. I will do that soon.

Cheers,

Brian

On Mon, Feb 22, 2010 at 3:51 PM, drewm1980 <email address hidden> wrote:
> Great!  How do I pull the change into my working copy?  I tried:
>
> awagner@hesse:/home/src/python/ipython/ipython_bzr$ bzr update
> Tree is up to date at revision 1228.
>
> awagner@hesse:/home/src/python/ipython/ipython_bzr$ bzr pull
> Using saved location: http://bazaar.launchpad.net/~ipython-dev/ipython/trunk/
> No revisions to pull.
>
> Thanks,
> Drew
>
> --
> Twisted import warnings
> https://bugs.launchpad.net/bugs/525805
> You received this bug notification because you are a member of IPython
> Developers, which is subscribed to IPython.
>
> Status in IPython - Enhanced Interactive Python: Fix Committed
>
> Bug description:
> Foolscap added a level to it's module hierarchy and is throwing warnings.
>
> Debian Testing as of Feb. 19:
> Python 2.5.2 (r252:60911, Jan 24 2010, 17:44:40)
> IPython 0.10
> twisted.version Version('twisted', 9, 0, 0)
>
> On importing I get the warnings:
> ____________
> from IPython.kernel import client
>   ...:
>
> /usr/lib/pymodules/python2.5/IPython/kernel/clientconnector.py:43:
> DeprecationWarning: Importing class Tub directly from 'foolscap' is
> deprecated since Foolscap 0.4.3. Please import foolscap.api.Tub
> instead
>  self.tub = Tub()
> __________
>
> On instantiation of a task client I get:
>
> ____________
> In [7]: tc = client.TaskClient()
> /usr/lib/pymodules/python2.5/IPython/kernel/taskfc.py:79:
> DeprecationWarning: Importing class Referenceable1 directly from
> 'foolscap' is deprecated since Foolscap 0.4.3. Please import
> foolscap.api.Referenceable instead
>  class FCTaskControllerFromTaskController(Referenceable):
> ____________
>
> Something similar for a multiengine client:
>
> ______________
> In [8]: mec = client.MultiEngineClient()
> /usr/lib/pymodules/python2.5/IPython/kernel/multienginefc.py:86:
> DeprecationWarning: Importing class Referenceable1 directly from
> 'foolscap' is deprecated since Foolscap 0.4.3. Please import
> foolscap.api.Referenceable instead
>  class FCSynchronousMultiEngineFromMultiEngine(Referenceable):
> _____________
>
>
>

--
Brian E. Granger, Ph.D.
Assistant Professor of Physics
Cal Poly State University, San Luis Obispo
<email address hidden>
<email address hidden>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers