IPython - Enhanced Interactive Python

Update version requirement to 2.5

Reported by Fernando Perez on 2010-01-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
IPython
Fix Committed
Critical
Fernando Perez

Bug Description

We are now using context managers in multiple places, so 2.5 is a requirement. We'd discussed dropping 2.4 compatibility for 0.11 a while ago, the main __init__ needs updating.

Fernando Perez (fdo.perez) wrote :

Fixed in my trunk-dev.

Changed in ipython:
status: In Progress → Fix Committed
Fernando Perez (fdo.perez) wrote :

Add the version check to setup.py so we warn 2.4 users in a more civilized way that it won't even install.

Changed in ipython:
status: Fix Committed → In Progress
importance: High → Critical
Fernando Perez (fdo.perez) wrote :

Fix in my trunk-dev branch

Changed in ipython:
status: In Progress → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers