readline, and completion do not work properly on zope extension

Bug #443972 reported by kiorky
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
IPython
Fix Committed
Low
Brian Granger

Bug Description

zope munge the stdin, so it breaks ipython completion and readline stuff.
I have made a branch to include the very straightforward fix.

Revision history for this message
kiorky (kiorky) wrote :
Changed in ipython:
status: New → Confirmed
status: Confirmed → Won't Fix
assignee: nobody → Brian Granger (ellisonbg)
Revision history for this message
kiorky (kiorky) wrote :

Just release the patch for 0.9 and 0.10 as you said, it works also on those branches.

Changed in ipython:
status: Won't Fix → New
Revision history for this message
Brian Granger (ellisonbg) wrote : Re: [Bug 443972] Re: readline, and completion do not work properly on zope extension

OK, we will do this then. I don't have time to do this today, so can you
simply make sure the ticket is clear about what the status of this is and
that the branch is ready to be merged to 0.10?

Thanks

Brian

On Thu, Oct 15, 2009 at 12:26 AM, kiorky <email address hidden> wrote:

> Just release the patch for 0.9 and 0.10 as you said, it works also on
> those branches.
>
> ** Changed in: ipython
> Status: Won't Fix => New
>
> --
> readline, and completion do not work properly on zope extension
> https://bugs.launchpad.net/bugs/443972
> You received this bug notification because you are a member of IPython
> Developers, which is subscribed to IPython.
>
> Status in IPython - Enhanced Interactive Python: New
>
> Bug description:
> zope munge the stdin, so it breaks ipython completion and readline stuff.
> I have made a branch to include the very straightforward fix.
>

--
Brian E. Granger, Ph.D.
Assistant Professor of Physics
Cal Poly State University, San Luis Obispo
<email address hidden>
<email address hidden>

Revision history for this message
Brian Granger (ellisonbg) wrote :

Please use launchpad to propose your branch for merging into the ipython/0.10 branch.

Changed in ipython:
status: New → In Progress
importance: Undecided → Low
Revision history for this message
Fernando Perez (fdo.perez) wrote :

I've pushed the fix (with a tiny modification to avoid directly writing into sys for storage of the variable) to 0.10.1 and trunk. In trunk the extension is on deathrow, but at least this way trunk is up to date and we won't have regressions when it gets updated.

Changed in ipython:
status: In Progress → Fix Committed
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers