IPython - Enhanced Interactive Python

Remove debian/ directory from bzr repository

Reported by Stephan Peijnik on 2009-04-28
2
Affects Status Importance Assigned to Milestone
IPython
Fix Released
Critical
Fernando Perez
0.10
Fix Released
Critical
Fernando Perez

Bug Description

I just branched ipython from launchpad and noticed the repository contains a debian/ directory.

Whilst the release tarballs do not contain that directory and are perfectly fine shipping the directory in the repository makes packaging development versions of ipython more complicated.

Seeing that the debian/ directory is way outdated anyways, do you think it would be possible to remove this directory from the bzr repository altogether?

-- Stephan

I am fine with this, but I don't run debian. Is this OK with all the
debian folks? If it is, I will remove the directory for the upcoming
0.10 release.

Brian

On Tue, Apr 28, 2009 at 10:09 AM, Stephan Peijnik <email address hidden> wrote:
> Public bug reported:
>
> I just branched ipython from launchpad and noticed the repository
> contains a debian/ directory.
>
> Whilst the release tarballs do not contain that directory and are
> perfectly fine shipping the directory in the repository makes packaging
> development versions of ipython more complicated.
>
> Seeing that the debian/ directory is way outdated anyways, do you think
> it would be possible to remove this directory from the bzr repository
> altogether?
>
> -- Stephan
>
> ** Affects: ipython
>     Importance: Undecided
>         Status: New
>
> --
> Remove debian/ directory from bzr repository
> https://bugs.launchpad.net/bugs/368719
> You received this bug notification because you are a member of IPython
> Developers, which is subscribed to IPython.
>
> Status in IPython - Enhanced Interactive Python: New
>
> Bug description:
> I just branched ipython from launchpad and noticed the repository contains a debian/ directory.
>
> Whilst the release tarballs do not contain that directory and are perfectly fine shipping the directory in the repository makes packaging development versions of ipython more complicated.
>
> Seeing that the debian/ directory is way outdated anyways, do you think it would be possible to remove this directory from the bzr repository altogether?
>
> -- Stephan
>

--
Brian E. Granger, Ph.D.
Assistant Professor of Physics
Cal Poly State University, San Luis Obispo
<email address hidden>
<email address hidden>

Changed in ipython:
assignee: nobody → ellisonbg
importance: Undecided → Critical
milestone: none → 0.10
status: New → Confirmed
Ville M. Vainio (villemvainio) wrote :

On Tue, Apr 28, 2009 at 8:09 PM, Stephan Peijnik <email address hidden> wrote:

> Seeing that the debian/ directory is way outdated anyways, do you think
> it would be possible to remove this directory from the bzr repository
> altogether?
>
> -- Stephan

Would updating the directory to match the current status do the trick?
It can be helpful for people who quickly like to roll out customized
packages to have the source right there.

--
Ville M. Vainio
http://tinyurl.com/vainio

Ville M. Vainio (villemvainio) wrote :

After doing some debian packaging myself, I second the request to do this. The current debian/ folder can be moved to a new branch under ipython project in launchpad.

Fernando Perez (fdo.perez) wrote :

I'll take care of this.

Question: is it OK if we just move the top-level debian/ dir under sandbox/ for 0.10? That way if anything useful was in there, it will make it easier to find later.

We'll try to engage the debian packagers better so that we can offer as-good-as-possible support out of the box, in the 0.11 cycle.

Changed in ipython:
assignee: Brian Granger (ellisonbg) → Fernando Perez (fdo.perez)
status: Confirmed → In Progress
Fernando Perez (fdo.perez) wrote :

In fact, now that I'm looking at your debian dir in:

http://svn.debian.org/viewsvn/python-modules/packages/ipython/trunk/debian/

Should we use that instead? We could then close both the manpages bug and this one in one shot...

How does that sound? I'll certainly include the manpages you offer, but I'd like to provide as good as possible debian support from our part.

Fernando Perez (fdo.perez) wrote :

Updating fields from parent bug

Stephan Peijnik (speijnik) wrote :

Moving the debian directory to a subdirectory (anything but <root>/debian) is fine with me.

If you do not intend to build Debian packages yourself you don't have to include anything. svn-buildpackage takes care of "merging" your tarball and the debian/ directory that exists on svn.debian.org automatically.

As far as the manpages are concerned I believe it would be good to include them not only in the debian/ directory but rather somewhere else, so all your targeted distributions benefit from those.

-- Stephan

Personally, I would rather not carry around distribution specific things in
the ipython source tree. Those things should stay with the distributions
themselves. The man pages on the other hand, should go into ipython's
source tree for all dists to take advantage of.

> Moving the debian directory to a subdirectory (anything but
> <root>/debian) is fine with me.
>

> If you do not intend to build Debian packages yourself you don't have to
> include anything. svn-buildpackage takes care of "merging" your tarball
> and the debian/ directory that exists on svn.debian.org automatically.
>

Then lets *not* include this anywhere in IPython.

> As far as the manpages are concerned I believe it would be good to
> include them not only in the debian/ directory but rather somewhere
> else, so all your targeted distributions benefit from those.
>

+1

Cheers,

Brian

>
> -- Stephan
>
> --
> Remove debian/ directory from bzr repository
> https://bugs.launchpad.net/bugs/368719
> You received this bug notification because you are a member of IPython
> Developers, which is subscribed to IPython.
>
> Status in IPython - Enhanced Interactive Python: In Progress
> Status in IPython 0.10 series: In Progress
>
> Bug description:
> I just branched ipython from launchpad and noticed the repository contains
> a debian/ directory.
>
> Whilst the release tarballs do not contain that directory and are perfectly
> fine shipping the directory in the repository makes packaging development
> versions of ipython more complicated.
>
> Seeing that the debian/ directory is way outdated anyways, do you think it
> would be possible to remove this directory from the bzr repository
> altogether?
>
> -- Stephan
>

--
Brian E. Granger, Ph.D.
Assistant Professor of Physics
Cal Poly State University, San Luis Obispo
<email address hidden>
<email address hidden>

Fernando Perez (fdo.perez) wrote :

Based on this discussion, I will then:

- update our manpages with those provided by upstream debian as given above.

- nuke the current top-level debian/ directory altogether.

Thanks!

f

Fernando Perez (fdo.perez) wrote :

Fix committed in my dev branch:

https://code.launchpad.net/~fdo.perez/ipython/trunk-dev

I simply nuked the directory, this one should be uncontroversial. Once we merge this we'll close both debian bugs.

Fernando Perez (fdo.perez) wrote :

Committed and pushed to trunk, will be in 0.10 final.

Changed in ipython:
status: In Progress → Fix Committed
Changed in ipython:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers