Exception color scheme not used in files read at startup

Bug #295798 reported by Fernando Perez on 2008-11-09
2
Affects Status Importance Assigned to Milestone
IPython
Fix Released
Undecided
Fernando Perez

Bug Description

When a script is run via

ipython foo.py

if it has errors, those are reported using colors regardless of the user's scheme choice.

Fernando Perez (fdo.perez) wrote :

Bug reported at Sage Days 11, work in progress. The problem is a stateful interface in excolors.py.

Changed in ipython:
assignee: nobody → fdo.perez
Fernando Perez (fdo.perez) wrote :

Fix committed in my branch, waiting review for merge into trunk.

Changed in ipython:
status: New → Fix Committed
Changed in ipython:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers