IPython - Enhanced Interactive Python

Manual pages for executables shipping with 0.9.1

Reported by Stephan Peijnik on 2008-10-30
2
Affects Status Importance Assigned to Milestone
IPython
Fix Released
Critical
Fernando Perez
0.10
Fix Released
Critical
Fernando Perez

Bug Description

It seems as if the 0.9.1 tarball is missing some manual pages. As I am packaging IPython 0.9.1 for Debian right now I wrote some manual pages for ipcontroller, ipcluster, ipengine, ipythonx and ipython-wx. These manual pages only include basic information and most of them only resemble the output of <command> --help.

However, I wanted to let you know that those exist and I would be happy if you could include them in the next release of IPython.

All manual pages can be found (together with other Debian packaging-related files) at http://svn.debian.org/viewsvn/python-modules/packages/ipython/trunk/debian/. Feel free to use them, comment on them and provide enhancements and fixes.

Changed in ipython:
importance: Undecided → Critical
milestone: none → 0.10
status: New → Confirmed
Changed in ipython:
assignee: nobody → Fernando Perez (fdo.perez)
status: Confirmed → In Progress
Fernando Perez (fdo.perez) wrote :

God, I hate that when you target a bug to a release, it doesn't inherit its already existing properties...

I'll take care of this one.

I have noticed that when you file features requests/bugs for lauchpad
itself, they are pretty responsive.

Brian

On Wed, Jul 29, 2009 at 11:03 AM, Fernando Perez <email address hidden>wrote:

> God, I hate that when you target a bug to a release, it doesn't inherit
> its already existing properties...
>
> I'll take care of this one.
>
> ** Also affects: ipython/0.10
> Importance: Undecided
> Status: New
>
> ** Changed in: ipython/0.10
> Importance: Undecided => Critical
>
> ** Changed in: ipython/0.10
> Status: New => In Progress
>
> ** Changed in: ipython/0.10
> Milestone: None => 0.10
>
> ** Changed in: ipython/0.10
> Assignee: (unassigned) => Fernando Perez (fdo.perez)
>
> --
> Manual pages for executables shipping with 0.9.1
> https://bugs.launchpad.net/bugs/291143
> You received this bug notification because you are a member of IPython
> Developers, which is subscribed to IPython.
>
> Status in IPython - Enhanced Interactive Python: In Progress
> Status in IPython 0.10 series: In Progress
>
> Bug description:
> It seems as if the 0.9.1 tarball is missing some manual pages. As I am
> packaging IPython 0.9.1 for Debian right now I wrote some manual pages for
> ipcontroller, ipcluster, ipengine, ipythonx and ipython-wx. These manual
> pages only include basic information and most of them only resemble the
> output of <command> --help.
>
> However, I wanted to let you know that those exist and I would be happy if
> you could include them in the next release of IPython.
>
> All manual pages can be found (together with other Debian packaging-related
> files) at
> http://svn.debian.org/viewsvn/python-modules/packages/ipython/trunk/debian/.
> Feel free to use them, comment on them and provide enhancements and fixes.
>

--
Brian E. Granger, Ph.D.
Assistant Professor of Physics
Cal Poly State University, San Luis Obispo
<email address hidden>
<email address hidden>

Fernando Perez (fdo.perez) wrote :

On Wed, Jul 29, 2009 at 11:21 AM, Brian Granger<email address hidden> wrote:
> I have noticed that when you file features requests/bugs for lauchpad
> itself, they are pretty responsive.

Good point. It's not worth complaining without reporting :)

This is now: https://bugs.launchpad.net/launchpad/+bug/407186

Fernando Perez (fdo.perez) wrote :

Fix committed in my dev branch:

https://code.launchpad.net/~fdo.perez/ipython/trunk-dev

Unless we spot any problems here, I'll go ahead and merge this into trunk/0.10 for release. I'd appreciate a quick eye over the changes, they are minimal.

Fernando Perez (fdo.perez) wrote :

Committed and pushed to trunk, will be in 0.10 final.

Changed in ipython:
status: In Progress → Fix Committed
Changed in ipython:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers