iPod Convenience: A suite of scripts for 7th Generation iPods

When running iphone-mount, i get ssh: : Name or service not known

Reported by Nic on 2008-03-03
4
Affects Status Importance Assigned to Milestone
iPod Convenience
Undecided
Unassigned

Bug Description

After the latest update, I get ssh: : Name or service not known when running iphone-mount

Nic (ntetreau) wrote :

Sorry click too quickly. ssh root@IP still works manually. iphone-mount just gives me "ssh: : Name or service not known" and then hangs.

Hi,

What version are you using? (dpkg -l)

Thanks
On Mon, Mar 3, 2008 at 3:25 PM, Nic <email address hidden> wrote:

> Sorry click too quickly. ssh root@IP still works manually. iphone-
> mount just gives me "ssh: : Name or service not known" and then hangs.
>
> --
> When running iphone-mount, i get ssh: : Name or service not known
> https://bugs.launchpad.net/bugs/198139
> You received this bug notification because you are subscribed to iPod
> Convenience.
>

--
Mario Limonciello
<email address hidden>

Nic (ntetreau) wrote :

I am running 0.7-0ubuntu1 on Hardy. Thanks.

Nic (ntetreau) wrote :

I can confirm that downgrading to 0.5 fixes this problem.

Nic (ntetreau) wrote :

In iphone-mount, changing:

    #Mount our Music Directory
    #work around if its 1.1.3+
    if ssh root@192.168.6.136 test -d /var/mobile; then
        sshfs root@$IPADDRESS:/var/mobile/Media $MOUNTPOINT/ -o workaround=rename
    else
        sshfs root@$IPADDRESS:/var/root/Media $MOUNTPOINT/ -o workaround=rename
    fi

to
    #Mount our Music Directory
    #work around if its 1.1.3+
    if ssh root@$IPADDRESS test -d /var/mobile; then
        sshfs root@$IPADDRESS:/var/mobile/Media $MOUNTPOINT/ -o workaround=rename
    else
        sshfs root@$IPADDRESS:/var/root/Media $MOUNTPOINT/ -o workaround=rename
    fi

fixes the mount issue for me, although I still get the "ssh: : Name or service not known" message

appleseed (capello-andrea) wrote :

>appleseed@appleseed-desktop:~$ ipod-touch-mount
ssh: : Name or service not known
root@192.168.1.40's password:
root@192.168.1.40's password:
root@192.168.1.40:/var/mobile/Media: No such file or directory
appleseed@appleseed-desktop:~$

i have many troubles running 0.7-0ubuntu1 (on gutsy).
i changed the "mount music directory" as nic suggested but the ipod doesn't mount anymore.
also it asks me for the pwd twice (as you can see just above).

how can i downgrade my ipod convenience to 0.5 version?

thanks guys!

Nic (ntetreau) wrote :

@ appleseed, be careful you are changing just the root@192.168.6.136 for root@$IPADDRESS in version 0.7, there is no need to change the music directory.

I'm attaching version 0.5 to this bug report

appleseed (capello-andrea) wrote :

thank you Nic, i'm going to downgrade it!

2008/3/6, Nic <email address hidden>:
>
> @ appleseed, be careful you are changing just the root@192.168.6.136 for
> root@$IPADDRESS in version 0.7, there is no need to change the music
> directory.
>
> I'm attaching version 0.5 to this bug report
>
> ** Attachment added: "ipod-convenience_0.5-0ubuntu1~ppa3_all.deb"
>
> http://launchpadlibrarian.net/12458162/ipod-convenience_0.5-0ubuntu1%7Eppa3_all.deb
>
>
> --
> When running iphone-mount, i get ssh: : Name or service not known
> https://bugs.launchpad.net/bugs/198139
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Mario Limonciello (superm1) wrote :

Fixed in 0.9

Changed in ipod-convenience:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers