Remove old rpc alias(es) from code

Bug #1424728 reported by Davanum Srinivas (DIMS) on 2015-02-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cinder
Undecided
ChangBo Guo(gcb)
CloudPulse
Undecided
zhangyangyang
Designate
Undecided
Hieu LE
IoTronic
Undecided
Kiran Totad
Ironic
Fix Released
Undecided
ChangBo Guo(gcb)
Magnum
Fix Released
Undecided
ChangBo Guo(gcb)
OpenStack Compute (nova)
Low
ChangBo Guo(gcb)
OpenStack Searchlight
Fix Released
Undecided
iswarya vakati
OpenStack Shared File Systems Service (Manila)
Undecided
ChangBo Guo(gcb)
Sahara
Fix Released
Undecided
ChangBo Guo(gcb)
grenade
Undecided
kavitha h r
keystonemiddleware
Undecided
Thomas Bechtold
neutron
Low
Ihar Hrachyshka
oslo.messaging
Low
Steve Kowalik
watcher
Undecided
iswarya vakati

Bug Description

We have several TRANSPORT_ALIASES entries from way back (Essex, Havana)
http://git.openstack.org/cgit/openstack/nova/tree/nova/rpc.py#n48

We need a way to warn end users that they need to fix their nova.conf So these can be removed in a later release (full cycle?)

fyi, Grenade fails if we just rip it out as well https://review.openstack.org/#/c/158169/

Mehdi Abaakouk (sileht) wrote :

Deprecating anything related to the oslo.messaging aliases should be sufficient, when all projects have migrated we can remove the aliases feature of oslo.messaging that leaves only for backward compatibility.

Grenade have to be updated to change the rpc_backend to use new option during the migration path, I guess

   iniset_rpc_backend nova $NOVA_CONF DEFAULT

should be added before: http://git.openstack.org/cgit/openstack-dev/grenade/tree/upgrade-nova#n107

Changed in nova:
importance: Undecided → Low
status: New → Confirmed
Mehdi Abaakouk (sileht) on 2015-02-27
Changed in oslo.messaging:
importance: Undecided → Low
status: New → Confirmed

Reviewed: https://review.openstack.org/180434
Committed: https://git.openstack.org/cgit/openstack/oslo.messaging/commit/?id=4d0f7ab652416af78e1e23d62235e868c4d1e57a
Submitter: Jenkins
Branch: master

commit 4d0f7ab652416af78e1e23d62235e868c4d1e57a
Author: Mehdi Abaakouk <email address hidden>
Date: Wed May 6 09:55:23 2015 +0200

    deprecate usage of transport aliases

    This change starts the deprecation process for the transport aliases.

    The first step is deprecate this one cycle. To ensure deployer have
    updated they configuration during Newton Then in Octacia we will deprecate
    'aliases' kwargs of transportURL() and get_transport() for consuming
    application.

    Related-bug: #1424728

    Change-Id: I314cefa5fb1803fa7e21e3e34300e5ced31bba89

Download full text (6.9 KiB)

Reviewed: https://review.openstack.org/325916
Committed: https://git.openstack.org/cgit/openstack/oslo.messaging/commit/?id=1c7ff9d60ae82bc3016503c7eb3bcdc0e228fcfc
Submitter: Jenkins
Branch: feature/amqp-dispatch-router

commit 2668177256e2c09f2db69d026655e94045c20e5f
Author: Edan David <email address hidden>
Date: Thu Jun 2 01:42:01 2016 -0400

    Fix typo: 'olso' to 'oslo'

    Change-Id: Ic86ded995ecf24b094b25c140da264526eafe611

commit a620319af4583925f02b4b14d3c5106b85726dad
Author: OpenStack Proposal Bot <email address hidden>
Date: Thu Jun 2 04:08:22 2016 +0000

    Updated from global requirements

    Change-Id: Idb293b41afef83871ebfdb451f7f6a079ce10711

commit 31691745d43be5ea74772a8a2e4072616fdf0814
Author: ozamiatin <email address hidden>
Date: Mon May 16 15:43:27 2016 +0300

    [zmq] Don't skip non-direct message types

    If using the router proxy we need to be able to
    dispatch all types of messages over the routers,
    not limiting them to direct types only.

    Also added fanout possibility to do on a client-side,
    so we can reduce latency on a proxy, and not using
    pub-sub for fanout when we don't want it.

    Change-Id: Ic88c306c1d386dd582cbccfc5719fba5668a9db8

commit 8ee19159d2aa00e175bbdadac7d0d52627334cb5
Author: ozamiatin <email address hidden>
Date: Mon May 16 17:07:30 2016 +0300

    [zmq] Refactoring of zmq client

    Split ZmqClient in order to create different clients
    for different configurations (direct/proxy).

    Change-Id: Ib374f62f53f2c82278ce5bc555ea440e8eba6617

commit 4b0e247d2d9d1c8eb5b9f904dd632bda9c706670
Author: OpenStack Proposal Bot <email address hidden>
Date: Tue May 31 03:05:21 2016 +0000

    Updated from global requirements

    Change-Id: I5e48d3f427128c6beebdd04ec9dbfc96683cee9e

commit 9d51fa4a2fa734e347be1998f5fd2b1e35dbc0a4
Author: Andrew Smith <email address hidden>
Date: Thu May 26 11:54:29 2016 -0400

    [AMQP 1.0] Randomize host list connection attempts

    Randomize the initial selection of the host list for amqp 1.0 connection
    attempts.

    This patch:
    * randomizes initial index
    * updates failover unit tests

    Change-Id: Iab5ae684a2cd8ec0c6d0c59ffffde5eb5baf883b

commit 5fb8f269e7c03fe8252cf09dccb88ad64cc43e88
Author: JiaJunsu <email address hidden>
Date: Mon May 16 06:03:07 2016 -0700

    Modify the TransportURL's docstrings

    To match the test_urls.TestParseURL multi_creds

    Change-Id: I4a37b7bce3703aa581bc46d41690bf7978f813a6
    Close-Bug: #1529310

commit 9ccfbdd3c3b19419c370b041c0f39be6b70b622d
Author: Gevorg Davoian <email address hidden>
Date: Tue May 24 12:32:11 2016 +0300

    Fix problems after refactoring RPC client

    The patch fixes some problems arised after merging the previous
    patch which this patch depends on.

    Change-Id: If38edec19f9bffc8ac54818b2536243a9edaf7e8
    Depends-On: I608c828123b196099933d16801f8ce7d9dd3a079
    Closes-Bug: #1584889

commit 4d0f7ab652416af78e1e23d62235e868c4d1e57a
Author: Mehdi Abaakouk <email address hidden>
Date: Wed May 6 09:55:23 2015 +0200

    deprecate usage ...

Read more...

tags: added: in-feature-amqp-dispatch-router
tags: added: deprecation oslo
Changed in neutron:
importance: Undecided → Low
assignee: nobody → Ihar Hrachyshka (ihar-hrachyshka)
status: New → Confirmed

Related fix proposed to branch: master
Review: https://review.openstack.org/380328

Changed in neutron:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/380328
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=8ad62fe75188e934549047b7fd0ab5fd31194842
Submitter: Jenkins
Branch: master

commit 8ad62fe75188e934549047b7fd0ab5fd31194842
Author: Ihar Hrachyshka <email address hidden>
Date: Sun Sep 25 01:29:40 2016 +0000

    Remove old oslo.messaging transport aliases

    Those are remnants from the oslo-incubator times. Also, oslo.messaging
    deprecated [1] transport aliases since 5.2.0+ that is the minimal
    version supported for stable/newton. The patch that bumped the minimal
    version for Neutron landed 3 months+ ago, so we can proceed ripping
    those aliases from the code base.

    [1] I314cefa5fb1803fa7e21e3e34300e5ced31bba89

    Change-Id: I9e66140ad0b10c50e216c78e4914c98313cada05
    Closes-Bug: #1424728

Changed in neutron:
status: In Progress → Fix Released

This issue was fixed in the openstack/neutron 10.0.0.0b1 development milestone.

Fix proposed to branch: master
Review: https://review.openstack.org/446990

Changed in nova:
assignee: nobody → ChangBo Guo(gcb) (glongwave)
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/446990
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=05c50f2479533966c3b885f033d09f3e717595c7
Submitter: Jenkins
Branch: master

commit 05c50f2479533966c3b885f033d09f3e717595c7
Author: ChangBo Guo(gcb) <email address hidden>
Date: Fri Mar 17 20:41:16 2017 +0800

    Remove old oslo.messaging transport aliases

    Those are remnants from the oslo-incubator times. Also, oslo.messaging
    deprecated [1] transport aliases since 5.2.0+ that is the minimal
    version supported for stable/newton. The patch that bumped the minimal
    version for Nova landed 3 months+ ago, so we can proceed ripping
    those aliases from the code base.

    [1] I314cefa5fb1803fa7e21e3e34300e5ced31bba89

    Change-Id: Id8c0bc6733e930803b8e9fcf42a9a1f81dcbb356
    Closes-Bug: #1424728

Changed in nova:
status: In Progress → Fix Released

Fix proposed to branch: master
Review: https://review.openstack.org/447286

Changed in magnum:
assignee: nobody → ChangBo Guo(gcb) (glongwave)
status: New → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/447289

Changed in cinder:
assignee: nobody → ChangBo Guo(gcb) (glongwave)
status: New → In Progress
Changed in designate:
assignee: nobody → ChangBo Guo(gcb) (glongwave)
status: New → In Progress
summary: - Remove old rpc alias(es) from nova.conf and code
+ Remove old rpc alias(es) from code

Fix proposed to branch: master
Review: https://review.openstack.org/447293

Changed in manila:
assignee: nobody → ChangBo Guo(gcb) (glongwave)
status: New → In Progress
Changed in heat:
assignee: nobody → ChangBo Guo(gcb) (glongwave)
status: New → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/447294

Changed in ironic:
assignee: nobody → ChangBo Guo(gcb) (glongwave)
status: New → In Progress
no longer affects: trove

Reviewed: https://review.openstack.org/447294
Committed: https://git.openstack.org/cgit/openstack/heat/commit/?id=1cc699f769d5738efd30c7fd8ca20527e48a03ef
Submitter: Jenkins
Branch: master

commit 1cc699f769d5738efd30c7fd8ca20527e48a03ef
Author: ChangBo Guo(gcb) <email address hidden>
Date: Sun Mar 19 21:00:57 2017 +0800

    Remove old oslo.messaging transport aliases

    Those are remnants from the oslo-incubator times. Also, oslo.messaging
    deprecated [1] transport aliases since 5.2.0+ that is the minimal
    version supported for stable/newton. The patch that bumped the minimal
    version for Heat landed 3 months+ ago, so we can proceed ripping
    those aliases from the code base.

    [1] I314cefa5fb1803fa7e21e3e34300e5ced31bba89

    Change-Id: I55b9b0b1687415861175c670fbf7f893e50f3199
    Closes-Bug: #1424728

Changed in heat:
status: In Progress → Fix Released
ChangBo Guo(gcb) (glongwave) wrote :
Changed in sahara:
assignee: nobody → ChangBo Guo(gcb) (glongwave)
status: New → In Progress
Changed in searchlight:
assignee: nobody → iswarya vakati (v-iswarya)
Changed in grenade:
assignee: nobody → iswarya vakati (v-iswarya)
Changed in watcher:
assignee: nobody → iswarya vakati (v-iswarya)

Reviewed: https://review.openstack.org/447293
Committed: https://git.openstack.org/cgit/openstack/manila/commit/?id=201f99f778510f6397bd6f341f8e88d4fcf829b2
Submitter: Jenkins
Branch: master

commit 201f99f778510f6397bd6f341f8e88d4fcf829b2
Author: ChangBo Guo(gcb) <email address hidden>
Date: Sun Mar 19 21:14:00 2017 +0800

    Remove old oslo.messaging transport aliases

    Those are remnants from the oslo-incubator times. Also, oslo.messaging
    deprecated [1] transport aliases since 5.2.0+ that is the minimal
    version supported for stable/newton. The patch that bumped the minimal
    version for Manila landed 3 months+ ago, so we can proceed ripping
    those aliases from the code base.

    [1] I314cefa5fb1803fa7e21e3e34300e5ced31bba89

    Change-Id: Iea406d784bcef5c4c50e11a49cd967d0143d1d62
    Closes-Bug: #1424728

Changed in manila:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/447295
Committed: https://git.openstack.org/cgit/openstack/ironic/commit/?id=330ba8c502880a16db4d2673ab36358f559711ec
Submitter: Jenkins
Branch: master

commit 330ba8c502880a16db4d2673ab36358f559711ec
Author: ChangBo Guo(gcb) <email address hidden>
Date: Sun Mar 19 21:16:53 2017 +0800

    Remove old oslo.messaging transport aliases

    Those are remnants from the oslo-incubator times. Also, oslo.messaging
    deprecated [1] transport aliases since 5.2.0+ that is the minimal
    version supported for stable/newton. The patch that bumped the minimal
    version for Ironic landed 3 months+ ago, so we can proceed ripping
    those aliases from the code base.

    [1] I314cefa5fb1803fa7e21e3e34300e5ced31bba89

    Change-Id: I42dcc4b64f0b8e667abad68f7a5ed1ba004ec329
    Closes-Bug: #1424728

Changed in ironic:
status: In Progress → Fix Released
Thomas Herve (therve) on 2017-03-20
no longer affects: heat

Reviewed: https://review.openstack.org/447288
Committed: https://git.openstack.org/cgit/openstack/sahara/commit/?id=c5b3f826516d16f8f01105f804cd8f2bd9de51cc
Submitter: Jenkins
Branch: master

commit c5b3f826516d16f8f01105f804cd8f2bd9de51cc
Author: ChangBo Guo(gcb) <email address hidden>
Date: Sun Mar 19 20:47:33 2017 +0800

    Remove old oslo.messaging transport aliases

    Those are remnants from the oslo-incubator times. Also, oslo.messaging
    deprecated [1] transport aliases since 5.2.0+ that is the minimal
    version supported for stable/newton. The patch that bumped the minimal
    version for Sahara landed 3 months+ ago, so we can proceed ripping
    those aliases from the code base.

    [1] I314cefa5fb1803fa7e21e3e34300e5ced31bba89

    Closes-Bug: #1424728

    Change-Id: I02fbe5f4f9f3bda80f4fc1ea94f852e1969ce1aa

Changed in sahara:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/447369
Committed: https://git.openstack.org/cgit/openstack/watcher/commit/?id=1386ce690f3a76922c40c1f00e5a90e709c8f8e7
Submitter: Jenkins
Branch: master

commit 1386ce690f3a76922c40c1f00e5a90e709c8f8e7
Author: ChangBo Guo(gcb) <email address hidden>
Date: Mon Mar 20 13:23:45 2017 +0800

    Remove old oslo.messaging transport aliases

    Those are remnants from the oslo-incubator times. Also, oslo.messaging
    deprecated [1] transport aliases since 5.2.0+ that is the minimal
    version supported for stable/newton. The patch that bumped the minimal
    version for Watcher landed 3 months+ ago, so we can proceed ripping
    those aliases from the code base.

    [1] I314cefa5fb1803fa7e21e3e34300e5ced31bba89

    Change-Id: Ie3008cc54b0eb3d1d02f55f388bd1c3b109d126d
    Closes-Bug: #1424728

Changed in watcher:
status: New → Fix Released

Reviewed: https://review.openstack.org/447371
Committed: https://git.openstack.org/cgit/openstack/searchlight/commit/?id=a0ca06a4df8129ac7e2e25226fca60f9eda2b3c5
Submitter: Jenkins
Branch: master

commit a0ca06a4df8129ac7e2e25226fca60f9eda2b3c5
Author: ChangBo Guo(gcb) <email address hidden>
Date: Mon Mar 20 13:28:03 2017 +0800

    Remove old oslo.messaging transport aliases

    Those are remnants from the oslo-incubator times. Also, oslo.messaging
    deprecated [1] transport aliases since 5.2.0+ that is the minimal
    version supported for stable/newton. The patch that bumped the minimal
    version for Searchlight landed 3 months+ ago, so we can proceed ripping
    those aliases from the code base.

    [1] I314cefa5fb1803fa7e21e3e34300e5ced31bba89

    Closes-Bug: #1424728

    Change-Id: Ia270d486d0a85354df30f7e5731d4c09a3ef3727

Changed in searchlight:
status: New → Fix Released
Changed in grenade:
assignee: iswarya vakati (v-iswarya) → nobody

Reviewed: https://review.openstack.org/447289
Committed: https://git.openstack.org/cgit/openstack/cinder/commit/?id=f8c875cda0a9a48e9a1cec92224a1453d50233aa
Submitter: Jenkins
Branch: master

commit f8c875cda0a9a48e9a1cec92224a1453d50233aa
Author: ChangBo Guo(gcb) <email address hidden>
Date: Sun Mar 19 20:51:44 2017 +0800

    Remove old oslo.messaging transport aliases

    Those are remnants from the oslo-incubator times. Also, oslo.messaging
    deprecated [1] transport aliases since 5.2.0+ that is the minimal
    version supported for stable/newton. The patch that bumped the minimal
    version for Cinder landed 3 months+ ago, so we can proceed ripping
    those aliases from the code base.

    [1] I314cefa5fb1803fa7e21e3e34300e5ced31bba89

    Closes-Bug: #1424728
    Change-Id: Ibaab1c9132bea25abdf6dfbad2550ba572d5cf1d

Changed in cinder:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/447376
Committed: https://git.openstack.org/cgit/openstack/oslo.messaging/commit/?id=5a7dcadc94ed4165cfc3c4f7e59e61c6ec5478bc
Submitter: Jenkins
Branch: master

commit 5a7dcadc94ed4165cfc3c4f7e59e61c6ec5478bc
Author: ChangBo Guo(gcb) <email address hidden>
Date: Mon Mar 20 13:52:19 2017 +0800

    Deprecate parameter aliases

    oslo.messaging deprecated transport aliases[1] since 5.2.0+
    that is the minimal version supported for stable/newton.
    This commit deprecates aliases kwargs of TransportURL() and
    get_transport(), then we can remove the parameter aliases
    in the future version.

    Related-Bug: #1424728

    [1]I314cefa5fb1803fa7e21e3e34300e5ced31bba89

    Change-Id: I0c96979dacd9eb05b4215c687b5e34e7b3475ddb

Thomas Bechtold (toabctl) wrote :

For keystonemiddleware, the changeset is https://review.openstack.org/#/c/453245/

Changed in keystonemiddleware:
assignee: nobody → Thomas Bechtold (toabctl)
status: New → In Progress

This issue was fixed in the openstack/ironic 8.0.0 release.

Reviewed: https://review.openstack.org/453245
Committed: https://git.openstack.org/cgit/openstack/keystonemiddleware/commit/?id=d94c40b1e0515117fbe7d04480640641f2a2edbd
Submitter: Jenkins
Branch: master

commit d94c40b1e0515117fbe7d04480640641f2a2edbd
Author: Thomas Bechtold <email address hidden>
Date: Tue Apr 4 18:09:34 2017 +0200

    Remove deprecated oslo.messaging aliases parameter

    Those are remnants from the oslo-incubator times. Also, oslo.messaging
    deprecated [1] transport aliases since 5.2.0+ that is the minimal
    version supported for stable/newton.

    [1] I314cefa5fb1803fa7e21e3e34300e5ced31bba89

    Closes-Bug: #1424728
    Change-Id: I50c4559ea2ebc8512a05ffad52e5f04b22743ff4

Changed in keystonemiddleware:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/447286
Committed: https://git.openstack.org/cgit/openstack/magnum/commit/?id=31ee6a32b1cb3791e2d2b41d695a1a6757fb42bf
Submitter: Jenkins
Branch: master

commit 31ee6a32b1cb3791e2d2b41d695a1a6757fb42bf
Author: ChangBo Guo(gcb) <email address hidden>
Date: Sun Mar 19 20:39:17 2017 +0800

    Remove old oslo.messaging transport aliases

    Those are remnants from the oslo-incubator times. Also, oslo.messaging
    deprecated [1] transport aliases since 5.2.0+ that is the minimal
    version supported for stable/newton. The patch that bumped the minimal
    version for Magnum landed 3 months+ ago, so we can proceed ripping
    those aliases from the code base.

    [1] I314cefa5fb1803fa7e21e3e34300e5ced31bba89

    Closes-Bug: #1424728

    Change-Id: I7c35f71f601f3191de4a97866d52db343e5735b1

Changed in magnum:
status: In Progress → Fix Released

This issue was fixed in the openstack/keystonemiddleware 4.15.0 release.

This issue was fixed in the openstack/cinder 11.0.0.0b1 development milestone.

This issue was fixed in the openstack/heat 9.0.0.0b1 development milestone.

This issue was fixed in the openstack/sahara 7.0.0.0b1 development milestone.

This issue was fixed in the openstack/watcher 1.1.0 release.

This issue was fixed in the openstack/searchlight 3.0.0.0b1 development milestone.

This issue was fixed in the openstack/manila 5.0.0.0b1 development milestone.

This issue was fixed in the openstack/nova 16.0.0.0b1 development milestone.

Changed in designate:
assignee: ChangBo Guo(gcb) (glongwave) → Hieu LE (hieulq)

Reviewed: https://review.openstack.org/447290
Committed: https://git.openstack.org/cgit/openstack/designate/commit/?id=72327ff6ab166b5d71350f8dc89bf8ad70d44c87
Submitter: Jenkins
Branch: master

commit 72327ff6ab166b5d71350f8dc89bf8ad70d44c87
Author: ChangBo Guo(gcb) <email address hidden>
Date: Sun Mar 19 20:54:26 2017 +0800

    Remove old oslo.messaging transport aliases

    Those are remnants from the oslo-incubator times. Also, oslo.messaging
    deprecated [1] transport aliases since 5.2.0+ that is the minimal
    version supported for stable/newton. The patch that bumped the minimal
    version for Designate landed 3 months+ ago, so we can proceed ripping
    those aliases from the code base.

    [1] I314cefa5fb1803fa7e21e3e34300e5ced31bba89

    Change-Id: Ic476ebb4fa8bbb0ef31020eee2214e04c58f1d60
    Closes-Bug: #1424728

Changed in designate:
status: In Progress → Fix Released
Changed in iotronic:
assignee: nobody → Kiran Totad (kiran-totad)

Fix proposed to branch: master
Review: https://review.openstack.org/483228

Changed in iotronic:
status: New → In Progress
Changed in grenade:
assignee: nobody → Kiran Totad (kiran-totad)
Changed in oslo.messaging:
assignee: nobody → sudhir agarwal (sudhir.agarwal)
kavitha h r (nidi) on 2017-07-13
Changed in grenade:
assignee: Kiran Totad (kiran-totad) → kavitha h r (nidi)

This issue was fixed in the openstack/designate 5.0.0.0b3 development milestone.

Changed in oslo.messaging:
assignee: sudhir agarwal (sudhir.agarwal) → nobody

This issue was fixed in the openstack/magnum 5.0.0 release.

Changed in cloudpulse:
assignee: nobody → zhangyangyang (zhangyangyang)
status: New → In Progress

Change abandoned by zhangyangyang (<email address hidden>) on branch: master
Review: https://review.openstack.org/502214

Fix proposed to branch: master
Review: https://review.openstack.org/580294

Changed in oslo.messaging:
assignee: nobody → Steve Kowalik (stevenk)
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/580294
Committed: https://git.openstack.org/cgit/openstack/oslo.messaging/commit/?id=e55f419017200d0026ffb0fb8cfef19833347e4e
Submitter: Zuul
Branch: master

commit e55f419017200d0026ffb0fb8cfef19833347e4e
Author: Steve Kowalik <email address hidden>
Date: Thu Jul 5 15:58:05 2018 +1000

    Remove transport aliases support

    To facilitate removing rpc_backend support, disentangle the aliases
    code by removing it to simplify the code and the tests. Aliases were
    first depreacted in 5.20.0 during Pike.

    Change-Id: I7d80cd050ce1eca2c6b6c38f0fac29d090b90bf3
    Closes-Bug: #1424728

Changed in oslo.messaging:
status: In Progress → Fix Released

This issue was fixed in the openstack/oslo.messaging 8.0.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers