python files aren't detected on gedit-latex

Bug #806006 reported by Ignacio Casal Quinteiro
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
intltool
Medium
Данило Шеган

Bug Description

For some reason the python files aren't detected on gedit-latex, see that if I put some translatable string in latex/__init__.py it is indeed detected but not in the other file.s

Changed in intltool:
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Данило Шеган (danilo)
Revision history for this message
Данило Шеган (danilo) wrote :

The problem is with handling multi-line/multi-quoted Python strings (like docstrings and such) in FindLeftoutFiles. I'll be looking into this a bit more later.

Revision history for this message
Данило Шеган (danilo) wrote :

Fix committed in r716 of lp:intltool.

Changed in intltool:
status: Triaged → Fix Committed
Revision history for this message
Данило Шеган (danilo) wrote :

The logic for finding missing files is still not perfect, though. Mixing single- and double-quoted strings in a single line will still trip it, though perhaps not in a significant way.

Changed in intltool:
milestone: none → 0.42.0
Changed in intltool:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers