Failed to execute 'lampstack' workload on wordpress 'Import wordpress posts' step

Bug #1668188 reported by KongWei
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Interop Challenge Workloads
Invalid
Undecided
Unassigned

Bug Description

Description
===========
There are some issues when executing workload 'lampstack':
* In 'Import wordpress posts' step, it was fail.
The message is:
{"changed": true, "cmd": ["wp", "--path=/var/www/html", "import", "/tmp/posts/superuser_content.xml", "--authors=create", "--quiet", "--allow-root"], "delta": "0:00:00.540234", "end": "2017-02-23 10:58:32.361748", "failed": true, "invocation": {"module_args": {"_raw_params": "wp --path=/var/www/html import /tmp/posts/superuser_content.xml --authors=create --quiet --allow-root", "_uses_shell": false, "chdir": null, "creates": null, "executable": null, "removes": null, "warn": true}, "module_name": "command"}, "rc": 1, "start": "2017-02-23 10:58:31.821514", "stderr": "Error: WordPress Importer needs to be activated. Try 'wp plugin activate wordpress-importer'.", "stdout": "", "stdout_lines": [], "warnings": []}

The os of the vm is ubuntu 14.04.

I add one step in 'roles/wordpress/tasks/ubuntu.yml', and it can success.

Expected result
===============
SUCCESS

Actual result
=============
Failure

Environment
===========
1. interop-workloads version
# git log
commit 0db0e2b3f332049fa8f9b5fdd3defe640bfdafa8
Merge: 634e7a7 561e7ed
Author: Jenkins <email address hidden>
Date: Tue Feb 21 20:21:03 2017 +0000

    Merge "NFV workload to test OpenStack interoperability"

2. Which workload did you use?
lampstack

Tags: lampstack
Revision history for this message
KongWei (kong-wei2) wrote :

- name: Activate wordpress theme
  command: >
    wp --path=/var/www/html theme activate superuser --allow-root

KongWei (kong-wei2)
Changed in interop-workloads:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers