[ICL] Enable intel_rapl driver for Icelake

Bug #1771252 reported by quanxian on 2018-05-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
intel
Medium
Unassigned
linux (Ubuntu)
Undecided
Unassigned
linux-oem-osp1 (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
AceLan Kao

Bug Description

Desription:
This feature is intended to track intel_rapl driver enabling for IceLake.

Commit:Powercap/intel_rapl driver enabling for Icelake

Target Release: 19.10
Target Kernel: 5.1

SRU Justification
[Impact]
New CPU is required to be listed in Intel RAPL (Running Average Power Limit) driver.

[Fix]
From Intel's suggestion, below 2 commits are required
   ba6f3ec198d5 powercap/intel_rapl: add Ice Lake mobile
   df7f8e00a50f powercap: intel_rapl: add support for Jacobsville

[Test]
Boot up Intel ICL-Y SDP with the patched kernel, nothing abnormal, but I'm unable to distinguish the difference.

[Regression Potential]
Low, the 2 commits add new ID to the table, should affect new CPU only.

quanxian (quanxian-wang) wrote :

Commit Info:
Powercap/intel_rapl driver enabling for Icelake

tags: added: intel-kernel-18.10
Joseph Salisbury (jsalisbury) wrote :

Can we move this bug to the "Linux" package and make it public?

Changed in intel:
importance: Undecided → Medium
status: New → Triaged
tags: added: kernel-da-key
quanxian (quanxian-wang) wrote :

platform is not PV, just private. Thanks

quanxian (quanxian-wang) on 2018-10-24
description: updated
tags: added: intel-kernel-19.04
removed: intel-kernel-18.10
quanxian (quanxian-wang) on 2019-02-27
description: updated
quanxian (quanxian-wang) wrote :

ba6f3ec198d555d0c9b7e038cb003922aea2797d

Changed in intel:
status: Triaged → Fix Committed
information type: Proprietary → Public
description: updated
quanxian (quanxian-wang) wrote :

git describe --contains df7f8e00a50f4d35b660ea2a2bc734decc1343e6
next-20190214~100^2^2

will be in v5.1-rc1

description: updated
quanxian (quanxian-wang) on 2019-05-06
no longer affects: linux
description: updated
tags: added: intel-kernel-19.10
removed: intel-kernel-19.04

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1771252

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: eoan
Changed in linux (Ubuntu):
status: Incomplete → Triaged
assignee: nobody → AceLan Kao (acelankao)
tags: added: icelake
AceLan Kao (acelankao) on 2019-05-14
Changed in linux (Ubuntu):
status: Triaged → In Progress
AceLan Kao (acelankao) on 2019-05-14
Changed in linux-oem-osp1 (Ubuntu):
assignee: nobody → AceLan Kao (acelankao)
status: New → In Progress
Changed in linux (Ubuntu):
status: In Progress → New
assignee: AceLan Kao (acelankao) → nobody
no longer affects: linux (Ubuntu Bionic)
AceLan Kao (acelankao) on 2019-05-14
description: updated
Changed in linux (Ubuntu):
status: New → Incomplete
AceLan Kao (acelankao) on 2019-05-14
Changed in linux-oem-osp1 (Ubuntu Bionic):
status: New → In Progress
Changed in linux-oem-osp1 (Ubuntu):
status: In Progress → New
Changed in linux-oem-osp1 (Ubuntu Bionic):
assignee: nobody → AceLan Kao (acelankao)
Changed in linux-oem-osp1 (Ubuntu):
assignee: AceLan Kao (acelankao) → nobody
AceLan Kao (acelankao) on 2019-05-14
Changed in linux (Ubuntu):
status: Incomplete → New
Changed in linux-oem-osp1 (Ubuntu Bionic):
status: In Progress → Fix Committed
Changed in linux (Ubuntu):
status: New → Incomplete
Timo Aaltonen (tjaalton) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-bionic' to 'verification-done-bionic'. If the problem still exists, change the tag 'verification-needed-bionic' to 'verification-failed-bionic'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-bionic
AceLan Kao (acelankao) on 2019-06-03
tags: added: verification-done-bionic
removed: verification-needed-bionic
AceLan Kao (acelankao) on 2019-06-14
Changed in linux-oem-osp1 (Ubuntu):
status: New → Invalid
AceLan Kao (acelankao) wrote :

The fix already in 5.0.0-1008.9

Changed in linux-oem-osp1 (Ubuntu Bionic):
status: Fix Committed → Fix Released
Changed in intel:
status: Fix Committed → Fix Released
quanxian (quanxian-wang) wrote :

Patch for ICLLAKE MOBILE intel_rapl support shipped in 5.3-rc1.

0ab74bcd1b50821391b264150d26b7f03ba6740b
ba6f3ec198d555d0c9b7e038cb003922aea2797d

Brad Figg (brad-figg) on 2019-07-24
tags: added: cscc
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers