[CNL-Y] enable kernel support of graphics

Bug #1757573 reported by quanxian on 2018-03-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
intel
Undecided
Timo Aaltonen
linux-oem (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

[impact]

Currently in 18.04 beta1, (v4.15), CNL-Y graphics is not enabled.
is_alpha_support = 1
i915/i915_pci.c
572 static const struct intel_device_info intel_cannonlake_gt2_info __initconst = {
573 GEN10_FEATURES,
574 .is_alpha_support = 1,
575 .platform = INTEL_CANNONLAKE,
576 .gen = 10,
577 .gt = 2,
578 };

Enabling it needs 59 commits backported from 4.16/drm-intel-next-queued according to a list provided by Intel.

[test case]
Test a kernel build with backports on CNL-Y.

[regression potential]
minor, they are mostly about CNL only

quanxian (quanxian-wang) wrote :

By the way, as roadmap of CNL-Y described

beta release will be out on WW17'18. Currently in 4.16, CNL-Y graphics should be in alpha phase. and absolutely unstable.

This is only for kernel. For mesa/2d/media driver, there should be more works on that.

summary: - [CNL-Y] enable graphics
+ [CNL-Y] enable graphics of kernel
summary: - [CNL-Y] enable graphics of kernel
+ [CNL-Y] enable alpha kernel support of graphics

SUSE graphics works well on CNL-Y with commits provided by Intel.

I have done a comparison between 4.16-rc6 and bionic (Ubuntu kernel 18.04), there are some difference. Seems more.

Would Canonical Graphics team to make sure if all the commits have been pushed into 18.04?

Thanks

I will attach the excel in this bugzilla.

quanxian (quanxian-wang) wrote :

we have a try on latest stable kernel 4.16-rc6. The function works normally except some little bugs.
We are still on more testing for 3D, 2D testing. Any result, will be shared in this bugzila.

Thanks for your cooperation.

Timo Aaltonen (tjaalton) wrote :

You should probably test what's going in 4.17 as it includes the rest of the commits from that list:

http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-intel-next/2018-03-09/

install linux-image..generic..amd64.deb

Timo Aaltonen (tjaalton) wrote :

actually I'll just build you bionic kernel with the backports.. it should be ready in an hour or so

Timo Aaltonen (tjaalton) wrote :

ok here it is:

https://aaltoset.kapsi.fi/cnl

forgot to change the version number to something temporary, the actual -14.15 won't have these patches

Timo Aaltonen (tjaalton) on 2018-03-23
Changed in intel:
assignee: nobody → Timo Aaltonen (tjaalton)
Timo Aaltonen (tjaalton) on 2018-03-28
information type: Proprietary → Public
summary: - [CNL-Y] enable alpha kernel support of graphics
+ [CNL-Y] enable kernel support of graphics
Timo Aaltonen (tjaalton) on 2018-03-28
description: updated

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1757573

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Timo Aaltonen (tjaalton) on 2018-03-29
Changed in linux-oem (Ubuntu Bionic):
status: New → Fix Committed
Timo Aaltonen (tjaalton) wrote :

I can trivially hang the GPU even with drm-intel-nightly just by going through the gnome control center options. Wonder if rev 03 is too old.

quanxian (quanxian-wang) wrote :

File a bug in freedesktop, maybe they could provide some hints.

Timo Aaltonen (tjaalton) on 2018-04-26
Changed in linux-oem (Ubuntu Bionic):
status: Fix Committed → Fix Released
Changed in intel:
status: New → Won't Fix
no longer affects: linux (Ubuntu)
no longer affects: linux (Ubuntu Bionic)
Changed in intel:
status: Won't Fix → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers