[Feature][CFL][ICL] [CNL]Thunderbolt support (Titan Ridge)

Bug #1730775 reported by quanxian on 2017-11-07
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
intel
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Description:
This is platform independent and can be verified on any of the three platforms mentioned here.
ICL TBT support requires native mode.

Target Kernel: 4.17
Target Release: 18.10

Anthony Wong (anthonywong) wrote :

Is there any update to Titan Ridge support? Dell mentions the support will be in 4.17, I'd like to confirm if that's the case. Thanks.

quanxian (quanxian-wang) on 2018-01-30
description: updated
tags: added: kernel
Changed in intel:
status: New → Incomplete
information type: Proprietary → Public

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1730775

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: bionic
Changed in intel:
status: Incomplete → Confirmed
Anthony Wong (anthonywong) wrote :

The main patchset "thunderbolt: Add support for Intel Titan Ridge" has been merged upstream:
    - https://lkml.org/lkml/2018/3/2/570
    - already merged into https://git.kernel.org/pub/scm/linux/kernel/git/westeri/thunderbolt.git/log/?h=next

There are two other related patchsets for thunderbolt native mode, one of which is still under review:
1. PCI: Fixes for native PCIe and ACPI hotplug
    - https://patchwork.ozlabs.org/cover/877884/
    - still pending on maintainer review

2. [PATCH] ACPICA: Recognize the Windows 10 RS3 OSI string
    - https://marc.info/?l=linux-acpi&m=151854485331385&w=2
    - this one has a dependency on the previous one.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Seth Forshee (sforshee) on 2018-03-28
Changed in linux (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (40.4 KiB)

This bug was fixed in the package linux - 4.15.0-15.16

---------------
linux (4.15.0-15.16) bionic; urgency=medium

  * linux: 4.15.0-15.16 -proposed tracker (LP: #1761177)

  * FFe: Enable configuring resume offset via sysfs (LP: #1760106)
    - PM / hibernate: Make passing hibernate offsets more friendly

  * /dev/bcache/by-uuid links not created after reboot (LP: #1729145)
    - SAUCE: (no-up) bcache: decouple emitting a cached_dev CHANGE uevent

  * Ubuntu18.04:POWER9:DD2.2 - Unable to start a KVM guest with default machine
    type(pseries-bionic) complaining "KVM implementation does not support
    Transactional Memory, try cap-htm=off" (kvm) (LP: #1752026)
    - powerpc: Use feature bit for RTC presence rather than timebase presence
    - powerpc: Book E: Remove unused CPU_FTR_L2CSR bit
    - powerpc: Free up CPU feature bits on 64-bit machines
    - powerpc: Add CPU feature bits for TM bug workarounds on POWER9 v2.2
    - powerpc/powernv: Provide a way to force a core into SMT4 mode
    - KVM: PPC: Book3S HV: Work around transactional memory bugs in POWER9
    - KVM: PPC: Book3S HV: Work around XER[SO] bug in fake suspend mode
    - KVM: PPC: Book3S HV: Work around TEXASR bug in fake suspend state

  * Important Kernel fixes to be backported for Power9 (kvm) (LP: #1758910)
    - powerpc/mm: Fixup tlbie vs store ordering issue on POWER9

  * Ubuntu 18.04 - IO Hang on some namespaces when running HTX with 16
    namespaces (Bolt / NVMe) (LP: #1757497)
    - powerpc/64s: Fix lost pending interrupt due to race causing lost update to
      irq_happened

  * fwts-efi-runtime-dkms 18.03.00-0ubuntu1: fwts-efi-runtime-dkms kernel module
    failed to build (LP: #1760876)
    - [Packaging] include the retpoline extractor in the headers

linux (4.15.0-14.15) bionic; urgency=medium

  * linux: 4.15.0-14.15 -proposed tracker (LP: #1760678)

  * [Bionic] mlx4 ETH - mlnx_qos failed when set some TC to vendor
    (LP: #1758662)
    - net/mlx4_en: Change default QoS settings

  * AT_BASE_PLATFORM in AUXV is absent on kernels available on Ubuntu 17.10
    (LP: #1759312)
    - powerpc/64s: Fix NULL AT_BASE_PLATFORM when using DT CPU features

  * Bionic update to 4.15.15 stable release (LP: #1760585)
    - net: dsa: Fix dsa_is_user_port() test inversion
    - openvswitch: meter: fix the incorrect calculation of max delta_t
    - qed: Fix MPA unalign flow in case header is split across two packets.
    - tcp: purge write queue upon aborting the connection
    - qed: Fix non TCP packets should be dropped on iWARP ll2 connection
    - sysfs: symlink: export sysfs_create_link_nowarn()
    - net: phy: relax error checking when creating sysfs link netdev->phydev
    - devlink: Remove redundant free on error path
    - macvlan: filter out unsupported feature flags
    - net: ipv6: keep sk status consistent after datagram connect failure
    - ipv6: old_dport should be a __be16 in __ip6_datagram_connect()
    - ipv6: sr: fix NULL pointer dereference when setting encap source address
    - ipv6: sr: fix scheduling in RCU when creating seg6 lwtunnel state
    - mlxsw: spectrum_buffers: Set a minimum quota for CPU port traffic
    - net: phy: Tell caller result ...

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
quanxian (quanxian-wang) on 2018-05-01
description: updated
tags: added: intel-kernel-18.10
quanxian (quanxian-wang) wrote :

0b0a0bd06ee031b0e439a11a1b15573d9845b4be 14862ee308bbcaae0ac9927b6cbccccb51386b6c 3080e197e936ab7cdcf66cacec22abe5c6c1007a 432019d644878dbefd8ec2482cb01ec68b8722b9 44b51bbb16d033ac1984123349ec055bae09b623 484cb153fe5ffcd0b7cf423cf29aaeadd0e862b1 4bac471da0d6bab6094c42cf82e08280f361fd31 68a7a2ace13156b8a3d8cd6cceab6c30b52e2923 6fc14e1a44e53c472865252b47398346a27d600e 79fae987518a3aa6c3c7b2e3ad5fe1e4080c12bc 8e9267bb3559065fddecf344cb54501704fcb68e 9aaa3b8b4c56d24210acef37b7c800ca218c3d40 a03e828915c00ed0ea5aa40647c81472cfa7a984 b6b0ea70f4254139e204870937cdb24d88dfac68 cb653eecde3dc37c67d3e7297ac5445d16f7be13 e4be8c9b6a512e274cb6bbac4ac869d73880a8b3 ee487dd2447a43dd318bd7ba2c54e59e707ad851 f2a659f7d8d5da803836583aa16df06bdf324252

Anthony Wong (anthonywong) wrote :

For the record, all the above commits are already in Bionic kernel.

quanxian (quanxian-wang) wrote :

hi, Anthony

Please make sure this commit had been into Bionic. Thanks

#git branch --contains f2a659f7d8d5da803836583aa16df06bdf324252
* v4.17-rc6
# git tag --contains f2a659f7d8d5da803836583aa16df06bdf324252
v4.17-rc1
...

commit f2a659f7d8d5da803836583aa16df06bdf324252
Author: Mika Westerberg <email address hidden>
Date: Tue Dec 19 12:44:56 2017 +0300

thunderbolt: Resume control channel after hibernation image is created

Changed in intel:
status: Confirmed → Fix Released
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-bionic' to 'verification-done-bionic'. If the problem still exists, change the tag 'verification-needed-bionic' to 'verification-failed-bionic'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-bionic
Andy Whitcroft (apw) on 2019-02-14
tags: added: kernel-fixup-verification-needed-bionic
removed: verification-needed-bionic
Brad Figg (brad-figg) on 2019-02-14
tags: added: verification-needed-bionic
Andy Whitcroft (apw) wrote :

This bug was erroneously marked for verification in bionic; verification is not required and verification-needed-bionic is being removed.

tags: removed: verification-needed-bionic
tags: added: verification-done-bionic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers