[Feature] PXE boot with Intel Omni-Path

Bug #1712031 reported by Tymoteusz Kielan on 2017-08-21
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
intel
Undecided
Unassigned
linux (Ubuntu)
High
Seth Forshee
linux-firmware (Ubuntu)
High
Seth Forshee

Bug Description

Description:

This is about ability to PXE boot over Intel Fabric.
Netboot initrd is missing infiniband kernel stack along with hfi1.ko (for 1st generation of Intel Omni-Path cards). In addition some firmware files required to load modules are also missing in initrd. This firmware came from existing linux-firmware package, but is not included in netboot initrd image.

Add Intel Omni-Path Architecture (OPA) Firmware to initrd.gz

The initrd.gz supplied on Ubuntu 17.04 is missing
the following firmware listed below in the /lib/firmware directory.
As a result, PXE boot over fabric fails.

        hfi1_dc8051.fw
        hfi1_fabric.fw
        hfi1_pcie.fw
        hfi1_sbus.fw

Target Release: 18.04

CVE References

description: updated

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1712031/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → debian-installer (Ubuntu)
Tymoteusz Kielan (tkielan) wrote :

1. Feature Overview:
    a) Name of feature:
        Add Intel Omni-Path Architecture (OPA) Firmware to initrd.gz

    b) Feature Description:
        The initrd.gz supplied on Ubuntu 17.04 is missing
        the following firmware listed below in the /lib/firmware directory.
        As a result, PXE boot over fabric fails.

        hfi1_dc8051.fw
        hfi1_fabric.fw
        hfi1_pcie.fw
        hfi1_sbus.fw
        hfi1_smbus.fw (to be confirmed)

        These firmware binaries can be found in the standard Ubuntu distro or
        linux-firmware (except hfi1_smbus.fw)

2. Feature Details:
    a) Architectures:
        64-bit Intel EM64T/AMD64

    b) Drivers or hardware dependencies:
        Omni-Path HFI, HFI driver

    c) Upstream acceptance information:
        Part of linux-firmware

    d) Severity (H,M,L):
        High

    e) Feature Needed by:
        Ubuntu 18.04 LTS

3. Business Justification:
    a) Why is this feature needed?
        The firmware is required for the HFI card for Omni-Path Architecture.

    b) What hardware does this enable?
        Omni-Path HFI

    c) Is this hardware on-board in a system (eg, LOM) or an add-on card?
        PCIe card

    d) Business impact?
        Required for Omni-Path

Tymoteusz Kielan (tkielan) wrote :

Please ignore my previous comment, as I have updated bug description

summary: - PXE boot with Intel Omni-Path feature request
+ [Feature] PXE boot with Intel Omni-Path
description: updated
quanxian (quanxian-wang) on 2017-08-24
description: updated
affects: debian-installer (Ubuntu) → intel

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1712031

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → High
Changed in linux-firmware (Ubuntu):
status: New → Triaged
importance: Undecided → High
Changed in linux-firmware (Ubuntu):
assignee: nobody → Seth Forshee (sforshee)
Seth Forshee (sforshee) on 2017-10-04
Changed in linux (Ubuntu):
assignee: nobody → Seth Forshee (sforshee)
Seth Forshee (sforshee) on 2017-10-04
Changed in linux (Ubuntu):
status: Triaged → Fix Committed
Changed in linux-firmware (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-firmware - 1.169

---------------
linux-firmware (1.169) artful; urgency=medium

  * [Feature] PXE boot with Intel Omni-Path (LP: #1712031)
    - Add Intel Omni-Path firmware to nic-firmware.lst

 -- Seth Forshee <email address hidden> Wed, 04 Oct 2017 09:23:35 -0500

Changed in linux-firmware (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (16.2 KiB)

This bug was fixed in the package linux - 4.13.0-15.16

---------------
linux (4.13.0-15.16) artful; urgency=low

  * linux: 4.13.0-15.16 -proposed tracker (LP: #1721373)

  * Boot regression on POWER9 (LP: #1721391)
    - Revert "crypto/nx: Add P9 NX support for 842 compression engine"
    - Revert "crypto/nx: Add P9 NX specific error codes for 842 engine"
    - Revert "crypto/nx: Use kzalloc for workmem allocation"
    - Revert "crypto/nx: Add nx842_add_coprocs_list function"
    - Revert "crypto/nx: Create nx842_delete_coprocs function"
    - Revert "crypto/nx: Create nx842_configure_crb function"
    - Revert "crypto/nx: Rename nx842_powernv_function as icswx function"
    - Revert "UBUNTU: [Config] CONFIG_PPC_VAS=y"
    - Revert "powerpc/powernv/vas: Define copy/paste interfaces"
    - Revert "powerpc/powernv/vas: Define vas_tx_win_open()"
    - Revert "powerpc/powernv/vas: Define vas_win_close() interface"
    - Revert "powerpc/powernv/vas: Define vas_rx_win_open() interface"
    - Revert "powerpc/powernv/vas: Define helpers to alloc/free windows"
    - Revert "powerpc/powernv/vas: Define helpers to init window context"
    - Revert "powerpc/powernv/vas: Define helpers to access MMIO regions"
    - Revert "powerpc/powernv/vas: Define vas_init() and vas_exit()"
    - Revert "powerpc/powernv: Move GET_FIELD/SET_FIELD to vas.h"
    - Revert "powerpc/powernv/vas: Define macros, register fields and structures"
    - Revert "powerpc/powernv: Enable PCI peer-to-peer"
    - Revert "powerpc/powernv: Add support to set power-shifting-ratio"
    - Revert "powerpc/powernv: Add support for powercap framework"
    - Revert "powerpc/perf: Add nest IMC PMU support"
    - Revert "powerpc/powernv: Detect and create IMC device"
    - Revert "powerpc/powernv: Add IMC OPAL APIs"

  * smartpqi patches for Artful (LP: #1721381)
    - scsi: smartpqi: add pqi reset quiesce support
    - scsi: smartpqi: enhance BMIC cache flush
    - scsi: smartpqi: update pqi passthru ioctl
    - scsi: smartpqi: cleanup doorbell register usage.
    - scsi: smartpqi: update kexec and power down support
    - scsi: smartpqi: add in new controller ids
    - scsi: smartpqi: change driver version to 1.1.2-125

  * CONFIG_DEBUG_FS is not enabled by "make zfcpdump_defconfig" with Ubuntu
    17.10 (kernel 4.13) (LP: #1719290)
    - SAUCE: s390: update zfcpdump_defconfig

  * [Feature] PXE boot with Intel Omni-Path (LP: #1712031)
    - d-i: Add hfi1 to nic-modules

  * [Feature]CNL:New device IDs for CNL (LP: #1685729)
    - pinctrl: intel: Add Intel Cannon Lake PCH-H pin controller support

linux (4.13.0-14.15) artful; urgency=low

  * linux: 4.13.0-14.15 -proposed tracker (LP: #1721122)

  * [Artful] ltp rwtest - Unable to handle kernel paging request at virtual
    address (LP: #1721067)
    - arm64: mm: Use READ_ONCE when dereferencing pointer to pte table

  * linux 4.13.0-13.14 ADT test failure with linux 4.13.0-13.14 (LP: #1720779)
    - SAUCE: LSM stacking: check for invalid zero sized writes

  * Add installer support for Broadcom BCM573xx network drivers. (LP: #1720466)
    - d-i: Add bnxt_en to nic-modules.

  * Miscellaneous Ubuntu changes
    - [Packaging] Include arch/arm6...

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Changed in intel:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers