[Feature]Enable xsavec/xsaves/xrstors on SKL

Bug #1460904 reported by XiongZhang on 2015-06-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
intel
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned
xen (Ubuntu)
Undecided
Unassigned

Bug Description

Xsaves is enabled in 3.17 kernel. But we found some bugs about Xsaves on SKL.
This entry is used to track this bug fix.

schedule:
kernel: 4.8
Xen: 4.7

summary: - [Feature]Enable xsavec/xsaves/xrstors
+ [Feature]Enable xsavec/xsaves/xrstors on SKL
XiongZhang (xiong-y-zhang) wrote :

Patchset are sent to community for review:
https://lkml.org/lkml/2015/5/8/732

description: updated
description: updated

If the new upstream kernel target is 4.4, I'd suggest we postpone this feature to our 16.04 LTS release in April, 2016.

information type: Proprietary → Private
description: updated
description: updated
description: updated
XiongZhang (xiong-y-zhang) wrote :

Xen 4.7 has implemented this.

description: updated
XiongZhang (xiong-y-zhang) wrote :

Xsaves is enabled in v4.8 kernel again with the following patches:
b8be15d x86/fpu/xstate: Re-enable XSAVES
35ac2d7 x86/fpu/xstate: Fix fpstate_init() for XRSTORS
5060b91 x86/fpu/xstate: Return NULL for disabled xstate component address
1fc2b67 x86/fpu/xstate: Fix __fpu_restore_sig() for XSAVES
ac73b27 x86/fpu/xstate: Fix xstate_offsets, xstate_sizes for non-extended xstates
996952e x86/fpu/xstate: Fix XSTATE component offset print out
91c3dba x86/fpu/xstate: Fix PTRACE frames for XSAVES
1499ce2 x86/fpu/xstate: Fix supervisor xstate component offset
03482e0 x86/fpu/xstate: Align xstate components according to CPUID
99aa22d x86/fpu/xstate: Copy xstate registers directly to the signal frame when compacted format is in use
7d93706 x86/fpu/xstate: Keep init_fpstate.xsave.header.xfeatures as zero for init optimization
bf15a8c x86/fpu/xstate: Rename 'xstate_size' to 'fpu_kernel_xstate_size', to distinguish it from 'fpu_user_xstate_size'
a1141e0 x86/fpu/xstate: Define and use 'fpu_user_xstate_size'

Tim Gardner (timg-tpi) wrote :

These patches will be released in 16.10 as I do not think the backports will qualify for SRU.

information type: Private → Public

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1460904

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu):
status: Incomplete → Fix Released
Changed in xen (Ubuntu):
status: New → Fix Released
Changed in intel:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers