[Feature] Skylake audio support (HD/HDMI/DP audio)

Bug #1398277 reported by Yingying Zhao on 2014-12-02
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
intel
Undecided
Unassigned
linux (Ubuntu)
Medium
Tim Gardner
Wily
Medium
Tim Gardner

Bug Description

Support for Skylake audio (HD/HDMI/DP audio)

Upstream status:
Alpha – Done (ww 03)
Beta – Done (ww12)
PV – Done (ww23)

tags: removed: need-upstream-update
description: updated
description: updated

Do we have references for the upstream commits for this?

description: updated
description: updated
Timo Aaltonen (tjaalton) wrote :

Hui will work on this, thanks ;)

powerwell support for HDMI/DP audio will be included in the next pull request for i915_bpo

Changed in intel:
assignee: nobody → Hui Wang (hui.wang)
Timo Aaltonen (tjaalton) wrote :

sorry, wrong bug

Changed in intel:
assignee: Hui Wang (hui.wang) → nobody
description: updated
summary: - [Feature] Skylake audio support (HD audio, DSP audio)
+ [Feature] Skylake audio support (HD/HDMI/DP audio)
description: updated
description: updated

Hi Xiong, do we have a list of commits for this that we should confirm we have included in Wily 15.10? Thanks.

XiongZhang (xiong-y-zhang) wrote :

I don't have a commits list for this, but it could work on Wily 15.10.
But you should back port the following patches to support HDMI / DP hotplug
25adc13 ALSA: hda - Wake the codec up on pin/ELD notify events
45c053d ALSA: hda - allow codecs to access the i915 pin/ELD callback
51e1d83 drm/i915: Call audio pin/ELD notify function
2a8ceed drm/i915: Add audio pin sense / ELD callback

Tim Gardner (timg-tpi) on 2015-09-24
information type: Proprietary → Public
Changed in linux (Ubuntu Wily):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
Changed in linux (Ubuntu Wily):
importance: Undecided → Medium
Changed in intel:
status: New → Confirmed
Tim Gardner (timg-tpi) on 2015-09-24
Changed in linux (Ubuntu Wily):
status: In Progress → Fix Committed
David Henningsson (diwic) wrote :

Hi Tim and thanks for taking care of it so far - for consistency, would you mind adding two more:

commit d5f362a7b977bdfaf8a955f3d604a29267bd5464
Author: David Henningsson <email address hidden>
Date: Thu Sep 3 11:51:35 2015 +0200

    drm/i915: Add locks around audio component bind/unbind

And:

commit f0675d4a8ed9d3e863ff611561ee0944969a2784
Author: David Henningsson <email address hidden>
Date: Thu Sep 3 11:51:34 2015 +0200

    drm/i915: Drop port_mst_index parameter from pin/eld callback

....that brings us more in line with both 4.3 as well as in 3.19. (Because upstream made a mistake, the four patches we have in 3.19 corresponds to the six pointed out by Xiong and me.)

Just adding a note here that Tim picked up the additional two patches requested by David in comment #6. There are in the 4.2.0-12.14 kernel currently in wily-proposed. Thanks.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 4.2.0-12.14

---------------
linux (4.2.0-12.14) wily; urgency=low

  [ Tim Gardner ]

  * Release Tracking Bug
    - LP: #1499712

  [ Ben Pope ]

  * SAUCE: drivers/net/ethernet/atheros/alx: Add Killer E2400 device ID
    - LP: #1498633

  [ Knuth Posern ]

  * SAUCE: thunderbolt: Allow loading of module on recent Apple MacBooks
    with thunderbolt 2 controller
    - LP: #1497321

  [ Laurent Dufour ]

  * SAUCE: powerpc/hvsi: Fix endianness issues in the HVSI driver
    - LP: #1499357

  [ Upstream Kernel Changes ]

  * x86/hyperv: Mark the Hyper-V TSC as unstable
    - LP: #1498206
  * intel_pstate: fix PCT_TO_HWP macro
    - LP: #1499040
  * perf/x86/intel/rapl: Add support for Knights Landing (KNL)
    - LP: #1461370
  * drm/i915: Add audio pin sense / ELD callback
    - LP: #1398277
  * drm/i915: Call audio pin/ELD notify function
    - LP: #1398277
  * ALSA: hda - allow codecs to access the i915 pin/ELD callback
    - LP: #1398277
  * ALSA: hda - Wake the codec up on pin/ELD notify events
    - LP: #1398277
  * drm/i915: Add locks around audio component bind/unbind
    - LP: #1398277
  * drm/i915: Drop port_mst_index parameter from pin/eld callback
    - LP: #1398277

 -- Tim Gardner <email address hidden> Thu, 24 Sep 2015 09:19:23 -0600

Changed in linux (Ubuntu Wily):
status: Fix Committed → Fix Released
Changed in intel:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers