Update firmware for 7260 / 3160 devices (Wilkins Peak)

Reported by Yingying Zhao on 2014-01-02
42
This bug affects 11 people
Affects Status Importance Assigned to Milestone
intel
Undecided
Unassigned
linux-firmware (Ubuntu)
Status tracked in Trusty
Precise
Undecided
Tim Gardner
Saucy
Undecided
Tim Gardner
Trusty
Undecided
Tim Gardner

Bug Description

2 new firmware versions are now available and need to update for 7260 / 3160
devices(Wilkins Peak) at http://wireless.kernel.org/en/users/Drivers/iwlwifi

[1]
Wireless 7260 3.10+ kernel -> iwlwifi-7260-ucode-22.1.7.0.tgz
Wireless 3160 3.10+ kernel -> iwlwifi-3160-ucode-22.1.7.0.tgz

also available in linux-firmware.git
commit 824994715e0276e64cdbf2badbe02921a78fb287
iwlwifi: update firmware for 7260 / 3160 devices

[2]
Wireless 7260 3.13+ kernel -> iwlwifi-7260-ucode-22.15.8.0.tgz
Wireless 3160 3.13+ kernel -> iwlwifi-3160-ucode-22.15.8.0.tgz

Quote from Emmanuel: "OSVs can safely have both firmware files installed
regardless of the kernel version. Kernel 3.10 won’t load 22.15.8.0 but 22.1.7.0
only. Kernel 3.13 will try to load 22.15.8.0 and if it is not there, it will
try to load 22.1.7.0. So nothing bad will happen if OSVs have both firmware
installed. Just a bit of a waste - but nothing worse than that."

Tim Gardner (timg-tpi) on 2014-01-02
information type: Proprietary → Public
Changed in linux-firmware (Ubuntu Trusty):
status: New → Fix Released
Changed in linux-firmware (Ubuntu Precise):
status: New → Fix Committed
Changed in linux-firmware (Ubuntu Saucy):
status: New → In Progress
Tim Gardner (timg-tpi) wrote :

Actually, only API 7 has been committed. When will a request to add API 8 to upstream linux-firmare be made ?

Changed in linux-firmware (Ubuntu Trusty):
status: Fix Released → In Progress
assignee: nobody → Tim Gardner (timg-tpi)
Changed in linux-firmware (Ubuntu Saucy):
assignee: nobody → Tim Gardner (timg-tpi)
Changed in linux-firmware (Ubuntu Precise):
assignee: nobody → Tim Gardner (timg-tpi)
Seth Forshee (sforshee) wrote :
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-firmware - 1.119

---------------
linux-firmware (1.119) trusty; urgency=low

  * iwlwifi: update firmware for 7260 / 3160 devices
    version: 22.15.8.0
    Supported by kernel 3.13 and up.
    cherry-picked from git://git.kernel.org/pub/scm/linux/kernel/git/egrumbach/linux-firmware
    http://www.spinics.net/lists/linux-wireless/msg116615.html
    -LP: #1265436
 -- Tim Gardner <email address hidden> Fri, 03 Jan 2014 10:35:23 -0700

Changed in linux-firmware (Ubuntu Trusty):
status: In Progress → Fix Released
Tim Gardner (timg-tpi) on 2014-01-03
Changed in linux-firmware (Ubuntu Saucy):
status: In Progress → Fix Committed

Hello Yingying, or anyone else affected,

Accepted linux-firmware into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/linux-firmware/1.116.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Reply to #4:
I tested the linux-firmware in saucy-proposed, both 7260 and 3160 work fine and have no regression.

Chris Halse Rogers (raof) wrote :

Marking verification done as per comment #5

tags: added: verification-done
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-firmware - 1.116.1

---------------
linux-firmware (1.116.1) saucy; urgency=low

  * iwlwifi: update firmware for 7260 / 3160 devices
    22.0.7.0 --> 22.1.7.0
    -LP: #1265436
 -- Tim Gardner <email address hidden> Fri, 03 Jan 2014 12:47:22 -0700

Changed in linux-firmware (Ubuntu Saucy):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for linux-firmware has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Hello Yingying, or anyone else affected,

Accepted linux-firmware into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/linux-firmware/1.116.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Hi, I tested this from proposed.

I put back the old /lib/firmware/iwlwifi-7260-7.ucode,
updated from linux-firmware from proposed,
and /lib/firmware/iwlwifi-7260-7.ucode was the new version.

I´ve used the wifi for about a day with no problems. Thanks!

Seth Forshee (sforshee) wrote :

I tested with both 3160 and 7260 cards. In both cases saucy's 3.11 kernel still loads the 22.1.7.0 firmware, as expected. This firmware is unchanged since linux-firmware 1.116.1, so the behavior is predictably identical.

Scott Kitterman (kitterman) wrote :

The verification of the Stable Release Update for mikutter has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Tim Gardner (timg-tpi) on 2014-03-02
summary: - Saucy SRU: update firmware for 7260 / 3160 devices (Wilkins Peak)
+ Update firmware for 7260 / 3160 devices (Wilkins Peak)
Yingying Zhao (yingying-zhao) wrote :

There is a new firmware[3] version 22.24.8.0 upgrade for 7260 /3160 (Wilkins Peak) devices.
Wireless 7260 3.13+ kernel -> iwlwifi-7260-ucode-22.24.8.0.tgz
Wireless 3160 3.13+ kernel -> iwlwifi-3160-ucode-22.24.8.0.tgz

This new firmware is based on LinuxCore4 stream and is supported starting
kernel 3.13. It replaces the previously released FW(based on LinuxCore3).

Quote from the release note:

"This firmware is supported starting 3.13 kernel.
We have a here quite a few bug fixes with a few new features.
Most of the improvements concern P2P client and GO modes.

The firmware for 7260 is available at (1) and for 3160 at (2).
I will send a pull request to linux-firmware.git soon.

The new firmware's version number is 22.24.8.0:

$ dmesg | grep loaded\ firmware
loaded firmware version 22.24.8.0 op_mode iwlmvm

(1)
http://wireless.kernel.org/en/users/Drivers/iwlwifi?action=AttachFile&do=get&target=iwlwifi-7260-ucode-22.24.8.0.tgz
(2)
http://wireless.kernel.org/en/users/Drivers/iwlwifi?action=AttachFile&do=get&target=iwlwifi-3160-ucode-22.24.8.0.tgz
"

Tim Gardner (timg-tpi) on 2014-03-05
Changed in linux-firmware (Ubuntu Trusty):
status: Fix Released → Fix Committed
Tim Gardner (timg-tpi) on 2014-03-05
Changed in linux-firmware (Ubuntu Precise):
milestone: none → ubuntu-12.04.5
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-firmware - 1.126

---------------
linux-firmware (1.126) trusty; urgency=low

  * Update firmware for 7260 / 3160 devices (Wilkins Peak)
    https://bugs.launchpad.net/intel/+bug/1265436/comments/13
    Quote from the release note:
      "This firmware is supported starting 3.13 kernel.
      We have a here quite a few bug fixes with a few new features.
      Most of the improvements concern P2P client and GO modes."
    -LP: #1265436
 -- Tim Gardner <email address hidden> Wed, 05 Mar 2014 08:34:45 -0700

Changed in linux-firmware (Ubuntu Trusty):
status: Fix Committed → Fix Released

Hello Yingying, or anyone else affected,

Accepted linux-firmware into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/linux-firmware/1.79.12 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Daniel Holm (danielholm) wrote :

Adam,

Will this package be build for 14.04 any time soon as well? It is still on 1.127.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers