[Feature] Intel Bluetooth on Wilkins Peak wireless adapter

Bug #1011423 reported by Yingying Zhao on 2012-06-11
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
intel
Undecided
Unassigned
linux (Ubuntu)
Undecided
Tim Gardner
Precise
Undecided
Unassigned
Saucy
Undecided
Tim Gardner
linux-firmware (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
linux-lts-saucy (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Tim Gardner

Bug Description

Wilkins Peak is WiFi and Bluetooth combo card for Shark Bay mobile platform. Wilkins Peak comes in two SKUs. But the Bluetooth core is same on those two SKUs. This feature request is for the Bluetooth core in the Wilkins Peak.

Yingying Zhao (yingying-zhao) wrote :

The current schedule is:
Beta ww16’13, PV – ww26’13

James M. Leddy (jm-leddy) wrote :

We will be supporting this via a compat-backport package.

XiongZhang (xiong-y-zhang) wrote :

From An, Tedd:
WilkinsPeak Bluetooth is ROM based and it will work as is as a generic bluetooth device.
However, it is strongly recommended to download the firmware (ROM patch file) to fix the bugs in the device firmware.

The WilkinsPeak Bluetooth ROM patch driver is upstreamed to bluetooth-next tree and it is waiting for merging to 3.10 mainline.
Here is a link for this driver patch:
http://git.kernel.org/cgit/linux/kernel/git/bluetooth/bluetooth-next.git/commit/?id=dffd30ee9619ccd7153f1861ba0436bbc4400f36

Regarding the firmware file (ROM patch file), I sent the patch to linux-firmware tree maintainer but hasn't been processed yet.

description: updated
AceLan Kao (acelankao) on 2013-05-14
Changed in linux (Ubuntu):
status: New → In Progress
status: In Progress → New
AceLan Kao (acelankao) wrote :

Hi,
I'm using the patch btusb driver and the new firmware on my 7260 machine and got the following message.
[ 10.712424] usbcore: registered new interface driver btusb
[ 10.725020] Bluetooth: hci0: read Intel version: 370710018001290c00
[ 10.726632] Bluetooth: hci0 failed to open Intel firmware file: intel/ibt-hw-37.7.10-fw-1.80.1.29.c.bseq(-2)
[ 10.784742] Bluetooth: hci0: Intel Bluetooth firmware file: intel/ibt-hw-37.7.bseq
[ 10.788920] Bluetooth: hci0: Intel Bluetooth firmware patch completed

It wanted to load another version of firmware and failed.
So, I tried to rename the firmware to ibt-hw-37.7.10-fw-1.80.1.29.c.bseq
And then I got
[ 9.892201] Bluetooth: hci0: read Intel version: 370710018001290c00
[ 9.902748] Bluetooth: hci0: Intel Bluetooth firmware file: intel/ibt-hw-37.7.10-fw-1.80.1.29.c.bseq

But the BD addr all becomes zeros (it's not zero if it loads the firmware failed)
hci0: Type: BR/EDR Bus: USB
        BD Address: 00:00:00:00:00:00 ACL MTU: 0:0 SCO MTU: 0:0
        DOWN INIT RUNNING
        RX bytes:57 acl:0 sco:0 events:8 errors:0
        TX bytes:2615 acl:0 sco:0 commands:15 errors:0

XiongZhang (xiong-y-zhang) wrote :

It seems like you are using WP2 B2 card which is old one. The current and distributed version is WP2 B3.
Could you confirm you are using WP2 B2 ? If it is, could you get a WP2 B3 ?

AceLan Kao (acelankao) wrote :

Hi,
I don't know how to distinguish with B2 and B3 chip,
but I tried some other cards and the btusb tried loading the firmware ibt-hw-37.7.10-fw-1.80.2.3.d.bseq and then bt works.
Thank you very much.

Anthony Wong (anthonywong) wrote :

@Xiong
Is there any way to check if we have B2 or B3 card?

XiongZhang (xiong-y-zhang) wrote :

This card isn't marked clearly as B3.
Please see the attached picture for WP2 B3 card

tags: added: blocks-hwcert-enablement
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux (Ubuntu):
status: New → Confirmed
XiongZhang (xiong-y-zhang) wrote :

updated firmaware:
http://permalink.gmane.org/gmane.linux.bluez.kernel/37580

kernel v3.10 for USB interface BT:

  commit dffd30ee9619ccd7153f1861ba0436bbc4400f36
  Author: Tedd Ho-Jeong An <email address hidden>
  Date: Fri Apr 19 09:57:43 2013 -0700

    Bluetooth: Add support for Intel Bluetooth device [8087:07dc]

One fix in v3.11
    commit 53e21fbc288218a423959f878c86471a0e323a9a
    Author: Johan Hedberg <email address hidden>
    Date: Sat Jul 27 14:11:14 2013 -0500

    Bluetooth: Fix calling request callback more than once

Hcitool for UART interface BT:
http://git.kernel.org/?p=bluetooth/bluez.git;a=commit;h=8d25f9528b1ffb58c7c110b9cd06b1d88af5b697

http://git.kernel.org/?p=bluetooth/bluez.git;a=commit;h=4a3f496862c30d5373f1651c093951a5a42929a4

XiongZhang (xiong-y-zhang) wrote :

the latest firmware with revision 2E land into linux-firmware tree.
https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git

there are two commits:
1.
commit 3fe01af27849c45c36c4c88eab8e24ddfeae307e
Author: Tedd Ho-Jeong An <email address hidden>
Date: Thu Aug 22 17:49:32 2013 -0700

    Fix filename for Intel Bluetooth firmware

2.
commit 74c9a8ceb4fe9d0491dc6b9859766e5a66c0c96c
Author: Tedd Ho-Jeong An <email address hidden>
Date: Thu Aug 22 17:49:29 2013 -0700

    linux-firmware: update Intel Bluetooth firmware patch file

Tim Gardner (timg-tpi) on 2013-09-12
Changed in linux (Ubuntu):
assignee: nobody → Tim Gardner (timg-tpi)
status: Confirmed → In Progress
Changed in linux (Ubuntu Saucy):
status: In Progress → Fix Committed
information type: Private → Public
no longer affects: linux-lts-saucy (Ubuntu Saucy)
Anthony Wong (anthonywong) wrote :

lts-saucy kernel nor the linux-firmware in Precise have the necessary firmware files:

ibt-hw-37.7.10-fw-1.0.2.3.d.bseq
ibt-hw-37.7.10-fw-1.80.2.3.d.bseq
ibt-hw-37.7.bseq

They should be added to make bluetooth work in 12.04 + Saucy kernel.

Tim Gardner (timg-tpi) wrote :

I'm going to add the Intel bluetooth files to linux-firmware.

Changed in linux-lts-saucy (Ubuntu Precise):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → Won't Fix
Changed in linux-lts-saucy (Ubuntu):
status: New → Invalid
Changed in linux (Ubuntu Precise):
status: New → Invalid
Changed in linux-firmware (Ubuntu Precise):
status: New → Fix Committed
Changed in linux-firmware (Ubuntu):
status: New → Fix Released
Tim Gardner (timg-tpi) on 2013-11-21
Changed in linux (Ubuntu Saucy):
status: Fix Committed → Invalid
Changed in linux (Ubuntu):
status: Fix Committed → Invalid

Hello Yingying, or anyone else affected,

Accepted linux-firmware into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/linux-firmware/1.79.9 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Tim Chen (timchen119) wrote :

Both 7260 and 3160 bluetooth works on precise-proposed/linux-firmware 1.79.9.

Test kernel was precise-updates/linux-image-generic-lts-saucy/3.11.0-13-generic kernel

tags: added: verification-done

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-firmware - 1.79.9

---------------
linux-firmware (1.79.9) precise; urgency=low

  * Add Intel bluetooth files
    linux-firmware: Add firmware patch file for Intel Bluetooth device(3160)
    linux-firmware: update Intel Bluetooth firmware patch file
    Add Intel Bluetooth firmware patch files
    -LP: #1011423

linux-firmware (1.79.8) precise-proposed; urgency=low

  * Add firmware files for QCA9564(Aphrodite)
    -LP: #1245345
 -- Tim Gardner <email address hidden> Thu, 21 Nov 2013 09:41:21 -0700

Changed in linux-firmware (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in intel:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers