installation-report-generator doesn't support 10.04 (alpha2)

Bug #515142 reported by Jérôme Maeder
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Installation Report Generator
New
Undecided
Unassigned

Bug Description

After installation of a Ubuntu 10.04 (alpha2), I tried to report my installation config by choosing the "Auto-detect" option in the menus.

Unfortunately, I got the following exception during the execution of the program from a console:

Exception in thread Thread-1:
Traceback (most recent call last):
  File "/usr/lib/python2.6/threading.py", line 527, in __bootstrap_inner
    self.run()
  File "/usr/share/installation-report-generator/plugins/UbuntuItWiki.py", line 149, in run
    self.__get_the_page()
  File "/usr/share/installation-report-generator/plugins/UbuntuItWiki.py", line 141, in __get_the_page
    codename = releases[self.hwconfig.release]
KeyError: '10.04'

Are the alpha version of ubuntu supposed to be supported?

Regards,

Jérome

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers