Exporting EPS creates a too-wide picture

Bug #166892 reported by Bug Importer on 2005-08-26
0
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Unassigned

Bug Description

The following picture looks fine when viewing in Inkscape (the
pictures was generated by CMAP 0.14 using the GD::SVG module).

But when it is exported, the text on some of the scales is pushed too
far out creating an extra-wide picture.

You can contact me via: schibeci at cbbc dot murdoch dot edu dot
au

Bug Importer (bug-importer) wrote :

Works fine for me with CVS version. Please attach the EPS
file too.

Chukharevv (chukharevv) wrote :

I can confirm that the problem still exists in 0.43 with
the file attached by the originator.

In addition, I have a file which produces lines outside of
the graph when saved as eps (inkscape-0.43 shows the svg
file correctly). The file was created with gnumeric-1.6.3,
it contains 201 points, but the x scale was changed to show
only first 25 points.

My system is FreeBSD 6.1-STABLE, I use ggv-2.12.0 and
evince-0.5.3 to see the saved eps files.

Chukharevv (chukharevv) wrote :

Well, I just upgraded inkscape to version 0.44.
It is a bit better: my file is saved as eps file
with the expected sizes, but a line continues to the
page boarder, not ending at the edge of the graph canvas.

The file of the bug report originator is saved as eps in
the same very wide page with many Y scale text colomns as
older versions did.

BTW, I cannot attach files to this bug report, is it
possible at all?

Rwst (rwst) wrote :

it should be possible if you are logged in, and you are. can
you put your files onto a web page and give the URI? if not,
we have no problem if you open a new report (where I'm sure
you can upload but please do not forget the little checkbox).

Chukharevv (chukharevv) wrote :

My files:
http://h33.erkki.ton.tut.fi/~chu/tmp/Book2.svg
http://h33.erkki.ton.tut.fi/~chu/tmp/Book2.eps

EPS of the originator's file:
http://h33.erkki.ton.tut.fi/~chu/tmp/z0RLz8KHp.eps
(check how far it goes to the right...)

Can it be that I need to join the project to attach files?

JiHO (jiho) wrote :

Originator: NO

The problem is gone for me on a recent SVN, Inkscape produces correct EPS,
PS and PDF for the original submitter file (viewed with ggv, preview or
adobe reader). I cannot get the other files from chukharevv. I guess the
server is no more. I assume this is fixed and close the bug. I emailed the
orginal submitter and will reopen the bug if necessary.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments