Can't open .eps file.

Bug #166457 reported by Murrayc-users on 2005-04-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
Unassigned

Bug Description

When attempting to open the attached .eps file,
Inkscape (version .40) shows an error dialog with
"Failed to load the requested file
/home/murrayc/sigi_vk_201.eps".

Murrayc-users (murrayc-users) wrote :
Praedor (praedor) wrote :

I am unable to open ANY eps file. I have eps files exported
by OpenOffice, some of these I have converted using
eps2eps. No matter, there is not an eps on my system that
inkscape can open. Every single one of these eps files
displays fine in gv and every single one prints perfectly. In
every case inkscape gives me a variation of this for every
attempted eps I try to open:

pstoedit: version 3.33 / DLL interface 108 (build Jul 31 2004 -
release build) : Copyright (C) 1993 - 2003 Wolfgang Glunz
Warning: some types of raster images in the input file cannot
be converted if the output is sent to standard output
Interpreter finished. Return status 0
/usr/share/inkscape/extensions/sk2svg.sh: line
9: /home/praedor/tmp/sk2svg.15462/sk2svg15462.svg: No
such file or directory
Extension::Script: Unknown error for pclose
: Success
/tmp/ink_ext_Z6vgt9:1: parser error : Document is empty

^
/tmp/ink_ext_Z6vgt9:1: parser error : Start tag expected, '<' not
found

^

** (inkscape:15349): CRITICAL **: void
sp_document_set_uri(SPDocument*, const gchar*): assertion
`document != NULL' failed

** (inkscape:15349): CRITICAL **: void
sp_document_set_uri(SPDocument*, const gchar*): assertion
`document != NULL' failed

** (inkscape:15349): CRITICAL **: void
sp_document_set_uri(SPDocument*, const gchar*): assertion
`document != NULL' failed

Peter Moulder (pjrm) wrote :

The attached sigi_vk_201.eps file seems to be corrupt:
ghostscript gives an error for it. murrayc, can you give an
example file that isn't corrupt?

praedor: Do you have sketch/skencil and ghostscript
installed ? (They need to be installed, as well as
pstoedit.) What version of inkscape are you using?

Bug Importer (bug-importer) wrote :

EPS isn't even listed as an optional file format under open
or import. If I choose one by displaying 'all files' then I
get the same error.

Bryce Harrington (bryce) wrote :

Possibly this is using ill2svg.pl to do the conversion.
However, ill2svg.pl is a really primitive converter.

I recommend importing the EPS files into Scribus and then
saving as SVG. Chances are good that Inkscape would be able
to read them from there.

Recommended solution to this bug is to replace ill2svg.pl
with a better pdf parser such as the one from Scribus.

Duplicate of bug 1114254

I will copy this to the other one as it lists ghost script
as well. Dropping this to 3 as a duplicate

praedor: Do you have sketch/skencil and ghostscript
installed ? (They need to be installed, as well as
pstoedit.)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.