Comment 39 for bug 992124

su_v (suv-lp) wrote :

Alex Valavanis wrote on 2013-03-14:
> Dropped the ancient gcc version check and started fixing a
> load of the broken forward declarations in lp:inkscape r12203.

Now compiler version check fails later on in configure:

(…)
checking for CAIRO_USER_FONTS... yes
../configure: line 22142: test: -gt: unary operator expected
checking for INKSCAPE... yes
(…)

Looks as if this test in 'configure.ac' fails (>= r12203):

| dnl ******************************
| dnl Unconditional dependencies
| dnl ******************************
|
| dnl sigc++-2.0 >= 2.0.12: using "visit_each" not available in 2.0.10
| if test $cc_vers_major -gt 3; then
| min_sigc_version=2.0.12
| else
| min_sigc_version=2.0.11
| fi