Activity log for bug #992124

Date Who What changed Old value New value Message
2012-04-30 18:48:56 su_v bug added bug
2012-05-01 15:04:46 su_v description Follow-up report to Bug #889172 “Compile failure (clang): "variable length array" errors in box3d.cpp” <https://bugs.launchpad.net/inkscape/+bug/889172> Rationale: - «clang support is a good thing» <http://thread.gmane.org/gmane.comp.graphics.inkscape.devel/36760/focus=36767> - OS X is migrating from GCC to CLANG (latest Xcode versions >= 4.2 no longer include Apple's GCC at all). It might be desirable to support building Inkscape using the system compiler on latest OS X versions (compiling Inkscape with custom GCC versions can cause known compatibility issues because the C++ libraries are built with a different compiler version [1]). Drawbacks: - Missing OpenMP support (?) Current status: Even though most of the reported 'non-POD element type' issues have been fixed in current trunk (and backported to 0.48.x), Inkscape still fails to build with clang: 1) autotools - configure.ac: configure fails The check for the compiler version has 'gcc version' hardcoded and fails with clang. [2] 2) unsolved 'variable length array of non-POD element type' errors - src/2geom/basic-intersection.cpp - src/2geom/solve-bezier-parametric.cpp 3) blocker: failure to compile 'src/color-profile.cpp' <http://www.graphicall.org/ftp/ideasman42/inkscape_clang.html> «I think the problem is that ColorProfileImpl should be defined in the Inkscape namespace instead of in the global namespace, so that it matches its declaration in color-profile.h. The code has an using declaration that pulls ColorProfileImpl into the global namespace and it looks like GCC then allows defining the type in the scope of the using declaration, but I doubt whether this is standards conforming.» [3] Test system: OS X 10.7.2, MacPorts 2.0.4 (up-to-date) Inkscape 0.48+devel r11297 Clang versions tested: - Apple clang version 3.0 (tags/Apple/clang-211.12) (based on LLVM 3.0svn) - clang version 3.0 (tags/RELEASE_30/final) (MacPorts) - clang version 3.1 (branches/release_31 155781) (MacPorts) --- [1] <http://wiki.inkscape.org/wiki/index.php/FAQ#On_Linux.2C_Inkscape_crashes_with_.22invalid_pointer.22_message> [2] <http://trac.macports.org/ticket/31492> <http://fink.cvs.sourceforge.net/fink/dists/10.7/stable/main/finkinfo/graphics/inkscape.info?view=markup#l104> [3] <http://thread.gmane.org/gmane.comp.graphics.inkscape.devel/37024/focus=37060> Follow-up report to Bug #889172 “Compile failure (clang): "variable length array" errors in box3d.cpp” <https://bugs.launchpad.net/inkscape/+bug/889172> Rationale: - «clang support is a good thing» <http://thread.gmane.org/gmane.comp.graphics.inkscape.devel/36760/focus=36767> - OS X is migrating from GCC to CLANG (latest Xcode versions >= 4.2 no longer include Apple's GCC at all). It might be desirable to support building Inkscape using the system compiler on latest OS X versions (compiling Inkscape with custom GCC versions can cause known compatibility issues because the C++ libraries are built with a different compiler version [1]). Drawbacks: - Missing OpenMP support (Clang 3.x) Current status: Even though most of the reported 'non-POD element type' issues have been fixed in current trunk (and backported to 0.48.x), Inkscape still fails to build with clang: 1) autotools - configure.ac: configure fails with > checking GNU compiler version... > configure: error: gcc >= 3.0 is needed to compile inkscape The check for the compiler version has 'gcc version' hardcoded and fails with clang. [2] 2) unsolved 'variable length array of non-POD element type' errors - src/2geom/basic-intersection.cpp - src/2geom/solve-bezier-parametric.cpp 3) blocker: failure to compile 'src/color-profile.cpp' <http://www.graphicall.org/ftp/ideasman42/inkscape_clang.html> «I think the problem is that ColorProfileImpl should be defined in the Inkscape namespace instead of in the global namespace, so that it matches its declaration in color-profile.h. The code has an using declaration that pulls ColorProfileImpl into the global namespace and it looks like GCC then allows defining the type in the scope of the using declaration, but I doubt whether this is standards conforming.» [3] Test system: OS X 10.7.2, MacPorts 2.0.4 (up-to-date) Inkscape 0.48+devel r11297 Clang versions tested: - Apple clang version 3.0 (tags/Apple/clang-211.12) (based on LLVM 3.0svn) - clang version 3.0 (tags/RELEASE_30/final) (MacPorts) - clang version 3.1 (branches/release_31 155781) (MacPorts) --- [1] <http://wiki.inkscape.org/wiki/index.php/FAQ#On_Linux.2C_Inkscape_crashes_with_.22invalid_pointer.22_message> [2] <http://trac.macports.org/ticket/31492>     <http://fink.cvs.sourceforge.net/fink/dists/10.7/stable/main/finkinfo/graphics/inkscape.info?view=markup#l104> <http://www.freebsd.org/cgi/query-pr.cgi?pr=161204> <http://clang.debian.net/status.php?version=3.0&key=WRONG_GCC_ASSUMPTION> [3] <http://thread.gmane.org/gmane.comp.graphics.inkscape.devel/37024/focus=37060>
2012-09-04 05:17:29 ScislaC inkscape: status New Confirmed
2012-10-05 16:58:30 Daniel Macks bug added subscriber Daniel Macks
2013-02-12 18:28:28 Samuel Chase attachment added variable-length-array-error.diff https://bugs.launchpad.net/inkscape/+bug/992124/+attachment/3525579/+files/variable-length-array-error.diff
2013-02-12 18:42:32 Samuel Chase bug added subscriber Samuel Chase
2013-02-12 19:48:42 Samuel Chase attachment added clang-build-errors.log https://bugs.launchpad.net/inkscape/+bug/992124/+attachment/3525680/+files/clang-build-errors.log
2013-02-12 20:24:00 Samuel Chase attachment added clangscape-backtrace.log https://bugs.launchpad.net/inkscape/+bug/992124/+attachment/3525730/+files/clangscape-backtrace.log
2013-02-12 20:26:55 Samuel Chase attachment added color-profile.patch https://bugs.launchpad.net/inkscape/+bug/992124/+attachment/3525731/+files/color-profile.patch
2013-02-13 08:44:44 su_v attachment added 992124-clang-src-r12120.diff https://bugs.launchpad.net/inkscape/+bug/992124/+attachment/3526196/+files/992124-clang-src-r12120.diff
2013-02-13 08:54:25 su_v attachment added 992124-clang-osx-quartz-r12121.diff https://bugs.launchpad.net/inkscape/+bug/992124/+attachment/3526198/+files/992124-clang-osx-quartz-r12121.diff
2013-02-13 09:06:50 su_v attachment added 2013-02-13-mp-quartz-clang-12121.txt https://bugs.launchpad.net/inkscape/+bug/992124/+attachment/3526205/+files/2013-02-13-mp-quartz-clang-12121.txt
2013-02-13 10:36:28 su_v attachment added 992124-clang-basic-r12121.diff https://bugs.launchpad.net/inkscape/+bug/992124/+attachment/3526312/+files/992124-clang-basic-r12121.diff
2013-02-13 17:56:52 Samuel Chase attachment added clang-unsigned-comparison-warnings.diff https://bugs.launchpad.net/inkscape/+bug/992124/+attachment/3526907/+files/clang-unsigned-comparison-warnings.diff
2013-02-13 18:20:35 Samuel Chase attachment removed clang-unsigned-comparison-warnings.diff https://bugs.launchpad.net/inkscape/+bug/992124/+attachment/3526907/+files/clang-unsigned-comparison-warnings.diff
2013-02-13 18:21:01 Samuel Chase attachment added uint-comparison-warn-and-memleaks.diff https://bugs.launchpad.net/inkscape/+bug/992124/+attachment/3526940/+files/uint-comparison-warn-and-memleaks.diff
2013-02-13 18:41:44 jazzynico inkscape: status Confirmed In Progress
2013-02-13 18:41:44 jazzynico inkscape: assignee Samuel Chase (samebchase)
2013-02-13 20:06:14 Samuel Chase bug watch added http://trac.macports.org/ticket/31492
2013-02-13 20:43:23 su_v attachment added 992124-uint-comparison-warn-and-memleaks-r12122.diff https://bugs.launchpad.net/inkscape/+bug/992124/+attachment/3527326/+files/992124-uint-comparison-warn-and-memleaks-r12122.diff
2013-02-14 03:28:31 Samuel Chase attachment added r12114.diff https://bugs.launchpad.net/inkscape/+bug/992124/+attachment/3527800/+files/r12114.diff
2013-03-07 09:24:56 su_v attachment added 2013-03-06-mp-quartz-clang-12175-201806-warnings-debug-build.txt https://bugs.launchpad.net/inkscape/+bug/992124/+attachment/3561784/+files/2013-03-06-mp-quartz-clang-12175-201806-warnings-debug-build.txt
2013-03-13 22:48:34 su_v bug watch added http://llvm.org/bugs/show_bug.cgi?id=7798
2013-03-15 01:17:19 Alex Valavanis attachment added Build log (2013-03-15) https://bugs.launchpad.net/inkscape/+bug/992124/+attachment/3574771/+files/build.log
2013-03-15 08:11:12 su_v attachment added 2013-03-15-mp-quartz-gtk3-12206.txt https://bugs.launchpad.net/inkscape/+bug/992124/+attachment/3575183/+files/2013-03-15-mp-quartz-gtk3-12206.txt
2013-03-15 18:51:13 Alex Valavanis attachment added Build log (2013-01-15) [cleaned unused-arguments] https://bugs.launchpad.net/inkscape/+bug/992124/+attachment/3576154/+files/build.log
2013-04-21 10:21:19 su_v inkscape: status In Progress Fix Committed
2013-04-21 10:21:19 su_v inkscape: milestone 0.49
2015-02-21 02:55:16 Bryce Harrington inkscape: status Fix Committed Fix Released