character coding error in emf import

Bug #990083 reported by Nagy Tamás on 2012-04-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Unassigned

Bug Description

I have an emf file exported from starUML and contains a diagram. It contains a number of text elements. If one element contains national characters (like á, é, ó, etc.) than inkscape import drops that text element while importing. Inkscape imports every other element, only text elements with national characters inside are missing.

If I import the file to a different app (eg. word), it displays it correctly.

Inkscape version is 0.48.1
Opsys: Windows 7 ultimate

Nagy Tamás (bigtom) wrote :
Alvin Penner (apenner) wrote :

the text problem is not reproduced on Windows 7, Inkscape 0.48.3.1-1.exe
could you try this version? it is available at http://sourceforge.net/projects/inkscape/files/inkscape/0.48.3.1/
- unfortunately there are some other problems, which are still present in a recent development build, namely missing ellipses.

su_v (suv-lp) wrote :

> Inkscape imports every other element, only text elements
> with national characters inside are missing.

Duplicate of bug #612882?

Bug #612882 “Fail to import non-ascii texts from wmf files”
<https://bugs.launchpad.net/inkscape/+bug/612882>

tags: added: emf importing win32

Hello

Text problem is solved in 0.48.3.1-1 and i also confirm the missing
eclipses.
Thank you
Tom

2012.04.28. 2:19 keltezéssel, Alvin Penner írta:
> the text problem is not reproduced on Windows 7, Inkscape 0.48.3.1-1.exe
> could you try this version? it is available at http://sourceforge.net/projects/inkscape/files/inkscape/0.48.3.1/
> - unfortunately there are some other problems, which are still present in a recent development build, namely missing ellipses.
>

Nagy Tamás (bigtom) wrote :

Hello

The character problem is fixed in 0.48.3.1-1, so it is possible a duplicate.
Thank you
Tom

2012.04.28. 4:11 keltezéssel, ~suv írta:
>> Inkscape imports every other element, only text elements
>> with national characters inside are missing.
> Duplicate of bug #612882?
>
> Bug #612882 “Fail to import non-ascii texts from wmf files”
> <https://bugs.launchpad.net/inkscape/+bug/612882>
>
> ** Tags added: emf importing win32
>

Kris (kris-degussem) wrote :

Thanks for the update.
Marked as duplicate.

Alvin Penner (apenner) wrote :

just a final follow-up...
The missing ellipses were caused by some clip regions that were applied when they should not have been applied.

fix committed to bzr rev 11307

Changed in inkscape:
status: New → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments