Zoom to entire drawing doesn't work correctly (cached visual bbox info)

Bug #970370 reported by Alfred Bergkemper on 2012-03-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
Alvin Penner

Bug Description

Hello,

when i delete a part of a drawing and press '4' to zoom to the entire drawing there is no reaction.

I first have do change some text, add an object etc. before the '4'-key works as usually.

I'm working with Inkscape 0.48+devel r11109, windows xp with all updates.

su_v (suv-lp) wrote :

Testing archived builds (on Mac OS X 10.5.8 (32bit Intel):
- not reproduced with Inkscape 0.48+devel r10614
- reproduced with Inkscape 0.48+devel r10620

Apparently also due to the caching of the visual bounding box introduced in r10618:
<http://thread.gmane.org/gmane.comp.graphics.inkscape.devel/37154/focus=37301>

Related reports:
bug #960986 (filter effects region),
bug #955141 (visual bounding box of clipped/masked objects)

tags: added: regression selection zoom
Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
summary: - Zoom to entire drawing doesn't work correct
+ Zoom to entire drawing doesn't work correctly (cached visual bbox info)
jazzynico (jazzynico) wrote :

Reproduced on Windows XP, Inkscape trunk revision 11652.

Changed in inkscape:
status: Confirmed → Triaged
su_v (suv-lp) on 2012-09-24
Changed in inkscape:
milestone: none → 0.49
Alvin Penner (apenner) wrote :

fix committed to rev 12006

Changed in inkscape:
status: Triaged → Fix Committed
su_v (suv-lp) on 2013-01-01
Changed in inkscape:
assignee: nobody → Alvin Penner (apenner)
milestone: 0.49 → none
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers