epson print filter fails when printing

Bug #964726 reported by William Kray on 2012-03-25
32
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Unassigned

Bug Description

OS: arch linux 64bit
Inkscape version: 0.48.3.1 r9886
Printer: Epson NX430 small-in-one
Avasys Epson Driver: epson-inkjet-printer-201105w 1.0.0

printing from Inkscape in any output format (SVG or Bitmap) fails. CUPS is called correctly, but the job immediately stops, and the message is as follows:

stopped
"/opt/epson-inkjet-printer-201105w/cups/lib/filter/epson_inkjet_printer_filter failed"

this happens regardless of the documents contents. it does not happen when using a generic CUPS-PDF virtual printer. I don't have any problems printing from any other programs on my system.

jazzynico (jazzynico) on 2012-04-04
tags: removed: arch avasys epson fail filter
Changed in inkscape:
importance: Undecided → Medium
William Kray (william-kray) wrote :

tested with Ubuntu Precise Pangolin installed in Virtualbox, printing goes to the print queue successfully, but printing never begins. no error messages appear for as long as i have waited (about a minute and a half).

Inkscape 0.48.3.1 r9886

peterthevicar (peterbcs) wrote :

I have a similar problem. Print to an Epson Stylus Office B42WD queue. The CUPS status stays at "Rendering Complete" but no printing actually happens. CUPS test page for the queue works fine. I exported the drawing to a bitmap, inserted that into a LibreOffice document and printed to the same printer with no problem. It's a workaround as long as you don't use Inkscape too often.

12.04 Precise Pangolin, inkscape 0.48.3.1-1ubuntu1

William Kray (william-kray) wrote :

agreed, all other programs seem handle printing properly. on my arch machine, the problems started when the libpng and libtiff packages were updated. many programs needed to be updated to work properly with the updated libs- among them was Inkscape. there must be some communication problem with the driver regarding those libs.

I wish I could use the workaround more regularly but I use Inkscape for work and it takes too long. it still works on my Ubuntu 10.04 installation, so I'm using that for now... but then I also don't have the latest and greatest gimp!

Andy (andy-akw) wrote :

Same problem here under Ubuntu 12.04, but with HP Deskjet F380 printer. Print system just hangs saying 'processing' but nothing happens. Printer works fine with other software. I use a similar work-around: print to file (PDF) rather than the printer, then open the PDF and print that. Still a pain in the backside :(

su_v (suv-lp) wrote :

Which version of GTK+ do you have installed?

Similar to
- Bug #975972 "Inkscape sends jobs with zero page size"
  <https://bugs.launchpad.net/inkscape/+bug/975972>
this could well be another duplicate of
- Bug #998156 'GTK Print dialog sends broken custom page size attribute: "PageSize=Custom.Custom.<width>x<length>"'
  <https://bugs.launchpad.net/bugs/998156>

Betagraphic (betagraphic) wrote :

I cannot print directly from Inkscape. The print job spools then is deleted before it can be printed.
I have an Epson Stylus T22 running under XUBUNTU 11.10

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers