Visual bounding box not updated when changing filter settings

Bug #960986 reported by Yann Papouin on 2012-03-21
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Low
Unassigned

Bug Description

Current trunk, Win32.

In Filter General Settings tab of the Filter Editor dialog, you are able to change general values like Coordinates and Dimensions.
Changing theses values should immediately update the visual bounding box, actually you have to move the object to update it and see the result

description: updated
su_v (suv-lp) wrote :

Happens due to caching of the visual bounding box in trunk, see also
<http://thread.gmane.org/gmane.comp.graphics.inkscape.devel/37154/focus=37301>

tags: added: filters-svg regression selection
Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
su_v (suv-lp) wrote :

Related issue mentioned in bug #955141 (see comment #5 there - similar issue can occur after clipping an object).

jazzynico (jazzynico) wrote :

Reproduced on Windows XP, Inkscape trunk revision 11692.

Changed in inkscape:
status: Confirmed → Triaged
su_v (suv-lp) on 2012-09-24
Changed in inkscape:
milestone: none → 0.49
insaner (insaner) wrote :

same here.

r12268 linux

Alvin Penner (apenner) wrote :

fix committed to rev 12306

Changed in inkscape:
status: Triaged → Fix Committed
jazzynico (jazzynico) on 2013-04-28
Changed in inkscape:
milestone: 0.49 → none
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers