Overlay scrollbars causing input boxes to be small

Bug #946631 reported by Antonio Roberts on 2012-03-04
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Inkscape
Low
John Smith
inkscape (Ubuntu)
Low
Unassigned

Bug Description

I opened up the Document Metadata tab and two of the input boxes are so small you can't see the text being entered. Modifying the height of the tab doesn't resize these boxes (see attached image)

Inkscape version: 1:0.48+devel+11044+30~oneiric1 (Inkscape PPA install on 4th March 2012)

Tags: ui Edit Tag help

Related branches

Antonio Roberts (hellocatfood) wrote :
su_v (suv-lp) wrote :

Related report:
Bug #884368 "unable to edit attributes in Inkscape XML Editor (Ubuntu overlay-scrollbar issues) "
<https://bugs.launchpad.net/inkscape/+bug/884368>
(see comment #12)

tags: added: ui
Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
Alex Valavanis (valavanisalex) wrote :

@John - this seems like something close to your heart! Would you be able to take a look?

Changed in inkscape (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Changed in inkscape:
assignee: nobody → John Smith (john-smithi)
John Smith (john-smithi) wrote :

Committed to trunk r11050.
Multi-line text boxes in Document Metadata should be about 2 lines in height now.

Changed in inkscape:
status: Confirmed → Fix Committed
Changed in inkscape:
milestone: none → 0.49
kroq-gar78 (kroq-gar78) on 2012-03-19
Changed in inkscape (Ubuntu):
assignee: nobody → kroq-gar78 (kroq-gar78)
kroq-gar78 (kroq-gar78) wrote :

Here's the diff between r11050 and 11049 in lp:inkscape.
I downloaded the patch and attached it. Not sure if you want to apply for a Feature Freeze exception or what, so I didn't link lp:inkscape or anything, because then you'd have a new upstream release.

The attachment "Diff between r11050 and r11049 of lp:inkscape to fix this bug" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
tags: added: patch-accepted-upstream
removed: patch
tags: added: backport-proposed patch
removed: patch-accepted-upstream
tags: added: patch-accepted-upstream
removed: patch
kroq-gar78 (kroq-gar78) on 2012-03-20
Changed in inkscape (Ubuntu):
assignee: kroq-gar78 (kroq-gar78) → nobody
Kris (kris-degussem) wrote :

Backported for inkscape 0.48.4 in 0.48.x branch revision 9897.

Changed in inkscape:
milestone: 0.49 → 0.48.4
tags: removed: backport-proposed patch-accepted-upstream
Ted Gould (ted) on 2012-12-17
Changed in inkscape:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package inkscape - 0.48.4-0ubuntu1

---------------
inkscape (0.48.4-0ubuntu1) raring; urgency=low

  * New upstream release (LP: #1091308). Fixes several Ubuntu bugs:
    - Inkscape crashed with SIGSEGV in getObject() (LP: #941317)
    - Inkscape crashed with SIGSEGV in
      Inkscape::Extension::Implementation::Script::effect() (LP: #944077)
    - Inkscape crashed with SIGSEGV in
      Inkscape::Extension::Output::get_extension() (LP: #973174)
    - Overlay scrollbars causing input boxes to be small (LP: #946631)
  * Drop 03_track_libpoppler25_abi_changes.patch: applied upstream
  * Drop 04_track_libpoppler25_abi_changes_colorspace.patch: applied upstream
 -- Alexander Valavanis <email address hidden> Wed, 19 Dec 2012 13:45:59 +0000

Changed in inkscape (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers