Failure to build with GTKMM_DISABLE_DEPRECATED

Bug #943225 reported by Alex Valavanis on 2012-02-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
John Smith

Bug Description

Inkscape fails to build when GTKMM_DISABLE_DEPRECATED is defined.

To reproduce:
* Build using:
make CPPFLAGS+="-DGTKMM_DISABLE_DEPRECATED

This is an essential step towards GTK+3 compliance. We should add the deprecation flag to configure.ac once we manage to build cleanly.

See the attached build log for a list of remaining issues

John Smith (john-smithi) on 2012-03-14
Changed in inkscape:
assignee: nobody → John Smith (john-smithi)
John Smith (john-smithi) wrote :

Commit to trunk r11083.
Refactored and replaced the deprecated Gtk::OptionMenu with a Gtk::ComboBox derived class for the Fill Stroke Style Markers.
Should be functionally the same. Combobox is a few pixels shorter than the OptionMenu.

Inkscape now builds with GTKMM_DISABLE_DEPRECATED.

Changed in inkscape:
status: Triaged → Fix Committed
Alex Valavanis (valavanisalex) wrote :

Great! I've added the deprecation flag to configure.ac in r11084 to ensure that no new deprecated symbol usage can occur.

Changed in inkscape:
milestone: none → 0.49
Bryce Harrington (bryce) on 2015-02-21
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints