Failure to build with GDK_DISABLE_DEPRECATED

Bug #943207 reported by Alex Valavanis on 2012-02-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Alex Valavanis

Bug Description

Inkscape fails to build when GDK_DISABLE_DEPRECATED is defined.

To reproduce:
* Build using:
make CPPFLAGS+="-DGDK_DISABLE_DEPRECATED

This is an essential step towards GTK+3 compliance. We should add the deprecation flag to configure.ac once we manage to build cleanly.

See the attached build log for a list of remaining issues

Related branches

John Smith (john-smithi) wrote :

Committed revision 11284 - Replace deprecated gdk_draw_rgb_image with cairo drawing in sp-color-slider.

Alex Valavanis (valavanisalex) wrote :

Fixed in lp:inkscape r11431 for Gtk+ 2. Once the Gtk+ 3 migration is complete, we can start working on the newly-deprecated symbols.

Changed in inkscape:
assignee: nobody → Alex Valavanis (valavanisalex)
milestone: none → 0.49
status: Triaged → Fix Committed
Alex Valavanis (valavanisalex) wrote :

I have removed the GDK_DISABLE_DEPRECATED flag from configure.ac in lp:inkscape r11435 because our internal copy of GDL uses the deprecated GdkGC API.

The options are:
1. Pull in a load of GTK+2 incompatible changes from upstream and hack them to build against GTK+2.

2. Find our own GTK+2-compatible fix for the GdkGC usage, and then restore the GDK_DISABLE_DEPRECATED flag.

3. Just carry on without the GDK_DISABLE_DEPRECATED flag.

Personally, I favour (2) if there is an easy fix, but not if it involves maintaining a large delta against upstream. (3) is also OK, as long as we are careful to avoid adding new deprecated code.

I'm leaving this bug as "Fix Committed" because all of our own code compiles happily with the flag, and our GTK+ 3 build uses an external copy of GDL. In other words, the deprecated GDK symbol usage in our fork of GDL won't affect our migration to GTK+ 3.

Bryce Harrington (bryce) on 2015-02-21
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints