inkscape crashed with SIGSEGV in getObject()

Bug #941317 reported by Giorgi Gzirishvili on 2012-02-26
36
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Johan Engelen
inkscape (Ubuntu)
Medium
Unassigned

Bug Description

-

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: inkscape 0.48.3-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.93-0ubuntu2
Architecture: amd64
Date: Sun Feb 26 13:09:59 2012
ExecutablePath: /usr/bin/inkscape
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
ProcCmdline: inkscape
SegvAnalysis:
 Segfault happened at: 0x688505 <_ZN8Inkscape11Preferences8_getNodeERKN4Glib7ustringEb+69>: mov (%rdi),%rax
 PC (0x00688505) ok
 source "(%rdi)" (0x100000000) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: inkscape
StacktraceTop:
 SPGradient::rebuildVector() ()
 SPGradient::ensureColors() ()
 SPRGPainter::painter_new(SPPaintServer*, Geom::Matrix const&, Geom::Matrix const&, NRRect const*) ()
 sp_paint_server_painter_new(SPPaintServer*, Geom::Matrix const&, Geom::Matrix const&, NRRect const*) ()
 ?? ()
Title: inkscape crashed with SIGSEGV in SPGradient::rebuildVector()
UpgradeStatus: Upgraded to precise on 2012-02-24 (2 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare vboxusers

Related branches

Giorgi Gzirishvili (giogziro95) wrote :

StacktraceTop:
 getObject (this=0x0) at /usr/include/c++/4.6/bits/locale_facets.h:1077
 SPGradient::rebuildVector (this=0x49de010) at sp-gradient.cpp:1038
 SPGradient::ensureColors (this=0x49de010) at sp-gradient.cpp:1130
 SPRGPainter::painter_new (ps=0x49de010, full_transform=..., bbox=0xa8aad90) at sp-gradient.cpp:1907
 sp_paint_server_painter_new (ps=0x49de010, full_transform=..., parent_transform=..., bbox=0xa8aad90) at sp-paint-server.cpp:108

Changed in inkscape (Ubuntu):
importance: Undecided → Medium
summary: - inkscape crashed with SIGSEGV in SPGradient::rebuildVector()
+ inkscape crashed with SIGSEGV in getObject()
tags: removed: need-amd64-retrace
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in inkscape (Ubuntu):
status: New → Confirmed
Changed in inkscape (Ubuntu):
status: Confirmed → Triaged
Changed in inkscape:
importance: Undecided → High
tags: added: crash
Johan Engelen (johanengelen) wrote :

Any way for me to reproduce it?

Johan Engelen (johanengelen) wrote :

Thanks for the very detailed crash information from which I was able to find the culprit and fix it :-)
rev. 11157

Changed in inkscape:
assignee: nobody → Johan Engelen (johanengelen)
milestone: none → 0.49
status: New → Fix Committed
su_v (suv-lp) on 2012-04-07
tags: added: backport-proposed
Kris (kris-degussem) wrote :

Backported for 0.48.4 in 0.48.x branch in revision 9892.

tags: removed: backport-proposed
Changed in inkscape:
milestone: 0.49 → 0.48.4
Ted Gould (ted) on 2012-12-17
Changed in inkscape:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package inkscape - 0.48.4-0ubuntu1

---------------
inkscape (0.48.4-0ubuntu1) raring; urgency=low

  * New upstream release (LP: #1091308). Fixes several Ubuntu bugs:
    - Inkscape crashed with SIGSEGV in getObject() (LP: #941317)
    - Inkscape crashed with SIGSEGV in
      Inkscape::Extension::Implementation::Script::effect() (LP: #944077)
    - Inkscape crashed with SIGSEGV in
      Inkscape::Extension::Output::get_extension() (LP: #973174)
    - Overlay scrollbars causing input boxes to be small (LP: #946631)
  * Drop 03_track_libpoppler25_abi_changes.patch: applied upstream
  * Drop 04_track_libpoppler25_abi_changes_colorspace.patch: applied upstream
 -- Alexander Valavanis <email address hidden> Wed, 19 Dec 2012 13:45:59 +0000

Changed in inkscape (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers