Build error in text-edit.cpp (older glib/gtk)

Bug #937288 reported by Cafuego on 2012-02-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Alex Valavanis

Bug Description

Inkscape currently fails to build with older gtk and glib libraries on Ubuntu Lucid and Maverick:

  CXX ui/dialog/text-edit.o
ui/dialog/text-edit.cpp:247: warning: unused parameter 'docontent'
ui/dialog/text-edit.cpp: In member function 'SPCSSAttr* Inkscape::UI::Dialog::TextEdit::getTextStyle()':
ui/dialog/text-edit.cpp:502: error: 'combo' was not declared in this scope
ui/dialog/text-edit.cpp: At global scope:
ui/dialog/text-edit.cpp:645: warning: unused parameter 'widget'
make[4]: *** [ui/dialog/text-edit.o] Error 1

Full build logs are available at:

https://launchpad.net/~cafuego/+archive/inkscape/+build/3224708/+files/buildlog_ubuntu-maverick-amd64.inkscape_0.49%7Edevel%2B11002%2B6%7Emaverick1_FAILEDTOBUILD.txt.gz

https://launchpad.net/~cafuego/+archive/inkscape/+build/3224709/+files/buildlog_ubuntu-maverick-i386.inkscape_0.49%7Edevel%2B11002%2B6%7Emaverick1_FAILEDTOBUILD.txt.gz

https://launchpad.net/~cafuego/+archive/inkscape/+build/3224689/+files/buildlog_ubuntu-lucid-amd64.inkscape_0.49%7Edevel%2B11002%2B6%7Elucid1_FAILEDTOBUILD.txt.gz

https://launchpad.net/~cafuego/+archive/inkscape/+build/3224690/+files/buildlog_ubuntu-lucid-i386.inkscape_0.49%7Edevel%2B11002%2B6%7Elucid1_FAILEDTOBUILD.txt.gz

Alex Valavanis (valavanisalex) wrote :

Should be an easy fix. Just a case of a typo in the conditional build.

Changed in inkscape:
assignee: nobody → Alex Valavanis (valavanisalex)
importance: Undecided → High
status: New → In Progress
Alex Valavanis (valavanisalex) wrote :

Fixed in lp:inkscape r11004 hopefully.

I don't have a convenient maverick/lucid build environment on this machine, so please let me know if the problem persists.

Changed in inkscape:
status: In Progress → Fix Released
Kris (kris-degussem) on 2012-02-21
Changed in inkscape:
milestone: none → 0.49
su_v (suv-lp) wrote :

@Kris - I don't think this needs a milestone, since the issue never occurred in a released version: so far, we don't milestone regressions reported for current trunk only and fixed there as well - the reports are simply closed as 'Fix Released'.

AFAIU this does not affect the 0.48.x branch and needs not to be backported either.

Changed in inkscape:
milestone: 0.49 → none
Alex Valavanis (valavanisalex) wrote :

Yep, this was only introduced in trunk with the new text edit dialog. No need to backport.

Cafuego (cafuego) wrote :

Confirmed fixed in 11004. Took a little while to check because Launchpads build daemons were failing for unrelated reasons, it seems. Thanks Alex :-)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers