Build with dbusapi enabled fails after updating from 10958 to 10963

Bug #931003 reported by su_v on 2012-02-12
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Alex Valavanis

Bug Description

Build fails after updating from 10958 to 10963:

  CXX extension/dbus/document-interface.o
../../src/extension/dbus/document-interface.cpp: In function ‘gchar* finish_create_shape(DocumentInterface*, GError**, Inkscape::XML::Node*, gchar*)’:
../../src/extension/dbus/document-interface.cpp:239: error: ‘Inkscape::DocumentUndo’ has not been declared
../../src/extension/dbus/document-interface.cpp: In function ‘gboolean dbus_call_verb(DocumentInterface*, int, GError**)’:
../../src/extension/dbus/document-interface.cpp:270: error: ‘Inkscape::DocumentUndo’ has not been declared
../../src/extension/dbus/document-interface.cpp: In function ‘gboolean document_interface_call_verb(DocumentInterface*, gchar*, GError**)’:
../../src/extension/dbus/document-interface.cpp:383: error: ‘Inkscape::DocumentUndo’ has not been declared
../../src/extension/dbus/document-interface.cpp: In function ‘gchar* document_interface_image(DocumentInterface*, int, int, gchar*, GError**)’:
../../src/extension/dbus/document-interface.cpp:542: error: ‘Inkscape::DocumentUndo’ has not been declared
../../src/extension/dbus/document-interface.cpp: In function ‘gchar* document_interface_node(DocumentInterface*, gchar*, GError**)’:
../../src/extension/dbus/document-interface.cpp:559: error: ‘Inkscape::DocumentUndo’ has not been declared
../../src/extension/dbus/document-interface.cpp: At global scope:
../../src/extension/dbus/document-interface.cpp:622: warning: unused parameter ‘error’
../../src/extension/dbus/document-interface.cpp: In function ‘gboolean document_interface_load(DocumentInterface*, gchar*, GError**)’:
../../src/extension/dbus/document-interface.cpp:951: error: ‘Inkscape::DocumentUndo’ has not been declared
../../src/extension/dbus/document-interface.cpp: At global scope:
../../src/extension/dbus/document-interface.cpp:958: warning: unused parameter ‘error’
../../src/extension/dbus/document-interface.cpp:971: warning: unused parameter ‘error’
../../src/extension/dbus/document-interface.cpp: In function ‘void document_interface_resume_updates(DocumentInterface*, GError**)’:
../../src/extension/dbus/document-interface.cpp:1071: error: ‘Inkscape::DocumentUndo’ has not been declared
make[3]: *** [extension/dbus/document-interface.o] Error 1
make[2]: *** [all] Error 2
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Tested systems (trunk configured with '--enable-dbusapi'):
- OS X 10.7.2, Apple llvm-gcc-4-2 (GTK+/X11 2.24.10)
- Mac OS X 10.5.8, Apple GCC 4.2.1 (GTK+/X11 2.24.4)

Note: Build succeeds if configured without dbus API, tested with
- OS X 10.7.2, Apple llvm-gcc-4.2.1, FSF GCC 4.6.2 (GTK+/X11 2.24.10)
- Mac OS X 10.5.8, Apple GCC 4.2.1 (GTK+/Quartz 2.24.10)

Changed in inkscape:
status: New → In Progress
importance: Undecided → High
Alex Valavanis (valavanisalex) wrote :

Fixed (hopefully) in lp:inkscape r10965. Please let me know if the problem is still there

Changed in inkscape:
status: In Progress → Fix Released
su_v (suv-lp) wrote :

@Alex - both builds succeeded without error after updating to 10965. Thx for the quick response :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers